Page 1 of 2 12 LastLast
Results 1 to 10 of 13
Discuss 10.4.10 update/install guide by profit42.com at the Using Leopard - Hackint0sh.org; Hi, I just wrote a 10.4.10 update/install guide. i wrote it quite fast and out ...
  1. #1
    Professional Array

    Join Date
    Aug 2006
    Posts
    84
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    13

    Arrow 10.4.10 update/install guide by profit42.com

    Hi,

    I just wrote a 10.4.10 update/install guide. i wrote it quite fast and out of my head cause I destroyed my 10.4.10 install yesterday, so could you please check it?

    You can find it here: http://coolblog.profit42.com/2007/06...boot-intelamd/

    And btw: Thanks to all developers, without this wasn't possible!



  2. #2
    Professional Array

    Join Date
    Mar 2007
    Posts
    61
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    11

    Default

    well, the easiest way to update to 10.4.10 for me was :

    apply Apple combo update (don't reboot)
    replace kernel with patched kernel from IRC
    install R3D3 in extensions
    replace AppleSMBios.kext with previously working one

    (optional)
    reinstall audio kext (for me, ALC883)
    fix spplatform plugin in ASP using previously working folder (so the hardware tab in ASP displays info correctly)

    done on GA945GM-S2 mobo, nvidia PCIe card. Everything works great this way.

  3. #3
    Senior Professional Array neonkoala's Avatar

    Join Date
    Jul 2006
    Posts
    277
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    23

    Default

    I would try it but I'm too lazy to open Firefox just to browse a website which refuses to adapt to me. Poor web design by the host (not aimed at the poster btw).

  4. #4
    Professional Array

    Join Date
    Aug 2006
    Posts
    84
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    13

    Default

    Quote Originally Posted by neonkoala View Post
    I would try it but I'm too lazy to open Firefox just to browse a website which refuses to adapt to me. Poor web design by the host (not aimed at the poster btw).
    I block IE access cause:

    1) I'm not going to write non validating CSS just because IE isn't supporting validating CSS.

    2) IE users mostly aren't prepared for the content on my site. I want to show bluesnarfing tutorials to people who don't know what Firefox is. it's for their own safety.

    3) I couldn't access microsoft connect with Firefox some time ago and I had to use IE and since then I hate that extraordinary slow browser.... (especially in Vista on an old computer...)



    But let's get back to the topic: Thanks gotoh, I added your instructions as an alternative.

  5. #5
    Professional Array

    Join Date
    Mar 2007
    Posts
    61
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    11

    Default

    you're welcome !
    you should warn that this method works fine as long as your hardware don't require specific patched extensions.

    Also I forgot to mention to set correct permissions to the files that require it (kernel, and extensions like R3D3...) I use a script for it, so I don't have to type in terminal each time...


  6. #6
    Professional Array

    Join Date
    Mar 2007
    Posts
    61
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    11

    Default

    here is the content of the script I'm using, anyone may use it, or paste these lines in postflight scripts in .pkg / .mpkg for safe permissions fix and caches removal before reboot !!

    Code:
    sudo chown -R root:wheel /System/Library/Extensions/
    sudo chmod -R 755 /System/Library/Extensions/
    sudo touch /System/Library/Extensions
    sudo rm -R /System/Library/Extensions.kextcache
    sudo rm -R /System/Library/Extensions.mkext
    sudo rm -R /System/Library/Caches/com.apple.kernelcaches
    sudo diskutil repairPermissions /

  7. #7
    Professional Array

    Join Date
    Aug 2006
    Posts
    84
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    13

    Default

    Thanks again! I added the lines as fast as I could cuase repairing permissions is indeed quite important.

    EDIT: I destroyed my good old ethernet card, don't know how, but it isn't working anymore (in vista, osx and linux) and it aren't the drivers... (I'm typing this from my dads laptop) If I don't reply to things tomorrow, that's the reason....
    Last edited by profit42; 06-26-2007 at 12:26 AM.

  8. #8
    Newbie Array

    Join Date
    Apr 2007
    Posts
    5
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Well, it worked. Running a Dell XPS M170 with Pentium M (SSE2). Only weird thing is the System Profilier crashing when I run it. All other apps work.

  9. #9
    Newbie Array

    Join Date
    Jul 2006
    Posts
    3
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Hi all,

    after update I had to resotre ATINDRV.kext and IONetworkingFamily to make ATI X1600 and Intel PRO 1000 work again.

    --
    Regards
    fingerr
    OSx86 (10.4.10/8.8.1)@Toshiba Tecra A7-108, T2300, X1600 (71c51002) QE/CI , Intel HDA ALC861 (AppleAzalia), 2048 RAM, Intel PRO/1000, 120GB SATA, Toshiba BT (sometimes works), WiFi 3945 (not working)

    best regards - fingerr

  10. #10
    Rookie Array

    Join Date
    Mar 2007
    Posts
    16
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by dukrous View Post
    Well, it worked. Running a Dell XPS M170 with Pentium M (SSE2). Only weird thing is the System Profilier crashing when I run it. All other apps work.
    Instal the 10.4.4 loginwindow PKG from Jas's 10.4.8 DVD, or just manually place in a 10.4.4 loginwindow


 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 8
    Last Post: 02-13-2011, 08:38 PM
  2. Replies: 10
    Last Post: 10-05-2008, 05:43 AM
  3. GUIDE TO UPDATE TO 1.1.4 (ZiPhone)
    By PowerKhrum in forum iPhone "2G" (Rev. 1)
    Replies: 5
    Last Post: 03-15-2008, 08:18 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 12:18 PM.
twitter, follow us!