Hi Dear Iphone Friends ,

I would like to share an experience i really do hope that the dev team reads this , maybe there is a solution that they will get after this article>

Well like almost all of you i bought an iphone 3g 16 gb black and as most
iphones it was network locked , but as yellowsn0w was around it really was not a problem getting the network back with my sim.

When 2.2.1 came out i accidently upgraded to it and i was with out my phone for 5 months until the great DEV TEAM came out with ultrasn0w , so i was very happy BUT while trying to JAILBREAK the device, it would always get stuck on the 3rd reboot , im sure a lot of you peeps out there could still be having that problem.I was kind of deppresed after trying over and over at least 50 times as i was going to give up i said well why dont i give it a try on a windows XP machine ( i was currently using my VISTA ULTIMATE 64x) and voila the whole thing worked like a charm .

So after the reboot etc i was kind of waiting to see some pretty signal bars come up and believe it or not they did come up , BUT i actually have to sim cards with my operator an old sim that dates 3 years back and a new version that dates to at least 1 year back which i was initially using on my iphone when i first got it .

So when i unlocked the phone with the ultrasnow i was actully using my old sim and so when i rebooted the iphone network signal was present, so i thought cool my new sim should work as well , so i replaced the sim as well as reboot the phone and big dissapointement NO SIGNAL, i tried everything so that i could refresh the network but nada nothing even tried restore and going through the red and ultra process but nothing .So now i was confused was it the phone or the sim ????????

Anyway i tried the old sim again and guess what the card would register and signal was present !!!!!!!

So i called some1 that i know that works for the operator that i was using and he said that the problem that i was having was simply because the new sim was is a 5 volt sim whereas the old sim is a 3volt sim......

Now i ask my self how is it that my new sim worked on the iphone when i first got it and not now!!!!!!

Could it be a problem with the firmware ???? i dont think so!!!!
May be its Yellowsn0w.!!!!!!
I actually dont know if someone from the dev team will read this but i hope that they do maybe they can have an idea on where the problem lies .
If any 1 knows them please ask them to have a read
Anyways i would like to thank the dev team personally for their work they are truly the gods of iphone