Results 1 to 6 of 6
Discuss Upgrading a 3GS to iOS v4.3.1 from 4.0.1 SAFELY(!) at the Ultrasn0w (3G(S)/iPhone 4 unlock) - Hackint0sh.org; I have a 3GS (old Bootrom, BB: 5.13.04 at FW: 4.0.1, ultrasn0w unlock, AT&T) and ...
  1. #1
    Advanced Array

    Join Date
    Dec 2010
    Location
    Berkeley
    Posts
    33
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Upgrading a 3GS to iOS v4.3.1 from 4.0.1 SAFELY(!)

    I have a 3GS (old Bootrom, BB: 5.13.04 at FW: 4.0.1, ultrasn0w unlock, AT&T) and am interested in upgrading to 4.3.1. I got "burned" when I tried upgrading to 4.1 with severe battery drain that even Olethros couldn't figure out how to solve so I returned to 4.0.1 where I've happily resided. I do upgrades only when the 'features' look interesting enough. I have not only saved ALL SHSH blobs back to 3.1.3 but every time the DevTeam comes out with a new version of Pwnagetool, I've created a custom IPSW for each version from 4.0 to now, 4.3.1 but I have not installed them on the phone. So I have 3 questions:

    1) What problems, if any, can I expect if and when I upgrade to 4.3.1? Most of the problems I've read in the stickies and posts are associated with people who have done either none of the above or have upgraded their basebands. Fortunately I haven't and would like to remain at 5.13.04. Do I merely option-restore the custom ipsw for 4.3.1 in iTunes to do the upgrade or do I need to be in recovery mode?

    2) Once I install the new FW version (4.3.1) can I safely "restore from backup" rather setting up as new? It's a major pain and time consuming to completely set up a new phone and would like to avoid this if possible.

    3) Unfortunately, I did not save the Pwnage version that builds FW v 4.0.1. Pwnagetool v4.01 only builds v 4.0 NOT 4.0.1. Is there any place I can find the version of Pwnagetool that will build 4.0.1?

    I REALLY don't want to damage or somehow impair the functionality of my phone so I'm trying to check out all the pitfalls BEFORE I do anything stupid.



  2. #2
    Moderator Array

    Join Date
    Aug 2007
    Posts
    781
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    51

    Default

    1) I haven't had any problems with 4.3.1 myself, but maybe you should wait for the updated PwnageTool to create custom 4.3.2, which apparently have fixed some 4.3.1 problems (again, I haven't experienced anything, but others have). To restore you have to use redsn0w, select Enter pwned DFU mode and then you can restore to custom ipsw with option-restore.
    2) Yes you can restore from backup safely.
    3) I don't know which version that was, sorry, will try to find.

  3. #3
    Advanced Array

    Join Date
    Dec 2010
    Location
    Berkeley
    Posts
    33
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by element View Post
    1) I haven't had any problems with 4.3.1 myself, but maybe you should wait for the updated PwnageTool to create custom 4.3.2, which apparently have fixed some 4.3.1 problems (again, I haven't experienced anything, but others have). To restore you have to use redsn0w, select Enter pwned DFU mode and then you can restore to custom ipsw with option-restore.
    2) Yes you can restore from backup safely.
    In that case, I'll wait for 4.3.2. I prefer stability over features. As I found with 4.1, although there were plenty of people who used it successfully, this board was also littered with people for whom 4.1 had dealbreaking battery drain issues. Mine never got resolved.

    Ha, I forgot I have to jailbreak first with redsn0w.

    Quote Originally Posted by element View Post
    3) I don't know which version that was, sorry, will try to find.
    As it turns out, BB version 5.13.04 is associated with FW version 4.0.1. I assume that this means I DON'T need to use pwnagetool to build a custom ipsw and can just use the official Apple one I've stored locally. If I do this I assume it won't update my modem firmware since 5.13.04 is was the current version at the time of 4.0.1, right? I have modified my hosts file sot that Apple doesn't sign the downgrade. I think Jailbreakme.com supports FW versions up to 4.0.1 so maybe I don't need a custom ipsw from pwnagtool.

  4. #4
    Moderator Array

    Join Date
    Aug 2007
    Posts
    781
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    51

    Default

    There you go, PwnageTool 4.3.2 released, take a look: Dev-Team Blog

  5. #5
    Newbie Array

    Join Date
    Oct 2010
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I have a 3GS (Old Bootrom? i think ...not sure Week 26?, BB: 5.13.04 at FW: 4.0.1, ultrasn0w unlock, T-mobile) and i want to upgrade to 4.3.2.
    Don't remember much of what i did to unlock it ...except i think i used jailbreakme + untrasn0w & the part that i choose to save the SHSH when asked with the option.

    I would prefer to have a clean 4.3.2 IOS but an upgrade is fine too(which ever is safer).
    I have read a few threads & it all sounds a bit confusing.(If i use the Pwnage tool 4.3.2 and follow the steps listed iClarified - iPhone - How to Jailbreak Your iPhone 3GS Using PwnageTool (Mac) [4.3.2] i would not have to unlock as the baseband is not updated?) Can anyone explain or provide me links/steps for this?

    Also if something goes wrong will i be still be able to get it back to 4.0.1?


  6. #6
    Senior Professional Array x98car's Avatar

    Join Date
    Nov 2007
    Posts
    333
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    24

    Default

    That guide is a good one. Just follow that and you should be fine. It will not matter if you have old or new bootrom with that.

    You can go back to 4.0.1 but only if you have SHSH for 4.0.1

 

 

Similar Threads

  1. I don't get it.. How to un,jb 5.12.01 safely??
    By codilx in forum iOS 4.x (iPhone OS 4.x)
    Replies: 1
    Last Post: 06-23-2011, 10:24 AM
  2. [1.1.4] trying to safely update
    By shareef in forum iPhone "2G" (Rev. 1)
    Replies: 9
    Last Post: 03-14-2008, 06:21 PM
  3. [1.1.3 (1.1.2OTB)] Can I safely upgrade to 1.1.4?
    By tottolotto in forum iPhone "2G" (Rev. 1)
    Replies: 67
    Last Post: 03-04-2008, 07:42 AM
  4. Can 1.12 upgrade to 1.13 safely??
    By iRonno in forum General
    Replies: 1
    Last Post: 01-16-2008, 12:48 PM
  5. [1.0.0 OTB] Can i safely upgrade to 1.1.1 ?
    By xevans in forum iPhone "2G" (Rev. 1)
    Replies: 2
    Last Post: 01-12-2008, 09:05 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 02:17 AM.
twitter, follow us!