Results 1 to 9 of 9
Discuss "No Sim" after unlocking. at the Ultrasn0w (3G(S)/iPhone 4 unlock) - Hackint0sh.org; Hi there! I have just jailbroke my iphone 4 with 4.0.1 just now. My phone ...
  1. #1
    Newbie Array

    Join Date
    Aug 2010
    Posts
    6
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default "No Sim" after unlocking.

    Hi there!

    I have just jailbroke my iphone 4 with 4.0.1 just now. My phone was locked to the Vodafone network and was activated in June when I bought it. I have just manually cut a normal size sim card (O2) into a micro sim card. I jailbroke successfully and then installed the repo666.ultrasn0w.com. I also followed this website: Cydia.pushfix.info and then installed the Hactivation Patch. I then put the new sim card O2 into my iphone but it says "No Sim" instead of "Different SIM detected"

    Is this because my iphone is still locked to the vodafone or I have damaged the the new sim card and is not working? What can I do? I only want to unlock the phone really. BTW, on the top of my cydia home page, it says " This device has a pending TSS request". does it mean that Apple is yet to process whatever that is needed to unlock my iphone?

    Please help! I am very confused...... I would appreciate any comments to this matter.

    Cheers.



  2. #2
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    The message about pending TSS request has nothing to do with the unlock. That just means that cydia has not yet saved a 4.0.2 SHSH for you.

    Your unlock problems - could be bad cutting of the sim card
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  3. #3
    Newbie Array

    Join Date
    Aug 2010
    Posts
    6
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    right! I thought that the pending TSS request is related directly to that fact Apple has stopped signing 4.0.1 SHSH requests which means that Apple has barred people form using different sim card (other than the original carrier). Have I completely misunderstood the whole thing?

    and also, supposedly if the phone was still unlocked and I put a different sim card in, would the "no sim" signs come out as well?

  4. #4
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by alantiam View Post
    right! I thought that the pending TSS request is related directly to that fact Apple has stopped signing 4.0.1 SHSH requests which means that Apple has barred people form using different sim card (other than the original carrier). Have I completely misunderstood the whole thing?
    You have a bit of a mixed understanding of this.

    It is pretty normal for Cydia to display pending TSS request for a few days or even more than a week after you first press "make my life easier". Cydia does not request your SHSH from Apple straight away, instead you go into a queue and your request is processed via a batch process.

    There are literally a few million iPhones registered with the "make my life easier" service, so you are not the only one looking to get your SHSH backed up.

    However - don't confuse unlock with jailbreak.

    4.0.2 can't be jailbroken right now. You need jailbreak to install and run the unlock. However if 4.0.2 could be jailbroken, the existing unlock would work straight away - nothing was changed in 4.0.2 to block unlocking.

    Also the recent tweak with activation that makes it more difficult to use some types of generic SIM cards to activate your phone. This change was made on the server side and has nothing to do with 4.0.2

    Quote Originally Posted by alantiam View Post
    supposedly if the phone was still unlocked and I put a different sim card in, would the "no sim" signs come out as well?
    Can you still get reception with your vodaphone SIM? Do you still have your contract with them for the phone?

    It could be one of the following things:

    Damaged SIM
    Damaged SIM contacts (internally in phone) - easily damaged if you force the sim holder in
    IMEI blacklisted phone
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  5. #5
    Newbie Array

    Join Date
    Aug 2010
    Posts
    6
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Hello Olethros,

    Thank you so much for replying. I think I now have a better idea about the whole TSS pending request thing.

    When I bought this phone in June, the salesman at Vodafone activated the phone for me, which I presume by using my vodafone sim card. I am still with vodafone at the moment. does this mean that I have the original carrier activation card?

    I don't think the sim internal contact is damaged as I can still use my vodafone sim following the jailbreak but not the O2 sim card. I have actually cut 2 O2 prepay sims and both of them don't work.... so I do wonder whether it is the O2 sim cards problems as I am pretty sure they are not damaged. before cutting them, i put them on another mobile phone and they do work (at least the o2 logo was the on top left of the phone).

    I bought this phone from new from Vodafone so I doubt it is on the IMEI blacklist.

    So in summary, I now have a jailbroke iphone 4 with 4.0.1. the jailbreak is working fine on my phone. May be I should find a friend of mine who uses different network and see if their sim card works on mine. may be I should wait until the jailbreak for 4.0.2 to come out?

    Any more advice of this? Thank you so much again for being so patient with me.


  6. #6
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    It could either be that you have cut the sim cards wrong or that you are experiencing a bug with ultrasn0w.

    We have seen very few reports of ultrasn0w problems (a few from t-mobile in the US). So if it is a ultrasn0w bug then it is not very common.

    Also, another potential cause is of you had a previous iPhone and restored the itunes backup of that phone onto your new phone. That can create problems for some people.
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  7. #7
    Newbie Array

    Join Date
    Aug 2010
    Posts
    6
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Hello Olethros,

    By the way, I just went went to jailbreakme.com on Safari and it says "Oops... it looks like the installer crashed last time you tried to jailbreak. It might work if you try again." Is this normal? This is strange because it seemed to have installed well and Cydia also works fine too. do you think I should uninstall the jailbreak and reinstall it again? if I have to, do I have to restore my iphone via itune? there is a lot of information on the internet about how to jailbreak and unlock the phone but I couldn't really find much info about how to uninstall it.

    Thanks again!

  8. #8
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by alantiam View Post
    Hello Olethros,

    By the way, I just went went to jailbreakme.com on Safari and it says "Oops... it looks like the installer crashed last time you tried to jailbreak. It might work if you try again." Is this normal? This is strange because it seemed to have installed well and Cydia also works fine too. do you think I should uninstall the jailbreak and reinstall it again? if I have to, do I have to restore my iphone via itune? there is a lot of information on the internet about how to jailbreak and unlock the phone but I couldn't really find much info about how to uninstall it.

    Thanks again!
    It's hard to say. If it is working - then I would not restore and try again.

    You have no SHSH for 4.0.1 or 4.0 so if you restore, it is to 4.0.2 and jailbreakme does not work with 4.0.2
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  9. #9
    Newbie Array

    Join Date
    Aug 2010
    Posts
    6
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Hello Olethros,

    just to let you know that my iphone 4 has indeed been unlocked as I tried to put another sim that is correctly cut and I saw that wonderful O2 sign on the top left corner!

    Thank you so much for your support!

 

 

Similar Threads

  1. "No Service", "Searching...", and "No SIM" after unlocking
    By kimmy527 in forum Ultrasn0w (3G(S)/iPhone 4 unlock)
    Replies: 2
    Last Post: 08-04-2010, 08:45 AM
  2. [1.1.3 (1.0.2)][Problem]["no service" after unlocking, reward 10$]
    By futureknight in forum iPhone "2G" (Rev. 1)
    Replies: 24
    Last Post: 03-02-2008, 06:43 PM
  3. " No WiFi " during the unlocking process ??
    By vishisback in forum iPhone "2G" (Rev. 1)
    Replies: 0
    Last Post: 01-23-2008, 08:10 PM
  4. Replies: 0
    Last Post: 12-19-2007, 06:06 PM
  5. "Unlock.app" can fix "no service","no wifi","IMEI 049.."
    By max9241 in forum iPhone "2G" (Rev. 1)
    Replies: 17
    Last Post: 11-11-2007, 04:12 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 05:26 AM.
twitter, follow us!