Results 1 to 7 of 7
Discuss iphone 3GS update from 4.1 (8B117) on baseband 06.15 to 4.2.1 fails at the Ultrasn0w (3G(S)/iPhone 4 unlock) - Hackint0sh.org; Hello, I have an iPhone 3GS that is on fw 4.1 and baseband 06.15. When ...
  1. #1
    Rookie Array

    Join Date
    Dec 2007
    Posts
    16
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default iphone 3GS update from 4.1 (8B117) on baseband 06.15 to 4.2.1 fails

    Hello,
    I have an iPhone 3GS that is on fw 4.1 and baseband 06.15. When I try to update it in iTunes I always get a 1015 error. As I have read this is because of the baseband in 4.2.1 is older than the ipad baseband 06.15.

    Is there a way to update this to 4.2.1. I have tried to use Pwnagetool 4.1.3 to create a custom 4.2.1 fw but when I select the original 4.2.1 firmware I get an error message wrong firmware bundle selected.

    Anybody knows what I'm doing wrong or how I can go to 4.2.1.
    I have no SHSH saved unfortunately :S

    iTunes version : 10.1
    iPhone OS before restore : 4.1
    Platform : OSX 10.6.5

    Iphone Restore Log : http://pastebin.com/LLe5Jdgg
    Last edited by tbelmans; 12-07-2010 at 11:36 AM.



  2. #2
    Super Moderator Array n1ckn4m3's Avatar

    Join Date
    Mar 2009
    Location
    USA
    Posts
    2,717
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    145

    Default

    1015 is expected -- just use TinyTSS/FirmwareUmbrella to kick the device out of recovery mode after the flash.

    This was clearly documented in the upgrade notes -- this will remain to be the case until Apple puts out a new iOS that has a baseband higher than 06.15 and iPhone users have a higher baseband to upgrade to.

    Good luck!
    The preceding forum post has been brought to you by the letter "N" and the number 42.

    iPhone 4, 32GB (iOS 6.1.2 | evasi0n | SHSH: 4.0 - 6.1.2)
    iPad 2 3G, 64GB (iOS 6.1.2 | evasi0n
    |
    SHSH: 4.3 & 4.3.3 - 6.1)

    Restore problems? Read this: http://www.hackint0sh.org/f137/130802.htm

    Did we solve your problem? Got a dollar or two spare? Please Donate!


  3. #3
    Rookie Array

    Join Date
    Dec 2007
    Posts
    16
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I'm currently on 4.1 with BB 06.15. So what can I do best now ?
    I've tried creating a custom ipsw but Pwnagetool keeps saying that it's the wrong bundle when I feed him fw 4.2.1.

    Also when I update to stock 4.2.1 it fails with error 1015 but I cannot kick it out of recovery with TinyUmbrella. Any idea ?

    At the moment I have a carrier unlocked iphone on 4.1 with 06.15 baseband.

    Thanks man.
    Last edited by tbelmans; 12-07-2010 at 08:30 PM.

  4. #4
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by tbelmans View Post
    I'm currently on 4.1 with BB 06.15. So what can I do best now ?
    I've tried creating a custom ipsw but Pwnagetool keeps saying that it's the wrong bundle when I feed him fw 4.2.1.

    Also when I update to stock 4.2.1 it fails with error 1015 but I cannot kick it out of recovery with TinyUmbrella. Any idea ?

    At the moment I have a carrier unlocked iphone on 4.1 with 06.15 baseband.
    Old or new bootrom 3GS? This is vital to knowing if you can actually utilise custom IPSW or not.

    If you have new bootrom, then you realistically should stay on 4.1

    Pwnagetool 4.1.3 doesn't include (by default) support for the 3GS on 4.2.1. You must tweak pwnagetool manually and to add a bundle that supports 4.2.1 on the 3GS (old bootrom only). read update #3 at Dev-Team Blog - Ultra-recycle and also read update #1
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  5. #5
    Rookie Array

    Join Date
    Dec 2007
    Posts
    16
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by Olethros View Post
    Old or new bootrom 3GS? This is vital to knowing if you can actually utilise custom IPSW or not.

    If you have new bootrom, then you realistically should stay on 4.1

    Pwnagetool 4.1.3 doesn't include (by default) support for the 3GS on 4.2.1. You must tweak pwnagetool manually and to add a bundle that supports 4.2.1 on the 3GS (old bootrom only). read update #3 at Dev-Team Blog - Ultra-recycle and also read update #1
    It's the old bootrom. I already have update Pwnagetool with the special bundle but still cannot build a 4.2.1 custom firmware ?


  6. #6
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by tbelmans View Post
    It's the old bootrom. I already have update Pwnagetool with the special bundle but still cannot build a 4.2.1 custom firmware ?
    You may have the wrong original 4.2.1 IPSW download it again from here: http://www.hackint0sh.org/f127/22056.htm

    Other than that, I'd need to test it myself (I don't have time to do that until the weekend)
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  7. #7
    Rookie Array

    Join Date
    Dec 2007
    Posts
    16
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Thanks the phone is working on 4.2.1 now.
    I downloade Pwnagetool again and the bundle for 4.2.1 and now everything works. Something must have gone wrong in the process before.
    Thanks for the help guys, you rock!

    Tom

 

 

Similar Threads

  1. Iphone 4 update baseband?
    By litrica in forum Ultrasn0w (3G(S)/iPhone 4 unlock)
    Replies: 2
    Last Post: 03-08-2011, 10:00 AM
  2. Factory-unlocked iPhone 4 under 4.1(8B117) fw 02.10.04: Jailbreaking + Unlocking?
    By mattpower in forum Greenpois0n (iOS 4.1 jailbreak)
    Replies: 12
    Last Post: 02-21-2011, 12:41 PM
  3. Combo update fails
    By Mortax in forum Installation
    Replies: 1
    Last Post: 01-29-2011, 08:07 PM
  4. HELP /ADVICE - Iphone 4 - 4.1 (8B117)
    By pkaria in forum General
    Replies: 2
    Last Post: 01-25-2011, 11:47 PM
  5. Itunes Update Fails 10.5.8 iDeneb
    By jeff_ocs in forum Using Leopard
    Replies: 2
    Last Post: 06-09-2010, 04:14 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 04:10 AM.
twitter, follow us!