Some stats first: Iphone 4, BB 1.59.00 IOS 4.3.2 with the following SHSHs saved with Tinyumbrella, running on Win XP:

iPhone4 4.0.2 (8A400)-1877807488429
iPhone4 4.1 (8B117)-1877807488429
iPhone4 4.2.1 (8C148)-1877807488429
iPhone4 4.2b3 (8C5115c)-1877807488429
iPhone4 4.3 (8F190)-1877807488429
iPhone4 4.3.2 (8H7)-1877807488429
iPhone4 4.3.3 (8J2)-1877807488429
iPhone4 4.3.5 (8L1)-1877807488429
iPhone4 5.0.1 (9A405)-1877807488429
iPhone4 5.1b2 (9B5127c)-1877807488429
iPhone4 5.1b3 (9B5141a)-1877807488429

It started out as a failed attempt to upgrade to 5.0.1. I did manage to take the safe route and I've not given up my precious 1.59.00 BB so now I'm back to 4.3.2 which is fine (seing I can't get to where I wanted grrr). I've had 4.3.2 unlocked before with no problems. But I'm stuck, I've no signal and I've done what I can.

It's an American GSM phone from AT&T and I'm in Denmark, so I need to unlock in order for it to work at all. I have an american SIM-card that I've somehow used successfully about a year ago, but I forgot how that worked. I hactivated with snowbreeze 2.9.1, I've used the latest ultrasnow from Cydia, neither has paid off.

It has been suggested that I should get a copy of ultrasn0w 1.2.2, but I can't seem to find a repository that has it and I don't know if it's available through Cydia.

I'd depserate for help, I've had a big shiny ip4-ipod for a week now and it's driving me crazy! I fear I wont get it working again

Does anyone have an idea what to do?

Many thanks in advance.