Results 1 to 10 of 10
Discuss [3GS] [iPod Touch 2G] PwnageTool 3.1.3 for Mac OS X at the Ultrasn0w (3G(S)/iPhone 4 unlock) - Hackint0sh.org; ...
  1. #1
    Moderator Array vikram's Avatar

    Join Date
    Feb 2008
    Posts
    258
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default [3GS] [iPod Touch 2G] PwnageTool 3.1.3 for Mac OS X

    "As an extra bonus to today's PwnageTool release, iPod touch 2G will now be supported. Custom boot logos for everyone "

    -Musclenerd
    update:
    it's out now.


    All aboard the update train!

    Here are some details on our latest version of PwnageTool for Mac OS X that adds support for the 3.1 release of the iPhone software for iPhone 3GS and iPod Touch 2G.

    SUMMARY:

    The iPhone 3GS is now supported in PwnageTool 3.1.3, assuming the phone was pwned at 3.0 or 3.0.1 - PwnageTool does not support the 3GS out of the box. If your iPhone 3GS has 3.1 preinstalled and is not Pwned then there is no tested jailbreak solution at the moment.

    The iPod 2G is now supported in PwnageTool 3.1.3, assuming the iPod 2G was pwned at 3.0 or 3.0.1 - PwnageTool does not support the iPod 2G with 3.1 software out of the box.

    DETAILS:

    1. GOLDEN RULE: If you are using a iPhone 3G or iPhone 3G(S) with ultrasn0w and rely on ultrasn0w to obtain cellular service then you should only update your device with an .ipsw that is made with the new PwnageTool. There are no second chances with this. You need to remember that PwnageTool will provide an upgrade path to newer versions of the iPhone software in the future.
    2. Please read all parts of this post before downloading and using these tools.
    3. Read items 1, 2 and 3 again and again.
    4. At the bottom of this post are the bittorrent files for the 3.1 capable version of PwnageTool.
    5. PwnageTool will work for the iPhone 3GS assuming you have already Pwned it at 3.0 or 3.0.1
    6. PwnageTool will work for the iPod touch 2G assuming you have already Pwned it at 3.0 or 3.0.1
    7. PwnageTool WILL work for Original iPhone (1st Generation), the iPhone 3G and iPhone 3G(S) and the iPod touch (1st Generation and 2nd Generation) but NOT the iPod touch 3rd generation.
    8. For 3G and 3G(S) users who are Pwned, PwnageTool is your key to updating in the future, just remember to never install an update directly from Apple, always use an .ipsw that has been created with PwnageTool.
    9. There is no Windows version of PwnageTool it is a Mac OS X tool only, we are not developing a Windows version of PwnageTool.

    What’s a Baseband?

    The ‘baseband’ is the generic nickname given to the internal components of the iPhone that handle the phone calls and Internet access. This ‘baseband’ is a tiny and unique independent computer system that runs inside your iPhone, it is separate to the main system that handles the applications (such as email and google maps) and it talks to the main part of the phone over an internal communications network.

    Think of it like a cable modem or other peripheral that is attached to your home PC that needs occasional updates. When a software update is released and presented to you within iTunes the baseband is sometimes updated (to fix bugs or add new features).

    The 3.1 update for the iPhone 3G and 3GS contains such an update, so running the vanilla updater straight away with iTunes will reprogram and update the baseband.

    WHICH DEVICE DO I HAVE?

    Read the description to identify your device, once you have correctly identified your device follow the specific instructions for that device as listed below.

    SIM Free/SP Unlocked/Factory Unlocked iPhone 3G(S)

    This applies if you bought your iPhone 3G(S) for $$$$$$$. This model of iPhone 3G(S) doesn’t have an Service Provider lock (aka factory unlocked) and you are able to put any SIM card into the phone and get service. Your phone is already unlocked so you do not need to worry about baseband updates, if your device was Pwned at 3.0 or 3.0.1 then you can use PwnageTool to create an ipsw and then use this to update and jailbreak your phone.

    SIM Free/SP Unlocked/Factory Unlocked iPhone 3G

    This applies if you bought your iPhone 3G for $$$$$$$. This model of iPhone 3G doesn’t have an Service Provider lock (aka factory unlocked) and you are able to put any SIM card into the phone and get service. Your phone is already unlocked so you do not need to worry about baseband updates, if your device was Pwned at 3.0 or 3.0.1 then you can use PwnageTool to create a 3.1.ipsw and then use this to with iTunes to upgrade and jailbreak your phone.

    iPhone 2G (1st Generation)

    Use PwnageTool to do the magic and then restore with iTunes using your newly created .ipsw ‘nuff said, you don’t need to worry about anything, the baseband will be unlocked, the phone jailbroken.

    iPod Touch 1G (Original iPod Touch)

    Use PwnageTool to create a firmware image and restore with that .ipsw using iTunes.

    iPod Touch 2G

    Use PwnageTool to create a firmware image and restore with that .ipsw using iTunes, this will only work if you are already Pwned at 3.0 or 3.1.

    iPod Touch 3G

    At this time PwnageTool does not support this device.

    Official Bittorrent Releases -

    * PwnageTool 3.1.3 : http://torrents.thepiratebay.org/510...31.TPB.torrent


    Unofficial Mirrors

    The following links are unofficial download mirrors, you download these at your own risk, we accept no responsibility if your computer explodes or if it becomes part of a NASA attacking botnet or even worse if your hands fall off mid-way during the use of these files. We do not check these links or archives and we accept no responsibility with regard to the validity of the files, or with other content these links provide or with the content that is on the linked site. Always check the published SHA1 sums. We would prefer that you downloaded the official bittorrent release that is linked above, but you are welcome to try these if you really must. Mirror owners should email direct links only to blog@iphone-dev.org , please don’t place mirrors in the comments as they will be deleted.
    torrent site is down, here is a mirror
    Download PwnageTool 3.1.3 for 3GS and iPod 2G
    Last edited by vikram; 10-02-2009 at 11:01 PM.



  2. #2
    Rookie Array

    Join Date
    Sep 2007
    Posts
    14
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Anyone tried it already? Do we have to do a restore with the custom firmware and then restore old settings from a backup? or is it recommended to set up as a new phone? Im afraid that Ill loose push notifications if I do a restore.

  3. #3
    Newbie Array

    Join Date
    Oct 2009
    Posts
    8
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by cariza View Post
    Anyone tried it already? Do we have to do a restore with the custom firmware and then restore old settings from a backup? or is it recommended to set up as a new phone? Im afraid that Ill loose push notifications if I do a restore.
    When will there be windows support?

  4. #4
    Senior Professional Array

    Join Date
    Oct 2007
    Location
    USA
    Posts
    153
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    17

    Default

    Quote Originally Posted by cariza View Post
    Anyone tried it already? Do we have to do a restore with the custom firmware and then restore old settings from a backup? or is it recommended to set up as a new phone? Im afraid that Ill loose push notifications if I do a restore.
    Same here.. I'm unlocked on T-mobile USA using a 3GS with 3.01. I actually went out an purchased a used Mac G5 just to use pwnage tool myself! And when I setup my 3GS I used a friends USA AT&T sim card to activate before I used redsn0w to jailbreak and then ultimately ultrasn0w to unlock - so I would have PUSH notification working - and it does, and I love it!

    I'm worried by upgrading to 3.1 I'd loose the push feature. CAN ANYONE VERIFY THIS? Or maybe a better question, is it possible to successfully BACKUP the push keys, certificates, and files that are associated with making push work correctly? So we can then restore them (manually if necessary) and regain true working push?

    (or is it better to just stay on 3.01 for the moment for us 3GS unlocked users?)

  5. #5
    Professional Array

    Join Date
    May 2008
    Posts
    52
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    8

    Default

    Quote Originally Posted by Toaster View Post
    Same here.. I'm unlocked on T-mobile USA using a 3GS with 3.01. I actually went out an purchased a used Mac G5 just to use pwnage tool myself! And when I setup my 3GS I used a friends USA AT&T sim card to activate before I used redsn0w to jailbreak and then ultimately ultrasn0w to unlock - so I would have PUSH notification working - and it does, and I love it!

    I'm worried by upgrading to 3.1 I'd loose the push feature. CAN ANYONE VERIFY THIS? Or maybe a better question, is it possible to successfully BACKUP the push keys, certificates, and files that are associated with making push work correctly? So we can then restore them (manually if necessary) and regain true working push?

    (or is it better to just stay on 3.01 for the moment for us 3GS unlocked users?)
    By reading your post, I assume it's possible to make a custom ispw of 3.0.1 and restore my phone to 3.0.1? I have problems with my OS right now and I think a format would help a lot.


  6. #6
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Just to be clear, unless you managed to get Cydia to backup your ECID SHSH for 3.0 or 3.0.1 you cannot currently restore to 3.0.x

    I think the dev team messed up in not offering a way to reload pwned 3.0 and 3.0.1 ipsws onto the 3GS via pwnagetool. There are many who are happy enough with 3.0 and don't need all that 3.1 offers. Or have a broken 3.0 install (push notifications had stopped working) and need to reinstall to fix the problem.

    I believe in theory it should be possible to backup the push certificates you already have. I would recommend doing that anyway.. just in case.

    Isn't that what the nimble / inject tools that are contained in the pushfix package released by the dev team as an unofficial solution do?

    If you copy nimble to your phone, run it - then backup the four files it creates to your mac. Load pwned 3.1, jailbreak, hacktivate and copy inject and the backed up files to your phone. Then run inject, that should work.
    Last edited by Olethros; 10-04-2009 at 08:22 AM.

  7. #7
    Professional Array

    Join Date
    May 2008
    Posts
    52
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    8

    Default

    Quote Originally Posted by Olethros View Post
    Just to be clear, unless you managed to get Cydia to backup your ECID SHSH for 3.0 or 3.0.1 you cannot currently restore to 3.0.x

    I think the dev team messed up in not offering a way to reload pwned 3.0 and 3.0.1 ipsws onto the 3GS via pwnagetool. There are many who are happy enough with 3.0 and don't need all that 3.1 offers. Or have a broken 3.0 install (push notifications had stopped working) and need to reinstall to fix the problem.

    I believe in theory it should be possible to backup the push certificates you already have. I would recommend doing that anyway.. just in case.

    Isn't that what the nimble / inject tools that are contained in the pushfix package released by the dev team as an unofficial solution do?

    If you copy nimble to your phone, run it - then backup the four files it creates to your mac. Load pwned 3.1, jailbreak, hacktivate and copy inject and the backed up files to your phone. Then run inject, that should work.
    Yup I have them all on file and on Cydia server. Any guides for this or is it as straight forward as it sounds. Make custom firm with pwn then restore then redsnow and ultra

    edit: it seems we can only do restore with 3.1 for pwnage tool
    Last edited by dorkiedoode; 10-04-2009 at 02:15 PM.

  8. #8
    Administrator Array

    Join Date
    Oct 2007
    Posts
    4,145
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    Quote Originally Posted by dorkiedoode View Post
    By reading your post, I assume it's possible to make a custom ispw of 3.0.1 and restore my phone to 3.0.1? I have problems with my OS right now and I think a format would help a lot.
    NOPE.
    current pwnagetool 3.1.3 does not allow the selection of firmware 3.0/3.0.1 for iPhone 3GS and therefore you CANNOT make custom firmware 3.0/3.0.1

    I chatted with MuscleNerd requesting this feature to be made available for device that has been pwned (for next pwnagetool refresh). He did not answer yes or no but he understands the justification. I told MuscleNerd this would be a nice option to have for those who DO NOT want to upgrade to 3.1 and would be useful to have to restore to pwned device.

    Oct 05 10:37:21 <dtube> MuscleNerd-- is it possible to have custom 3.0 for 3GS at the next refresh of pwnagetool ?
    Oct 05 10:40:17 <MuscleNerd> dtube: that's sort of a niche market , custom 3.0 for 3gs.....u mean people who went to 3.1 but now want to go back, and who don't have their ecid hashes?
    Oct 05 10:41:15 <dtube> MuscleNerd-- that is correct. right now, they have to go to 3.1 custom on their pwned device.
    Oct 05 10:41:39 <dtube> MuscleNerd-- it will be nice to be able to go 3.0 custom on pwned 3gs
    Oct 05 10:42:11 <MuscleNerd> dtube: i'm confused by the "have to go to 3.1 custom" part
    Oct 05 10:44:39 <dtube> MuscleNerd-- some people have 3gs with 3.0 pwned and somehow their phone is screwed up and the phone needs to be restored. However, they cannot without ecid/shsh. So now they can restore with 3.1 custom since device is pwned. If the device is pwned, they can restore 3.0 custom ipsw if it is available right ?
    Oct 05 10:45:05 <MuscleNerd> dtube ah ok yeah
    Last edited by dtube; 10-06-2009 at 05:37 PM.
    ** If you just want to support hackint0sh.org with a donation click here **

  9. #9
    Senior Professional Array

    Join Date
    Oct 2007
    Posts
    139
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    13

    Default

    dtube... after reading what you have posted I'm confused with your conversation with musclenerd. You stated that people who have their previous iphone 3GS pwned with 3.0 and their iphone messed up so they have to go to 3.1 firmware, which will update their baseband which means they cannot unlock or jailbreak anymore. You also stated that their ecid/shsh is not on cydia ....

    isn't this what everyone is waiting for? a jailbreak and unlock to work on 3.1 firmware with the new baseband of 5.11? Since if you restore to 3.1 and your ecid/shsh file is not on cydia it's the same as if you have a OTB 3GS just like I do isn't it?

    Or did I totally misunderstand your conversations with Musclenerd

  10. #10
    Administrator Array

    Join Date
    Oct 2007
    Posts
    4,145
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    Xterminater,
    Read again, I always mention custom 3.1 firmware for 3GS.

    Custom firmware (all versions) created by pwnagetool prevents baseband upgrade.

    I think you are confused.
    ** If you just want to support hackint0sh.org with a donation click here **


 

 

Similar Threads

  1. Replies: 10
    Last Post: 11-04-2010, 04:24 AM
  2. Replies: 6
    Last Post: 07-20-2008, 12:28 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 12:24 PM.
twitter, follow us!