Results 1 to 6 of 6
Discuss 3.0 full unlock sequence question at the Ultrasn0w (3G(S)/iPhone 4 unlock) - Hackint0sh.org; ...
  1. #1
    Newbie Array

    Join Date
    Jun 2009
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default 3.0 full unlock sequence question

    Hello all,

    Had a quick question with regards to the order of operations for unlocking my iPhone 3G. I want to fully unlock this baby so that when I travel overseas I can use a local SIM card from abroad with pre paid minutes etc, or use another carrier etc. I of course want to jailbreak it too.

    I currently have a 3G iPhone running Version 2.2 (5G77) and FIrmware 2.28. Also I have never unlocked/jailbreaked this phone yet.

    I'd like to upgrade to the new 3.0 software now, and then wait a few days to see how the ultrasn0w hack fairs with the general populous before using it.

    My question is whether I can/should perform this 3.0 upgrade now, or if I should unlock first, or if I should just wait? What's the best way to go about both upgrading, jailbreaking, and unlocking? Here's the path I'm under the impression will work:

    (From normal, phone - not unlocked or hacked at all)

    1) Upgrade to 3.0 software via iTunes
    2) Quickpwn
    3) Use Cydia to install Ultrasn0w (when available)

    Will this fully unlock my iPhone? At one point I thought I had read that I MUST use Pwnage tool, and NOT Quickpwn. Is this still the case? If so, does this mean Iíll need to:

    1) Upgrade to 3.0 software via iTunes
    2) Pwnage tool
    3) Use Cydia to install Ultrasn0w (when available)

    But can I use Pwnage tool after upgrading to 3.0 via iTunes? Should I instead:

    1) Pwnage tool
    2) Upgrade to 3.0 softwawre via iTunes
    3) Use Cydia to install Ultrasn0w (when available)

    Can someone help me with the order of operations here? Again, this is from a factory default phone with the software listed above. Thanks to all.



  2. #2
    Senior Professional Array

    Join Date
    Sep 2007
    Posts
    381
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    28

  3. #3
    Advanced Array

    Join Date
    Oct 2007
    Posts
    49
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    So you're asking how/when you should upgrade. Got it.

    So here's what I gather from what I've read for the 3 categories most people fall under.

    A. You're with AT&T/Other Official Carrier & you DO NOT want to Jailbreak:
    Upgrade to your hearts content! No issues

    B. You're with AT&T/Other Official Carrier & you DO want to Jailbreak:
    Feel free to upgrade, but use the most recent PwnageTool (or quickpwn, after it is updated/released)

    B. You're with an Unofficial Carrier:
    You can upgrade, using the most recent pwnage tool (or quickpwn, after it is updated/released), but you'll be "phoneless" (aka, you'll have a iPhone minus phone) until ultrasnow is released.

    So to exactly answer your question, you have two options:
    1. Upgrade Officially, through iTunes without PwnageTool (no Jailbreak). Then after the updated Quickpwn and Ultrasnow have been released, jailbreak and unlock (in that order, because there is no other way)

    2. Upgrade using PwnageTool & iTunes. You will have a Jailbroken, but NOT unlocked iPhone, at least until Ultrasnow is released. After it is released,just install it via Cydia (or whatever installer) to unlock.

    My personal opinion is that PwnageTool gives you a cleaner jailbreak/software install than QuickPwn does, but you need to have a Mac to use it...or a friend with one Oh, and if you don't have a Mac, I'd suggest option 1. You probably won't wait too long anyways.
    Last edited by SpyHunter39; 06-20-2009 at 05:04 AM.

  4. #4
    Senior Professional Array

    Join Date
    Sep 2007
    Posts
    381
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    28

    Default

    > B. You're with AT&T/Other Official Carrier & you DO want to Jailbreak:
    Feel free to upgrade, but use the most recent PwnageTool

    I respectfully disagree with using iTunes to upgrade to FW 3.0. You must use Pwnage Tool to modify FW 3.0 BEFORE you use iTunes. And I dont think you should use Pwnage Tool at all on a 3G with FW 3.0, because you will lose your phone service until Ultrasnow arrives.

    > 2. Upgrade using PwnageTool & iTunes. You will have a Jailbroken, but NOT unlocked iPhone,

    I agree, that is true on a 3G, not true on a 2G
    the following link basically says that you CAN unlock a 2G iPhone on FW 3.0.. very confusing:
    iClarified - Apple News - How to Update Your 2G iPhone to 3.0 Without Losing Activation, Unlock
    says: "You will loose your activation if you used QuickPwn to jailbreak your iPhone. If you used PwnageTool you will not."

    > My personal opinion is that PwnageTool gives you a cleaner jailbreak/software install than QuickPwn does

    I agree that if your 2G iPhone was unlocked with Pwnage Tool, then you can use FW 3.0..

    Its all very convoluted, and basically, not ready for prime time..

    there is currently no unlock for FW 3.0 running on a 3G iPhone, and there is no unlock for the 3GS either

    but there is a current unlock for FW 3.0 running on an iPhone 2G

    the rest of the technobabble about Activation and Jailbreaking is just causing confusion, and will not matter once Ultrasnow is released.

    Until Ultrasnow exists, using Pwnage is really only good for unlocking 2G iPhones.. unless you consider losing your phone service fun, in which case you can upgrade your 3G to FW 3.0 and use it as an ipod.. but why?

    moral of the story, if you have a 3G, wait, dont apply FW 3.0, not even with Pwnage Tool
    Last edited by jon_slider; 06-20-2009 at 07:40 AM.

  5. #5
    Peanut Brain Array Confucious's Avatar

    Join Date
    Nov 2008
    Location
    Woking, UK
    Posts
    505
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    32

    Default

    @Synapse_12 - at the moment neither quickpwn nor UltraSnow have been released.
    You could upgrade to 3.0 now but would not be able to jailbreak without either a Mac or a custom ipsw and you will not be able to unlock. Yet.

    If you want to unlock now you can just jailbreak and install yellowSn0w on FW 2.20

    My advice would be to hold fire for a few more days to make sure you can upgrade, jailbreak and unlock.
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.

    iPhone 4 locked to T-Mobile. 4.1 Limera1n'd


  6. #6
    Advanced Array

    Join Date
    Oct 2007
    Posts
    49
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by Confucious View Post
    @Synapse_12 - at the moment neither quickpwn nor UltraSnow have been released.
    You could upgrade to 3.0 now but would not be able to jailbreak without either a Mac or a custom ipsw and you will not be able to unlock. Yet.

    If you want to unlock now you can just jailbreak and install yellowSn0w on FW 2.20

    My advice would be to hold fire for a few more days to make sure you can upgrade, jailbreak and unlock.
    RedSnow was just released, which is just basically a retooled QuickPwn. So it's Jailbreaking is now an option for windows users and iPod Touch 2G user (those weren't options previously), but there is still no UltraSnow, so no iPhone 3G unlock.

 

 

Similar Threads

  1. Question about recognizing full HDD capacity.
    By drewsky in forum Kernel / Kext (Driver) Support
    Replies: 0
    Last Post: 09-09-2009, 11:20 AM
  2. Replies: 11
    Last Post: 10-18-2008, 04:36 AM
  3. [1.1.3 (1.0.2)] SMS out of Sequence
    By cwiza in forum iPhone "2G" (Rev. 1)
    Replies: 5
    Last Post: 02-27-2008, 05:21 PM
  4. Replies: 2
    Last Post: 02-21-2008, 11:26 PM
  5. quick question about sequence of events YES/NO?
    By apercele79 in forum iPhone "2G" (Rev. 1)
    Replies: 7
    Last Post: 10-27-2007, 07:23 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 01:41 AM.
twitter, follow us!