I am currently using an OTB 1.1.1 that was downgraded to 1.0.2 and activated with iNdependence to use my tmobile sim card with the PSS-SIM/ Hypercard method. However as software progresses and new features are available I find myself ready to upgrade to the latest firmware. I just want some guidance in making this process painless, such as activating it again to use my hyper card or also being able to use installer.app... I guess I would download oktoprep for 1.1.2 and then update my firmware. Im just unsure of how to activate the hypercard like i did with independence...any guidance would be greatly appreciated.