Results 1 to 5 of 5
Discuss Help: TurboSIM reprogrammed itself during restore! at the Turbo-, Supersim and Simcloning Solution - Hackint0sh.org; Hi, has anybody experienced the same problem, that the tsim obviously reprogrammed itself (during restore ...
  1. #1
    Professional Array

    Join Date
    Jun 2007
    Posts
    56
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default Help: TurboSIM reprogrammed itself during restore!

    Hi,

    has anybody experienced the same problem, that the tsim obviously reprogrammed itself (during restore of firmware 1.02) and now responds with a wrong ICCID (a non-AT&T one)?

    Here's what happened in detail:

    I successfully got my tsim to work using AppleSaft and (at that time) Firmware 1.01 on my iphone. A week ago, I updated to version 1.02 and re-activated using iActivator. No problems till then, tsim was still working like a charme.
    Two days ago, I borrowed my iPhone to a friend and put in his Vodafone Simcard, which also worked without a problem. Well, yesterday he tried to sync media with his PC and iTunes and all of a sudden, the iPhone didn't respond anymore and he had to restore the iPhone.
    From that point on, something strange happened: the tsim's fake ICCID somehow changed and since then, it always responds with the ICCID of the Vodafone Simcard!!! Of course, the iPhone always says "incorrect SIM". The ICCID of the vodafone card got definetly somehow in the tsim because
    the iPhone always shows the vodafone ICCID, no matter which Simcard I put in together with the tsim (O2, T-Mobile,...).

    The only possibility I see is reprogramming the TurboSIM. But I couldn't manage to do that, because "turbo-info" (and all other turbo-apps as well) always fail with a modem initialization error (tried a hundred times with complete restore and so on).

    What can I do now? Did anybody have the same problem (tsim reprogrammed itself)? How could that happen? How can I reprogram the tsim? Maybe using another phone or an iPhone where the "Sim Applications" (AppleSaft/Set) is still on?

    Thanks in advance.

    Almeida



  2. #2
    Professional Array

    Join Date
    Jun 2007
    Posts
    56
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    Here's the log when running "turbo-info"

    Code:
    turbo-info -v
    initializing modem
    1 -> ATV1
    1 <- ATV1
    OK
    1 -> ATE1
    1 <- ATE1
    OK
    1 -> AT+CPMS="SM","SM"
    1 <- AT+CPMS="SM","SM"
    ERROR
     AT+CPMS="SM","SM"
    ERROR
    1 -> AT+CMGF=0
    1 <- AT+CMGF=0
    OK
    1 -> AT+CPMS?
    1 <- AT+CPMS?
    modem initiated
    1 -> AT+CMGW=9
    1 <- 
    1 -> 029100110000810004FF0110
    After that, nothing happens anymore. I also tried using the SMS-Reset Utility but it fails as well with an error.

    Any ideas?

  3. #3
    Zf_
    Zf_ is offline
    iPhone Dev Team Array

    Join Date
    Jul 2007
    Posts
    717
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    47

    Default

    Put the TSIM + any SIM in another phone

    Start the phone, enable the SIM PIN

    Turn off the phone

    Start the phone, enter the TurboSIM PIN (written on Bladox package), an error will be reported, but the PIN attempts (usually set to 3) won't be decreased

    You can now reprogram the TSIM with an AT&T card in the iPhone

  4. #4
    Rookie Array

    Join Date
    Aug 2007
    Posts
    15
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by Zf_ View Post
    You can now reprogram the TSIM with an AT&T card in the iPhone
    Are you sure that it will work?! ...it would be really great.

  5. #5
    Professional Array

    Join Date
    Jun 2007
    Posts
    56
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    Thank you so much, Zf_!!

    You are my hero...

    It was exactly the problem I had. I put the TSIM together with my O2 card in a Sony Ericsson w800i, enabled PIN1, turned off/on and typed in the TPIN (of the turbosim).

    After that, reprogramming went well.

    If i knew that before, it would have saved me 7 hours of work. Anyway, I have no idea how it could happen that the tsim was reprogrammed with a restore of the iPhone. I will never ever do a restore without taking out the tsim.


 

 

Similar Threads

  1. Replies: 0
    Last Post: 02-12-2008, 06:04 PM
  2. Replies: 2
    Last Post: 01-29-2008, 08:56 AM
  3. [TurboSim] Backing up SMS/Full restore/No SIM Installed...
    By motion2010 in forum Turbo-, Supersim and Simcloning Solution
    Replies: 5
    Last Post: 01-17-2008, 08:44 AM
  4. Replies: 0
    Last Post: 09-05-2007, 11:26 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 01:04 PM.
twitter, follow us!