Page 1 of 2 12 LastLast
Results 1 to 10 of 11
Discuss Any future for Turbosim after software unlock? Your opinion requested at the Turbo-, Supersim and Simcloning Solution - Hackint0sh.org; Hi Guys, I'm running my US 1.1.2 BL 4.6 Iphone with Turbosim which cost a ...
  1. #1
    Advanced Array

    Join Date
    Nov 2007
    Posts
    36
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Any future for Turbosim after software unlock? Your opinion requested

    Hi Guys,

    I'm running my US 1.1.2 BL 4.6 Iphone with Turbosim which cost a pretty penny. Now that the SW unlock is available, is there any point in keeping it? I'm not entirely sure how the unlock works however I presume Apple will have closed the loop hole when they release 1.1.4. Therefore is it worth hanging on to my Turbosim in case it is the only solution that will potentially work with future firmware versions or now that an exploit in BL 4.6 has been found, is it likely a SW unlock will be available for all future firmwares (on the basis that some of the experts here understand what the SW unlock is exploiting).

    Tempted to offload my Turbosim and get what I can back on it but will hold onto it if it's likely to be of use in the future.



  2. #2
    Senior Professional Array smirkis's Avatar

    Join Date
    Dec 2007
    Posts
    361
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    30

    Default

    the loophole in 4.6bootloader has been found so i dont think there will be any issues in unlocking future firmware updates now just like anysim on 3.9bootloaders.

    so i think the turbosim is useless to you forever and may only be good for possible future iphones with new bootloaders? maybe.
    originally OTB 1.1.2 iPhone 4.6BL
    hActivated/Jailbroken/gUnlocked
    Tzones hacked
    T-Mobile USA

    now blackra1n'd 3.1.2

  3. #3
    The Man Array aviegas's Avatar

    Join Date
    Sep 2007
    Posts
    1,108
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    73

    Default

    It's not that simple.

    The current loophole allows a 04.02.13_G (1.1.2 level) to be flashed back, but not (yet) a 04.03.13_G (1.1.3 level). So with gunlock we are still "stuck" at the 1.1.2 level, just like with the *SIM solutions.

    There are 3 scenarios:

    a) Hardware unlocks - exist and will continue to exist but current ones are too complex (1.1.3)
    b) New/revised exploit in 4.6 to make it as simple to reflash as 3.9 (and to execute unsigned code)
    c) Dev/Elite resume work on JerrySIM: they were almos there, why quiting now!
    c) a new *SIM exploit

    The community as a whole must support all there avenues, or at the end, Apple will win.

  4. #4
    Advanced Array

    Join Date
    Nov 2007
    Posts
    36
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by aviegas View Post
    It's not that simple.

    The current loophole allows a 04.02.13_G (1.1.2 level) to be flashed back, but not (yet) a 04.03.13_G (1.1.3 level). So with gunlock we are still "stuck" at the 1.1.2 level, just like with the *SIM solutions.

    There are 3 scenarios:

    a) Hardware unlocks - exist and will continue to exist but current ones are too complex (1.1.3)
    b) New/revised exploit in 4.6 to make it as simple to reflash as 3.9 (and to execute unsigned code)
    c) Dev/Elite resume work on JerrySIM: they were almos there, why quiting now!
    c) a new *SIM exploit

    The community as a whole must support all there avenues, or at the end, Apple will win.
    Hi aviegas,

    Many thanks for your reply. With regard to the software unlock, as I understand it, the Geohot unlock also works on 1.1.3 OTB phone (8 and 16Gb) with baseband 04.03.13_G + 1.1.2 OTB phone upgraded through itunes but in each of these instances, the 04.03.13_G cannot be jailbroken but can be unlocked - have I understood that correctly?

  5. #5
    Busha
    Guest

    Default

    I have Restored my 1.1.2 OOTB on 1.1.3 trough iTunes, then Restored to 1.1.1, unlocked and then upgraded to 1.1.2 and everything works great !


  6. #6
    Senior Professional Array

    Join Date
    Nov 2007
    Posts
    178
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    15

    Default

    My phone is a 1.1.2, 4.6 OTB smoothly working with TurboSIM

    Geo's unlock (thanks Geo: I love you! ) would simply give me exactly what I already have, and as I don't want to install a "frankenstein 1.1.3"... I'll stick to 1.1.2 with TurboSIM.

    The day an unlock for *true* 1.1.3 (or greater) will be out, if it will be achieved by means other than TurboSIM, *then* I'll start wandering what to use my sim for ("cloning" another sim in order to have a second line, maybe? )
    Last edited by pl_svn; 02-09-2008 at 03:52 PM.

  7. #7
    Senior Professional Array

    Join Date
    Sep 2007
    Location
    Land of free USA
    Posts
    126
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    13

    Default

    Ok this is my opinion (I sell *sim),

    I think for those who has *sim should continue to use it for now, or at least untill all the 1.1.3 unlocking settle down. The software is free anyway and you already paid for *sim so take your time

    For those who plan to buy *sim, dont.... unless you want to help seller like me who is stuck

    G.

  8. #8
    Rookie Array

    Join Date
    Dec 2007
    Posts
    13
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Why would you even consider getting rid of your Turbosim? Surely the beauty of the Turbosim is that it can be updated to do any number of things when piggybacked to your sim. I'm certainly keeping mine, ready for the next upgrade.

    Aviegas makes some good points but I would say that Apple has already won, we've all bought an iphone and love playing with them. I'd certainly buy another.

  9. #9
    Advanced Array

    Join Date
    Dec 2007
    Posts
    44
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    This question is the reason why I post this thread.
    http://www.hackint0sh.org/forum/showthread.php?t=28722

    The TurboSIM, SuperSIM, and other programmable SIM can turn to be very good equipment to downgrade BL to either BL3.9 or BL4.6, which have exploits.

    However, please read the thread...

  10. #10
    Professional Array KaSt's Avatar

    Join Date
    Jan 2008
    Posts
    67
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    Geohot unlock also works on 1.1.3 OTB phone (8 and 16Gb) with baseband 04.03.13_G + 1.1.2 OTB phone upgraded through itunes but in each of these instances, the 04.03.13_G cannot be jailbroken but can be unlocked - have I understood that correctly?
    Actually not really. Geohot found a way to patch a BB 4.2.13G and apply it to both a 1.1.2 OTB and a 1.1.3 OTB. In both cases you'll end up with a 4.2.13G, unlocked.

    Meaning that on 1.1.3 Google locate me won't work etc, as using 1.1.2 bb.

    Ka.
    USW51 - 1.1.3 - Bootloadered
    UKW42 - 1.1.3 - Bootloadered


 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 18
    Last Post: 03-25-2008, 06:29 PM
  2. TurboSIM -> software unlock?
    By carrera06 in forum iPhone "2G" (Rev. 1)
    Replies: 2
    Last Post: 02-25-2008, 05:59 PM
  3. Is this new software unlock breakable with future updates?
    By stuppy in forum iPhone "2G" (Rev. 1)
    Replies: 3
    Last Post: 02-10-2008, 04:23 PM
  4. Replies: 11
    Last Post: 09-02-2007, 02:55 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 12:08 AM.
twitter, follow us!