Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 47
Discuss German language Interface for 1.1.1 ? at the Tools - Hackint0sh.org; Originally Posted by sirdir There are 2 files. One are the translations of the touch ...
  1. #21
    Senior Professional Array dragon-tmd's Avatar

    Join Date
    Jul 2007
    Posts
    147
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    14

    Default

    Quote Originally Posted by sirdir View Post
    There are 2 files. One are the translations of the touch applications, the other is a translastion(only german) I made of the iPhone-only (Maps, Weather, SMS, Phone, Notes) applications. it won't replace the applications (it shouldn't ), it only adds languages.
    Sadly you have to translate far more, the whole System\Library\PreferenceBundles ...


  2. #22
    Professional Array

    Join Date
    Oct 2007
    Posts
    98
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    11

    Default

    Quote Originally Posted by dragon-tmd View Post
    Sadly you have to translate far more, the whole System\Library\PreferenceBundles ...
    Isn't most of that in the 1st tar from the touch? My iPhone is quite german now…
    OK, I see, the prefs that don't exist on the touch are partly still in english (i.E carrier selection), but well, as I don't use them every day I won't bother translating them
    The rest is german, though.
    Last edited by sirdir; 10-16-2007 at 11:03 AM.

  3. #23
    Advanced Array

    Join Date
    Sep 2007
    Posts
    41
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I was scared it replaced all my files with yours, but I just copied over with cyberduck and it just added the new ones to my old files.

    It's working really nice, thank you very much!

    P.S: Don't worry about the dictionarys, maybe on 1.1.2...

  4. #24
    Newbie Array

    Join Date
    Sep 2007
    Posts
    7
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default it is working quite well...

    I have sorted only 3 problems out now:

    1. At the calendar application, I have missing points at the date string.

    For example "15 10 2007".

    2. Safari isnt able to connect to the Internet through WLAN. I always got a "NSURLErrorDomain:-1005" error message. iTunes Store, mail and app installer is working.

    3. At the edge settings (at preferences), I can see a key string "EDGE_STATIC_TEXT" below the Edge-Roaming switch.

    Any ideas? Probably some permission glitches? I will have to do some code comparsion..

  5. #25
    Professional Array

    Join Date
    Oct 2007
    Posts
    98
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    11

    Default

    Quote Originally Posted by javinv View Post
    I was scared it replaced all my files with yours, but I just copied over with cyberduck and it just added the new ones to my old files.

    It's working really nice, thank you very much!

    P.S: Don't worry about the dictionarys, maybe on 1.1.2...
    Well, as soon as they start selling the iphone in Spain, there should be a spanish dict. for sure Just hope apple gives up their 'locking'-efforts. By the way, I life in Spain quite a lot (well, don't know wether you do, as most Spanish speaking people don't even live in Spain ) y hablo un poquito español(cada semana un poquito más ).


  6. #26
    Professional Array

    Join Date
    Oct 2007
    Posts
    98
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    11

    Default

    Quote Originally Posted by rototom View Post
    I have sorted only 3 problems out now:

    1. At the calendar application, I have missing points at the date string.

    For example "15 10 2007".
    Maybe this is some glitch in the reginal settings coming from apple(maybe parts of it even don't exist yet… resp. maybe there are more definitions to copy over from the touch)? I'll look at that.

    Edit: Just looked at that on the touch: it's the same, there so that's the way Apple thinks a date should look like…
    It also seems that the °C and °F in Weather App don't work as expected, but I don't think that has something to do with the translation.

    2. Safari isnt able to connect to the Internet through WLAN. I always got a "NSURLErrorDomain:-1005" error message. iTunes Store, mail and app installer is working.
    This has to be another problem. It's working fine here. And I don't see what translations have to do with DNS lookups

    3. At the edge settings (at preferences), I can see a key string "EDGE_STATIC_TEXT" below the Edge-Roaming switch.
    That is because this preferences texts are from the touch and as the touch doesn't have EDGE, that translation is missing. Oh well. To be honest, I don't know wether it's worth the effort to me to change that. (Of course, one had to do that for every langugage…). I think I'm too lazy to find the correstponding file and change that
    If you're not happy with a translation, just delete the language.lproj from the corresponding directory and your're back to 'all-english'. I don't think it makes sense to try to have a prefect solution. When the iPhone comes out in 3 weeks in Germany, there will be a new version with better international support, for sure. My goal was just to have the applications I use everyday to be german. By the way, the translations made by apple aren't that perfact, either. Some are using up more space than there is on the buttoms so it says 'Empfan…' instead of 'Empfangen' and 'Abbrech…' instead of 'Abbrechen' etc. There's still much work to do

    Any ideas? Probably some permission glitches? I will have to do some code comparsion..
    Well, I guess that happens if one enables international functions that aren't really ready yet . But over all, I'm quite happy.
    Last edited by sirdir; 10-16-2007 at 11:33 AM. Reason: News regarding date

  7. #27
    Newbie Array

    Join Date
    Sep 2007
    Posts
    7
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    yes I know.

    It is no problem. I will get those glitches sorted out for shure.

    My safari application was working before without that error. Strange behaviour. But I will also get this worked out...

  8. #28
    Advanced Array

    Join Date
    Sep 2007
    Posts
    41
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Well I'm from spain! we don't really know when will apple want to start selling us the iphone, but anyway I don't find too fair that they don't include that dictionary on the touch just because they're not selling the iphone here... but hey, that's why they think different.

    that safari error doesn't come from this lenguage pack installation since mine works ok over wifi or edge.

    spanish transaltions don't look either perfect, maybe they're a little mexican..

  9. #29
    Professional Array

    Join Date
    Oct 2007
    Posts
    98
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    11

    Default

    Quote Originally Posted by rototom View Post
    yes I know.

    It is no problem. I will get those glitches sorted out for shure.
    Yes, it's not that it were complicated, you just need to add that key to the right file. The files can be opened by the xml editor on the mac.

    My safari application was working before without that error. Strange behaviour. But I will also get this worked out...
    That error means it doesn't find the domain name - maybe there's a problem with the dns configuration or the dns you use isn't working?

  10. #30
    Newbie Array

    Join Date
    Sep 2007
    Posts
    7
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by sirdir View Post
    Yes, it's not that it were complicated, you just need to add that key to the right file. The files can be opened by the xml editor on the mac.



    That error means it doesn't find the domain name - maybe there's a problem with the dns configuration or the dns you use isn't working?
    The safari glitch was a "self healing thing". It is gone know and safari is working as expected. I guess it was an iphone internal dns problem, because other apps were working fine (Mail, Installer, Store..). Nevertheless it is gone know.


 

 
Page 3 of 5 FirstFirst 12345 LastLast

Similar Threads

  1. [Language] Chinese Interface ?
    By raymng in forum Free Toolchain Software (Cydia App's)
    Replies: 5
    Last Post: 06-11-2008, 10:50 PM
  2. iPhone OS from German language to English
    By MacLahoriya in forum General
    Replies: 1
    Last Post: 04-21-2008, 10:50 AM
  3. [1.1.2] German language interface HELP!!
    By Iphornicator in forum Tools
    Replies: 2
    Last Post: 01-05-2008, 01:08 PM
  4. Replies: 5
    Last Post: 12-07-2007, 08:32 PM
  5. German Language Pack for iPhone Available!
    By mycintosh in forum Tools
    Replies: 184
    Last Post: 10-12-2007, 06:47 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 09:32 AM.
twitter, follow us!