Results 1 to 10 of 10
Discuss cant ssh into iPhone since 3.1.2 at the Tools - Hackint0sh.org; updated yesterday to 3.1.2 with pwnagetool. so now i want to change the dock graphic ...
  1. #1
    Senior Professional Array

    Join Date
    Sep 2007
    Posts
    260
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    20

    Default cant ssh into iPhone since 3.1.2

    updated yesterday to 3.1.2 with pwnagetool. so now i want to change the dock graphic and just did what i allways did:

    - installed openssh via cydia
    - started winSCP and entered the following:
    - 192.168.x.xxx, root, alpine, SFTP

    get the message "network error, connection refused"

    did they change the password? or anything that i am missing?



  2. #2
    Supporter Array pconde's Avatar

    Join Date
    Oct 2008
    Location
    Madrid, Spain
    Posts
    239
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    18

    Default

    Quote Originally Posted by nehvada View Post
    updated yesterday to 3.1.2 with pwnagetool. so now i want to change the dock graphic and just did what i allways did:

    - installed openssh via cydia
    - started winSCP and entered the following:
    - 192.168.x.xxx, root, alpine, SFTP

    get the message "network error, connection refused"

    did they change the password? or anything that i am missing?
    After installing openssh, did you reboot the iPhone? The SSH daemon starts at the iPhone boot, if you did not reboot, is not started

  3. #3
    Senior Professional Array

    Join Date
    Sep 2007
    Posts
    260
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    20

    Default

    reboot doesnt help

  4. #4
    Supporter Array pconde's Avatar

    Join Date
    Oct 2008
    Location
    Madrid, Spain
    Posts
    239
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    18

    Default

    Quote Originally Posted by nehvada View Post
    reboot doesnt help
    Search if WinSCP stores the certificates of the remote host. If it does, clean them.

  5. #5
    Professional Array

    Join Date
    Feb 2008
    Location
    Marbella, Spain
    Posts
    67
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    How many times have you tried? When I first SSH into a new device it always takes about 4 or 5 attempts before I can get in....
     iPhone3G S⃣ Black 16GB 3.1.2
     iPhone 3G White 16GB 3.1.2,
     iPhone 8GB 2.2.1,
     MacBook Air 1.8GHz SSD,
     MacPro 2x2.66GHz Dual Core,
     MacMini 1.8GHz C2D,
    BMW Z3 2.8


  6. #6
    Senior Professional Array

    Join Date
    Sep 2007
    Posts
    260
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    20

    Default

    Quote Originally Posted by pconde View Post
    Search if WinSCP stores the certificates of the remote host. If it does, clean them.
    no sessions or certificates stored.

    Quote Originally Posted by philstone View Post
    How many times have you tried? When I first SSH into a new device it always takes about 4 or 5 attempts before I can get in....
    i know, but it usually says "wait another 15 seconds" but here i get the error message almost instantly. tried it like hundred times, no succes.

  7. #7
    Supporter Array pconde's Avatar

    Join Date
    Oct 2008
    Location
    Madrid, Spain
    Posts
    239
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    18

    Default

    Quote Originally Posted by nehvada View Post
    no sessions or certificates stored.



    i know, but it usually says "wait another 15 seconds" but here i get the error message almost instantly. tried it like hundred times, no succes.
    Try to reinstall again openssh.
    Do you have SBSettings installed? There is a SSH toggle to enable/disable it.

  8. #8
    Senior Professional Array

    Join Date
    Sep 2007
    Posts
    260
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    20

    Default

    i had toggleSSH on it as well as open SSH. so i removed toggleSSH and reinstalled openSSH, rebooted, tried again, same result.

    thats really driving me crazy because i did it so many times with different phones...

    this evening i will try it on a mac.

  9. #9
    Supporter Array pconde's Avatar

    Join Date
    Oct 2008
    Location
    Madrid, Spain
    Posts
    239
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    18

    Default

    Quote Originally Posted by nehvada View Post
    i had toggleSSH on it as well as open SSH. so i removed toggleSSH and reinstalled openSSH, rebooted, tried again, same result.

    confused:
    It is extrange... Do you have Terminal installed? If you have it, try to search if the process is launched:

    ps aux |grep ssh

  10. #10
    Supporter Array

    Join Date
    Jan 2008
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    maybe its solved by now, but just in case - here is what worked for me

    open winscp, edit the connection, check advanced options, in SSH/Authentication I checked "Allow agent forwarding"

    and that fixed the issue


 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 02:47 AM.
twitter, follow us!