Page 1 of 8 12345678 LastLast
Results 1 to 10 of 74
Discuss Radeon HD 2X00 cards and drivers at the Tiger - Hackint0sh.org; 10.4.10 dvd from latest imacs has Radeon HD 2X00 drivers inside. If anyone interested in ...
  1. #1
    Engineer Array netkas's Avatar

    Join Date
    Oct 2006
    Posts
    235
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default Radeon HD 2X00 cards and drivers

    10.4.10 dvd from latest imacs has Radeon HD 2X00 drivers inside.
    If anyone interested in getting that to work, lets write here.
    Guess 8.10.3 kernel will be ready soon.



  2. #2
    Professional Array

    Join Date
    Apr 2006
    Posts
    72
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    11

    Default

    iMac Software Update 1.0 has the latest drivers for X2000 series.

    http://www.apple.com/support/downloa...eupdate10.html

  3. #3
    Engineer Array netkas's Avatar

    Join Date
    Oct 2006
    Posts
    235
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    update misses new kernel (8.10.3) and new openGL.framework(for HD 2x00 compatible)

  4. #4
    Rookie Array

    Join Date
    May 2006
    Posts
    10
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Interested to test it out for my 2400HD

  5. #5
    Engineer Array netkas's Avatar

    Join Date
    Oct 2006
    Posts
    235
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    so, what needed, new kernel & system.kext, new opengl framework and few new kexts
    also edited natit
    We have all , but not natit
    post ur dev-id.


  6. #6
    Rookie Array

    Join Date
    May 2006
    Posts
    10
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I have updated my to 10.4.10 using the Turbogirl package. My kernel should be 8.10.3. I do extracted the ATIRadeonX2000 files from imac update. Has tested with the new drivers with my device id 94c3. But when reboot, the screen remains blank after loading the login windows app. Appreciate if you can share me the files. Please also give me some instructions to follow.
    Thank you.

  7. #7
    Advanced Array

    Join Date
    Sep 2006
    Posts
    38
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    ckleea: 10.4.10 you have is not using the 8.10.3 kernel. To see your kernel version go to the terminal and type uname -a. YouŽll need a new kernel, System.kext from new iMac , iMac Frameworks, natit or try Borisbadenov method to try to get it working.
    netkas: IŽm going to buy a new ati 2400card for tests. I guess ioreg from new imac is necessary to modify natit, anybody has that?

  8. #8
    Advanced Array

    Join Date
    Oct 2006
    Posts
    41
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Briefly tried on friend's computer with all the required bits; got the computer to boot, can vnc in, but that's it just a blank screen and no signal to monitor. I tried to edit natit a bit and got as far as a blank screen and the monitor detecting a signal. Should get a chance to have another go later this week.

    P.S. the card was a 2600XT, on a 965 chipset w/ a C2D 4400

  9. #9
    Advanced Array

    Join Date
    Sep 2006
    Posts
    38
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    What kernel and frameworks have you used?

    Quote Originally Posted by consolation View Post
    Briefly tried on friend's computer with all the required bits; got the computer to boot, can vnc in, but that's it just a blank screen and no signal to monitor. I tried to edit natit a bit and got as far as a blank screen and the monitor detecting a signal. Should get a chance to have another go later this week.

    P.S. the card was a 2600XT, on a 965 chipset w/ a C2D 4400

  10. #10
    Professional Array

    Join Date
    Mar 2007
    Posts
    61
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    11

    Default

    someone at IM (doh) got interesting results with a HD2xxx card.
    he edited ATI kext a bit and could boot (black screen)
    when VNCing to his PC, he could see his display was correctly recognized and could switch display resolution.
    unfortunately, since he was using 10.4.9/8.9.1 kernel, nothing else was showing correctly (no QE/CI, and most important, BLACK DISPLAY )


 

 
Page 1 of 8 12345678 LastLast

Similar Threads

  1. ATI Radeon 4650 HD drivers?
    By djole94hns in forum Installation
    Replies: 1
    Last Post: 04-02-2011, 11:23 PM
  2. MacNN: AMD makes Radeon HD 6850, 6870 next-gen cards official
    By hackint0sh in forum Latest Headlines
    Replies: 0
    Last Post: 10-22-2010, 06:30 AM
  3. Is anyone developing drivers for the ATI Mobility Radeon?
    By pepito1 in forum Kernel / Kext (Driver) Support
    Replies: 21
    Last Post: 06-22-2010, 09:20 PM
  4. graphic cards' drivers needed
    By julienrobert in forum Kernel / Kext (Driver) Support
    Replies: 5
    Last Post: 01-12-2010, 04:30 PM
  5. Radeon Callisto Drivers
    By dcreamer in forum Hardware
    Replies: 2
    Last Post: 06-02-2009, 10:35 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 08:54 AM.
twitter, follow us!