Page 3 of 8 FirstFirst 12345678 LastLast
Results 21 to 30 of 74
Discuss Radeon HD 2X00 cards and drivers at the Tiger - Hackint0sh.org; as far as i know and have been into the new imac : hypoprion is ...
  1. #21
    Senior Professional Array

    Join Date
    May 2006
    Posts
    135
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    14

    Default

    as far as i know and have been into the new imac : hypoprion is for HD2600 for sure see my post on insanelymac.
    Guys r u using the new opengl.fk and kernel .3? here is the gl fk in case
    http://forum.insanelymac.com/index.p...=53052&st=520#
    1) C2D E2160@3Ghz | MoBo: ASUS P5E-VM DO | Chipset: ICH9 | No Onboard LAN Intel | Wifi: NetGear WPN311 (recognized as Airport Extreme) | Sound: ALC883 but no 5.1 ch atm | Memory: 2 Gb RAM | Geforce 8600 GT 256 MB/CE/QI | HD: SATA 160GB | DVD : Pioneer 111L 40X/16X | OSX 10.5.2 pc efi v8

    2) C2D E6600@3.53Ghz | MoBo: ASUS P5K | Wifi: RT2500USB | Sound: Onboard ALC883 | Memory: 2 Gb RAM | GeForce 8800GT 512 MB/CE/QI | HD: SAMSUNG SATA-II 500GB | DVD : Pioneer 111L 40X/16X | OSX 10.5.2 pc efi v8


  2. #22
    Advanced Array

    Join Date
    Sep 2006
    Posts
    38
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I´ve used 8.10.1 kernel on 10.4.10 System with old frameworks, as 8.10.3 is not yet available.

  3. #23
    Engineer Array netkas's Avatar

    Join Date
    Oct 2006
    Posts
    235
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    it's available, in private ways
    so, come to irc for that.

  4. #24
    Advanced Array

    Join Date
    Oct 2006
    Posts
    41
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by aed0101 View Post
    What kernel and frameworks have you used?
    As I said, .3 kernel, and kexts + frame work from a new iMac disc. Getting the card recognised is trivial, getting it working is another kettle of fish....

  5. #25
    Senior Professional Array

    Join Date
    May 2006
    Posts
    135
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    14

    Default

    consolidation u r using the .3 kernel hacked + opengl.Fk and drivers for HD2600?? then it should work....or at least it will in 10.4.11 for sure as for X1400
    1) C2D E2160@3Ghz | MoBo: ASUS P5E-VM DO | Chipset: ICH9 | No Onboard LAN Intel | Wifi: NetGear WPN311 (recognized as Airport Extreme) | Sound: ALC883 but no 5.1 ch atm | Memory: 2 Gb RAM | Geforce 8600 GT 256 MB/CE/QI | HD: SATA 160GB | DVD : Pioneer 111L 40X/16X | OSX 10.5.2 pc efi v8

    2) C2D E6600@3.53Ghz | MoBo: ASUS P5K | Wifi: RT2500USB | Sound: Onboard ALC883 | Memory: 2 Gb RAM | GeForce 8800GT 512 MB/CE/QI | HD: SAMSUNG SATA-II 500GB | DVD : Pioneer 111L 40X/16X | OSX 10.5.2 pc efi v8


  6. #26
    Advanced Array

    Join Date
    Sep 2006
    Posts
    38
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I have slightly modified ATY_Hypoprion.kext, removed all ATI kexts save ATIRadeonX2000.kext edited with my cardīs ID, removed Natit.kext and that is what I get: http://www.youtube.com/v/Wgb6g76x5DI
    That is what I get when I VNC from another computer: http://img136.imageshack.us/my.php?image=rtvk3.jpg
    Kext is loaded, but no res change.
    Last edited by aed0101; 08-19-2007 at 01:37 AM.

  7. #27
    Newbie Array

    Join Date
    Aug 2007
    Posts
    8
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Good news with a grain of salt. First thing's first:



    I have image on my DVI port with DVI2VGA apater. DVI doesn't work.

    BUT OpenGL Crashes Dashboard and other aplications (Quake3 for instance).

    I'll be back later posting instructions so far. I've been using 10.4.10 with kernel 8.10.3, but it looks like it could (no guarantees) work on 8.9.1 also.


    HUGE THANKS TO NETKAS AND HIS FRIENDS FOR THEIR PATIENCE AND SUPPORT.
    Last edited by enderwiggin; 08-19-2007 at 01:18 PM.

  8. #28
    Engineer Array netkas's Avatar

    Join Date
    Oct 2006
    Posts
    235
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    OK, status so far is :
    - need to modify framebuffer driver kexts (in atindrv folder)
    other kexts stays unmodified
    - need to use 8.10.3 kernel/system.kext and OPengl.framework from new imacs
    all files we have.

    qe/ci seems to works, as well as opengl, but unstable.
    guess it because enderwiggin has mix of system componnents from different version.

  9. #29
    Newbie Array

    Join Date
    Aug 2007
    Posts
    8
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    So, full procedure on how i got it working:

    1. Clean install Uphuck 10.4.9 1.4i

    2. Updated to 10.4.10, reboot.

    3. Copied System.kext for 10.4.10, 8.10.3 kernel, dsmos kext, and new OpenGL.Framework, repaired permissions, reboot.

    4. Edit ATI Drivers from iMac Update as follows:

    I. ATINDRV.kext

    This kext is comprised by two other kexts: ATY_Hypoprion.kext and ATY_Iago.kext. I edited the ATY_Hypoprion.kext Info.plist, according to Borisbadenov method. ATY_Iago.kext untouched yet. I wouldn't know where to start

    II. ATIRadeonX2000.kext

    I added my cards device and vendor ID: 0x95891002. Tested to see if it loads. It does.

    III. ATIRadeonX2000GA.plugin

    Edited according to the guide, with one comment: the strings

    <key>10029589-0000-0000-0000-000a27898d3e</key>
    <string>10029589-0000-0000-0000-000a27898d3e</string>

    had the original vendor/device code 1002514c which is ATI (1002) but doesn't seem to be Radeon HD device ID.

    5. Copied edited drivers to /System/Library/Extensions, repaired permisions and rebooted.

    The result is what you see here, working, but with bugs, especially in OpenGL.
    Last edited by enderwiggin; 08-19-2007 at 04:42 PM.

  10. #30
    Engineer Array netkas's Avatar

    Join Date
    Oct 2006
    Posts
    235
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    all files and talks at #radeonHD on irc.osx86.hu now


 

 
Page 3 of 8 FirstFirst 12345678 LastLast

Similar Threads

  1. ATI Radeon 4650 HD drivers?
    By djole94hns in forum Installation
    Replies: 1
    Last Post: 04-02-2011, 11:23 PM
  2. MacNN: AMD makes Radeon HD 6850, 6870 next-gen cards official
    By hackint0sh in forum Latest Headlines
    Replies: 0
    Last Post: 10-22-2010, 06:30 AM
  3. Is anyone developing drivers for the ATI Mobility Radeon?
    By pepito1 in forum Kernel / Kext (Driver) Support
    Replies: 21
    Last Post: 06-22-2010, 09:20 PM
  4. graphic cards' drivers needed
    By julienrobert in forum Kernel / Kext (Driver) Support
    Replies: 5
    Last Post: 01-12-2010, 04:30 PM
  5. Radeon Callisto Drivers
    By dcreamer in forum Hardware
    Replies: 2
    Last Post: 06-02-2009, 10:35 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 02:44 AM.
twitter, follow us!