Results 1 to 9 of 9
Discuss Screen Snaps Don't Save? at the Spirit (jailbreak) - Hackint0sh.org; This is a minor issue I am having... When I take a screen shot it ...
  1. #1
    Amazingly Knowledgeable Array

    Join Date
    Oct 2007
    Posts
    790
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    54

    Default Screen Snaps Don't Save?

    This is a minor issue I am having... When I take a screen shot it doesn't save it to the photos app.

    This must be a jailbreak issue... anyone else have this problem?
    iPhone US 8GB
    FW 1.0.2--> iUnlock--> iPhoneSIMfree--> 1.1.1 --> 1.1.2--> Soft upgrade 1.1.3 --> 1.1.4 using signal.app
    iPhone UK 16GB
    FW 1.1.3 OOB --> 1.1.4 --> iPlus 1.2 unlocked!

    <----If I helped you out, rep points are always nice (thanks for that idea!)



  2. #2
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Permissions on the DCIM directory is likely the problem.

    Here is a similar post that might help. As always search before posting - the answer is usually already in another thread

    http://www.hackint0sh.org/f146/114163.htm#post503458
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  3. #3
    Amazingly Knowledgeable Array

    Join Date
    Oct 2007
    Posts
    790
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    54

    Default

    This is on iPad - And I checked the permissions and it said this:

    Olivers-iPad-Wifi:~ mobile$ ls -l ~/Media | grep DCIM
    drwxr-x--- 4 mobile mobile 204 May 5 21:15 DCIM/
    Olivers-iPad-Wifi:~ mobile$ ls -l ~/Media/DCIM
    total 16
    drwx------ 3 root mobile 136 May 3 22:18 100APPLE/
    -rw-r--r-- 1 mobile mobile 6905 May 5 06:14 2010.05.05-06.12.36-IMPlus.log
    -rw-r--r-- 1 mobile mobile 6830 May 5 21:16 2010.05.05-21.15.04-IMPlus.log

    What can I do to get the screen shots saving again?
    iPhone US 8GB
    FW 1.0.2--> iUnlock--> iPhoneSIMfree--> 1.1.1 --> 1.1.2--> Soft upgrade 1.1.3 --> 1.1.4 using signal.app
    iPhone UK 16GB
    FW 1.1.3 OOB --> 1.1.4 --> iPlus 1.2 unlocked!

    <----If I helped you out, rep points are always nice (thanks for that idea!)

  4. #4
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by Spinstorm View Post
    drwx------ 3 root mobile 136 May 3 22:18 100APPLE/
    This line is your problem

    Open a shell on your iPhone (mobile terminal or via SSH)

    make sure you are root user - it should not say
    mobile$
    instead it should say
    root#
    you can also check by typing
    Code:
    id
    which should say
    uid=0(root)
    To become root (if you are not already) type:
    Code:
    su
    Once you are root type:
    Code:
    chown mobile:mobile /var/mobile/Media/DCIM/100APPLE
    ls -l /var/mobile/Media/DCIM
    The result should be similar to this.
    drwx------ 3 mobile mobile 4896 May 5 13:09 100APPLE/
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  5. #5
    Amazingly Knowledgeable Array

    Join Date
    Oct 2007
    Posts
    790
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    54

    Default

    I did that and it saves the photos but the photos then do not display properly and are just either blank or a white screen and on one occasion mobile substrate crashed.

    Any suggestions? Thanks for your help so far.

    This is what I got back when I typed what you said:

    /private/var/root$ chown mobile:mobile /var/mobile/Media/DCIM/100APPLE
    /private/var/root$ ls -l /var/mobile/Media/DCIM
    total 16
    drwx------ 3 mobile mobile 204 May 7 01:21 100APPLE
    -rw-r--r-- 1 mobile mobile 6905 May 5 06:14 2010.05.05-06.12.36-IMPlus.log
    -rw-r--r-- 1 mobile mobile 6830 May 5 21:16 2010.05.05-21.15.04-IMPlus.log
    iPhone US 8GB
    FW 1.0.2--> iUnlock--> iPhoneSIMfree--> 1.1.1 --> 1.1.2--> Soft upgrade 1.1.3 --> 1.1.4 using signal.app
    iPhone UK 16GB
    FW 1.1.3 OOB --> 1.1.4 --> iPlus 1.2 unlocked!

    <----If I helped you out, rep points are always nice (thanks for that idea!)


  6. #6
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by Spinstorm View Post
    I did that and it saves the photos but the photos then do not display properly and are just either blank or a white screen and on one occasion mobile substrate crashed.
    Then you have installed a package that modified the OS incorrectly or some mobile substrate addon that is causing the problem (or you have a hardware problem with the camera module)

    Does it work in mobile substrate safe mode?
    If you remove all existing photos, does that help?

    Aside from that, it's hard to troubleshoot further without more information (what Cydia/Rock/Icy packages that might be suspects for example)
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  7. #7
    Super Moderator Array n1ckn4m3's Avatar

    Join Date
    Mar 2009
    Location
    USA
    Posts
    2,717
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    145

    Default

    Quote Originally Posted by Spinstorm View Post
    I did that and it saves the photos but the photos then do not display properly and are just either blank or a white screen and on one occasion mobile substrate crashed.
    I'm going to guess that whatever ruined the permissions on the actual folder likely ruined the permissions on the files themselves as well. Change directory to the 100APPLE folder and drill down until you're at the files themselves. Make sure when you do the ls -al that you get the mobile mobile response and not the root response. Every file in that directory should be owned by the mobile user and not by the root user. Anything owned by root may be denied access or render incorrectly by the photo app, since the photo app runs in the context of the mobile user.
    The preceding forum post has been brought to you by the letter "N" and the number 42.

    iPhone 4, 32GB (iOS 6.1.2 | evasi0n | SHSH: 4.0 - 6.1.2)
    iPad 2 3G, 64GB (iOS 6.1.2 | evasi0n
    |
    SHSH: 4.3 & 4.3.3 - 6.1)

    Restore problems? Read this: http://www.hackint0sh.org/f137/130802.htm

    Did we solve your problem? Got a dollar or two spare? Please Donate!


  8. #8
    Amazingly Knowledgeable Array

    Join Date
    Oct 2007
    Posts
    790
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    54

    Default

    That makes sense. Thanks guy.

    I actually have another bug.

    I can't update apps from the app store without deleting them.

    Any app with an update when I click on update gives me a "cannot connect to iTunes" error.

    Deleting the app and Downloading it from scratch works but it's annoying!
    iPhone US 8GB
    FW 1.0.2--> iUnlock--> iPhoneSIMfree--> 1.1.1 --> 1.1.2--> Soft upgrade 1.1.3 --> 1.1.4 using signal.app
    iPhone UK 16GB
    FW 1.1.3 OOB --> 1.1.4 --> iPlus 1.2 unlocked!

    <----If I helped you out, rep points are always nice (thanks for that idea!)

  9. #9
    Super Moderator Array n1ckn4m3's Avatar

    Join Date
    Mar 2009
    Location
    USA
    Posts
    2,717
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    145

    Default

    Quote Originally Posted by Spinstorm View Post
    I can't update apps from the app store without deleting them.

    Any app with an update when I click on update gives me a "cannot connect to iTunes" error.

    Deleting the app and Downloading it from scratch works but it's annoying!
    I've only seen this behavior on phones that had the MobileInstallation hack installed for less than legitimate means. If this applies to you, remove that hack and reboot the phone entirely. The modifications that certain programs make to the MobileInstallation file wreak havoc with legitimately purchased programs.

    If you have no idea what I'm talking about and haven't ever patched MobileInstallation and have no idea why you ever would, good! You should be able to deauthorize and reauthorize your computer, then disable App Sync in iTunes (wiping your device of all your apps) then re-enable App Sync in iTunes to replace them all with clean copies that should update -- without you manually having to download them one at a time.
    The preceding forum post has been brought to you by the letter "N" and the number 42.

    iPhone 4, 32GB (iOS 6.1.2 | evasi0n | SHSH: 4.0 - 6.1.2)
    iPad 2 3G, 64GB (iOS 6.1.2 | evasi0n
    |
    SHSH: 4.3 & 4.3.3 - 6.1)

    Restore problems? Read this: http://www.hackint0sh.org/f137/130802.htm

    Did we solve your problem? Got a dollar or two spare? Please Donate!


 

 

Similar Threads

  1. Replies: 0
    Last Post: 07-28-2011, 07:00 PM
  2. MacNN: Apple snaps up iPhone4.com, WhiteiPhone.com domains
    By hackint0sh in forum Latest Headlines
    Replies: 0
    Last Post: 07-13-2011, 05:40 PM
  3. MacNN: Google snaps up AdMob for $750 million
    By hackint0sh in forum Latest Headlines
    Replies: 0
    Last Post: 11-09-2009, 10:20 PM
  4. MacNN: Bell snaps up Virgin Mobile Canada
    By hackint0sh in forum Latest Headlines
    Replies: 0
    Last Post: 05-07-2009, 03:30 PM
  5. MacNN: AT&T snaps up Wayport to add more Wi-Fi
    By hackint0sh in forum Latest Headlines
    Replies: 0
    Last Post: 11-06-2008, 05:20 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 03:17 PM.
twitter, follow us!