Results 1 to 10 of 10
Discuss Jailbreaking with new RedSn0w with old bootrom problem! at the Redsn0w - Hackint0sh.org; ...
  1. #1
    Newbie Array

    Join Date
    Dec 2011
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Jailbreaking with new RedSn0w with old bootrom problem!

    So I made a custom IPSW that didn't effect my baseband and restored to that.

    But since I have an old bootrom, I got this message

    "
    The IPSW for the following build is needed:
    iPhone2,1_5.0.1_9A404

    The required IPSW is either not public or not
    available right now. Please provide it
    manually using "Extras->Select IPSW".

    Note: If you provide this IPSW once, it will be
    cached so that you don't need to provide it again.
    "

    There was a response to this by the creator of Redsn0w and he wrote:

    "Update #17d: iPhone3GS owners in our comments section below noticed a problem with the untethered jailbreak available for the old-bootrom 3GS. We’ve corrected that problem in 0.9.9b9d. If you have an old-bootrom 3GS and have already used last night’s redsn0w on it, you can re-run it again without losing anything. Just use this new version, go to Extras->IPSW and manually select the 5.0.1 IPSW, then go back and Jailbreak it again (but you can uncheck Cydia because it’s already installed)."

    He mentions that you should manually select the 5.0.1 IPSW. I made a custom one that doesn't affect my BB, but I tried to select that one and it didn't work. Do I just select the one issued by Apple?

    Thanks.



  2. #2
    Rookie Array

    Join Date
    Jul 2010
    Posts
    12
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I am glad to know I am not alone. I have exactly the same problem. If iPhone2,1_5.0.1_9A404 exists I cannot find it, I did the build with iPhone2,1_5.0.1_9A405, and neither the BB build or the Apple ipsw resolves the issue.
    Last edited by probono; 12-26-2011 at 02:08 PM.

  3. #3
    Rookie Array

    Join Date
    Jul 2010
    Posts
    12
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I think I resolved the error

    1. Build the custom No BB ipsw in extras and upload in itunes

    then restart redsn0w

    2. in extras select the apple iPhone2,1_5.0.1_9A405
    3. then jailbreak, using the apple file for the jailbreak after uploading the custom no bb old file does not update the baseband

    anyhow it worked
    Last edited by probono; 12-27-2011 at 03:58 PM.

  4. #4
    Super Moderator Array n1ckn4m3's Avatar

    Join Date
    Mar 2009
    Location
    USA
    Posts
    2,717
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    145

    Default

    You're correct. You point redsn0w at the untouched / original .IPSW -- not at a custom firmware. Since redsn0w is NOT restoring the iOS version to your phone, this has no threat of updating.
    The preceding forum post has been brought to you by the letter "N" and the number 42.

    iPhone 4, 32GB (iOS 6.1.2 | evasi0n | SHSH: 4.0 - 6.1.2)
    iPad 2 3G, 64GB (iOS 6.1.2 | evasi0n
    |
    SHSH: 4.3 & 4.3.3 - 6.1)

    Restore problems? Read this: http://www.hackint0sh.org/f137/130802.htm

    Did we solve your problem? Got a dollar or two spare? Please Donate!


  5. #5
    RAC
    RAC is offline
    Newbie Array

    Join Date
    Dec 2011
    Posts
    5
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I have the exactly same problem....

    Created custom IPSW using redsnow 0.9.10b1 from iPhone2,1_5.0.1_9A405.

    Uploaded the Custom IPSW using Itunes and it completed all but now my screen is black and i am stuck in DFU mode. I tried to jailbreak and tethered boot but none of it is working, it gives the same message:
    The IPSW for the following build is needed:
    iPhone2,1_5.0.1_9A404

    The required IPSW is either not public or not
    available right now. Please provide it
    manually using "Extras->Select IPSW".

    Note: If you provide this IPSW once, it will be
    cached so that you don't need to provide it again.
    "

    I was just trying to untethered jailbreak to 5.0.1 from 4.0 with preservation of my baseband to use ultrasnow to unlock later.

    Any info would be appreciated. Thx


  6. #6
    Super Moderator Array n1ckn4m3's Avatar

    Join Date
    Mar 2009
    Location
    USA
    Posts
    2,717
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    145

    Default

    Did you restore in Pwned DFU mode? Custom restores with no baseband on iOS 5+ require Pwned DFU mode in order to restore successfully, else you'll be stuck in a restore loop due to the baseband.

    Secondarily, you can manually download the iPhone2,1_5.0.1_9A404.ipsw from iClarified if you want, it's available. Then point redsn0w at it. Not sure why it's barking that it can't find it, but since the file's available, just grab it and point redsn0w to it once.
    The preceding forum post has been brought to you by the letter "N" and the number 42.

    iPhone 4, 32GB (iOS 6.1.2 | evasi0n | SHSH: 4.0 - 6.1.2)
    iPad 2 3G, 64GB (iOS 6.1.2 | evasi0n
    |
    SHSH: 4.3 & 4.3.3 - 6.1)

    Restore problems? Read this: http://www.hackint0sh.org/f137/130802.htm

    Did we solve your problem? Got a dollar or two spare? Please Donate!


  7. #7
    RAC
    RAC is offline
    Newbie Array

    Join Date
    Dec 2011
    Posts
    5
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Yeah i used Pwned mode through redsnow(the lastest one b3) and uploaded the custom IPSW iPhone2,1_5.0.1_9A405 through itunes, I have done it thrice now and everytime if finishes successfully with the white bar on iphone going all the way and itunes saying your phone will restart but the phone stays black and nothing comes up and still stuck in DFU mode.

    I also tried to use iPhone2,1_5.0.1_9A404 in redsnow and tried to boot it up and jailbreak but it says "the connected device doest support untethered options"

    Also i installed back the custom IPSW 4.1 that was running before on my phone and now phone finally came up and running.

    The problem seems to be in the 3GS oldbootrom because 4.1 doesnt ask you what bootrom are you using, so if anyone has any resolution on how to install ios 5.0.1 on 3GS oldbootrom with preservation of BB please let us know. Thx
    Last edited by RAC; 12-30-2011 at 05:29 AM.

  8. #8
    Super Moderator Array n1ckn4m3's Avatar

    Join Date
    Mar 2009
    Location
    USA
    Posts
    2,717
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    145

    Default

    Have you tried using redsn0w 0.9.10b3? I believe this may be fixed. Alternately, you can use the older redsn0w for 5.0.0 (which also works on 5.0.1 if you point it at the 5.0.0 .IPSW) as your phone doesn't require the corona untether since it's an old bootrom iPhone anyways.
    The preceding forum post has been brought to you by the letter "N" and the number 42.

    iPhone 4, 32GB (iOS 6.1.2 | evasi0n | SHSH: 4.0 - 6.1.2)
    iPad 2 3G, 64GB (iOS 6.1.2 | evasi0n
    |
    SHSH: 4.3 & 4.3.3 - 6.1)

    Restore problems? Read this: http://www.hackint0sh.org/f137/130802.htm

    Did we solve your problem? Got a dollar or two spare? Please Donate!


  9. #9
    RAC
    RAC is offline
    Newbie Array

    Join Date
    Dec 2011
    Posts
    5
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Yeah i initially did it with b3 and also tried the latest one relaesed on dec 26 which is redsn0w_win_0.9.9b9d but no luck, same thing the phone completes the upload via i tunes and i get a messeage and your phone will restart with the new IOS but the phone never boots up hence stuck in DFU mode.

    The problem is in the bootrom using redsnow as the phone never boots up after completing so will wait untill they come up with a new redsnow or snowbreeze for this bootrom fix.

  10. #10
    Super Moderator Array n1ckn4m3's Avatar

    Join Date
    Mar 2009
    Location
    USA
    Posts
    2,717
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    145

    Default

    That's odd, I used a beta of 0.9.9 to jailbreak my 3GS and it asked me the bootrom question, etc. I hate to say I can't recall specifically what version, it was one of the originals from when 5.0 was released and jailbroken... Sorry I can't be more help, but you can definitely step backwards in redsn0w versions until you get to a version that asks you the question -- I'm 100% certain that at least one version exists that will JB 5.0 and 5.0.1 AND supports the old bootrom 3GS.
    The preceding forum post has been brought to you by the letter "N" and the number 42.

    iPhone 4, 32GB (iOS 6.1.2 | evasi0n | SHSH: 4.0 - 6.1.2)
    iPad 2 3G, 64GB (iOS 6.1.2 | evasi0n
    |
    SHSH: 4.3 & 4.3.3 - 6.1)

    Restore problems? Read this: http://www.hackint0sh.org/f137/130802.htm

    Did we solve your problem? Got a dollar or two spare? Please Donate!



 

 

Similar Threads

  1. Problem after Jailbreaking with Redsn0w - Cydia wont work
    By thms in forum iOS 3.x (iPhone OS 3.x)
    Replies: 2
    Last Post: 04-07-2011, 11:39 AM
  2. Replies: 3
    Last Post: 09-22-2010, 10:19 AM
  3. Replies: 10
    Last Post: 04-09-2010, 01:57 AM
  4. redsn0w or pwnage for jailbreaking?
    By rrpalma in forum Redsn0w
    Replies: 2
    Last Post: 06-23-2009, 06:49 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 05:53 AM.
twitter, follow us!