Page 1 of 4 1234 LastLast
Results 1 to 10 of 36
Like Tree7Likes
Discuss iPhone 3G iOS 4.2.1 No Wi-Fi and No Service after downgrade from 06.15.00 to 05.13.04 at the Redsn0w - Hackint0sh.org; Hi there! I have an iPhone 3G with jailbroken iOS 4.2.1 on it. I read ...
  1. #1
    Rookie Array

    Join Date
    Feb 2010
    Posts
    20
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default iPhone 3G iOS 4.2.1 No Wi-Fi and No Service after downgrade from 06.15.00 to 05.13.04

    Hi there!
    I have an iPhone 3G with jailbroken iOS 4.2.1 on it. I read an older article and installed 06.15.00 iPad firmware in order to unlock it so I can use it for what it should be (a phone). It had major battery drain issues and GPS was not working (the default problems), so I searched around some more and found out that the baseband can actually be downgraded from 06.15.00 to 05.13.04 now, so I went at it. The first try did not succeed and I was still on 06.15.00 after trying to downgrade it with redsn0w 0.9.14b1, I reinstalled the 06.15.00 baseband and tried downgrading it again with the newest redsn0w 0.9.14b2 version. This time I succeeded.
    However, now in the information section by Modem Firmware it was completely blank, but I knew that this time it downgraded, since it didn't show 06.15.00 anymore, so that counts for something, right?
    Here is the problem though, now I get no signal, and my phone says no wi-fi also. I have read that the no signal problem can be fixed by reinstalling ultrasn0w and Mobile Substrate, but I can't do that with both no signal and no wi-fi.
    What are my options here?

  2. Thanks athein thanked for this post.
    Like athein liked this post.


  3. #2
    Senior Professional Array x98car's Avatar

    Join Date
    Nov 2007
    Posts
    333
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    24

    Default

    Try restoring to a regular 4.2.1 firmware to see if that puts your baseband back on there. Right now it sounds like your baseband is corrupt.

  4. #3
    sam
    sam is offline
    Chief of Administration
    iPhone Dev Team
    Array sam's Avatar

    Join Date
    Jun 2007
    Posts
    1,852
    Post Thanks / Like
    Downloads
    35
    Uploads
    277
    Rep Power
    10

    Default

    If the BB is corrupt, I hope you can get it back, if you really manage to fry it it's possible you can throw the phone away or use it as an expensive paper weight.
    If you just want to support hackint0sh.org with a donation click here.
    Follow me on twitter: http://twitter.com/sam_hackint0sh

  5. #4
    Rookie Array

    Join Date
    Feb 2010
    Posts
    20
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Holy shit! Restored to a clean 4.2.1 firmware, jailbraked it with redsn0w and now it's fixed!
    05.15.04 firmware, everything is working. Thanks!
    Where do I go from here, do I need to downgrade 05.15.04 to 05.13.04, or is there no need for that?

  6. #5
    Senior Professional Array x98car's Avatar

    Join Date
    Nov 2007
    Posts
    333
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    24

    Default

    If you don't want to unlock it just leave it as is. If you still need to unlock you will need to update to 6.15 baseband then downgrade to 5.13. Do you know what bootloader you have? If not you can find out with f0recast. You should find that out first before doing anything.


  7. #6
    Rookie Array

    Join Date
    Feb 2010
    Posts
    20
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    The bootloader is 6.4_M3S2, I searched around and it looks like only 5.8 can be downgraded to 05.13.04
    Fucking bullshit. This means I have to install 06.15.00 baseband again, and downgrading will most likely end up with corrupted BB once again.
    And I do need it unlocked, otherwise it's useless.
    God damn.

  8. #7
    Senior Professional Array x98car's Avatar

    Join Date
    Nov 2007
    Posts
    333
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    24

    Default

    That's old info. Redsnow 0.9.14b2 can downgrade 6.15 to 5.13 now on any 3G or 3GS. Sounds like something just went wrong the first time you tried it.

  9. #8
    Rookie Array

    Join Date
    Feb 2010
    Posts
    20
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    It seems like not every 3G can be downgraded apparently. I have gone through this twice, and both times it ended up with corrupt baseband, no wifi, no bluetooth, no imei and no service.
    The process goes through solid every time, but it ends up corrupt. Could it be some rare piece of hardware that still can't be downgraded?

  10. #9
    Senior Professional Array x98car's Avatar

    Join Date
    Nov 2007
    Posts
    333
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    24

    Default

    Might be, MuscleNerd probably wasn't able to test it on every single hardware revision of 3G and 3GS's. If that's the case and you need an unlock you can either update to the ipad baseband again and just use that. Or if it is an ATT iPhone ATT should be able to unlock if for you at this point.

    If you are feeling adventurous you may try and downgrade the baseband again and when you are at the point where the baseband is missing try restoring to 3.1.3 instead of 4.2.1 to see if it loads that baseband (5.12 I think it was). That baseband can be unlocked.

  11. Thanks egon olsen thanked for this post.
    Like egon olsen liked this post.
  12. #10
    Rookie Array

    Join Date
    Feb 2010
    Posts
    20
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Can't really use 06.15.00 baseband, it drains the battery and uses my cellular network all the time looking for push certificates, and that can't be fixed since Apple blocked SAM a few months ago. The phone overheats and becomes unusable eventually.
    I tried contacting MuscleNerd on Facebook about this, but had no response. Know any other ways to contacting him?
    Official activation is sadly not an option.

    Alright, I downgraded and I am at the point with no BB again. What FW should I try restoring?
    If I restore to 3.1.3 with 5.12, will the baseband be preserved to 4.2.1? I was on 3.1.3 before with 06.15.00, it ran perfectly, but could literally run none of the new apps in the market today. So I would not like to stay on 3.1.3 again.
    Maybe I should try 4.1? iOS 4 appearantly has 05.13.04 as the default baseband, but could it really be updated on the phone in this state?


 

 
Page 1 of 4 1234 LastLast

Similar Threads

  1. Replies: 23
    Last Post: 06-03-2013, 12:43 PM
  2. No service, downgrade possible?
    By deiphonelvr in forum Blacksn0w (3G(S) unlock)
    Replies: 1
    Last Post: 04-25-2010, 09:47 PM
  3. Replies: 0
    Last Post: 07-18-2008, 06:35 AM
  4. Replies: 8
    Last Post: 12-11-2007, 01:21 AM
  5. iPhone Unlocking Service in the UK. Speedy Service!
    By arthertbc0702 in forum Flea Market
    Replies: 0
    Last Post: 10-04-2007, 03:06 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 06:07 AM.
twitter, follow us!