Results 1 to 3 of 3
Discuss Which is Compatible 3.1.2 firmware for existing 2.2.1 (5H11) at the Redsn0w - Hackint0sh.org; I am using 16 GB 2G phone brought from US in Feb2008, jailbroken first with ...
  1. #1
    Rookie Array

    Join Date
    Nov 2007
    Location
    New Delhi
    Posts
    22
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Which is Compatible 3.1.2 firmware for existing 2.2.1 (5H11)

    I am using 16 GB 2G phone brought from US in Feb2008, jailbroken first with ziphone whereby bootloader was downgraded to 3.9; then restored and again jailbroken with iplus. Thereafter I Upgraded to firmware version 2.2.1 (5H11) a few months back. Now I am facing problem with SMS programme and want to upgrade to 3.1.2 version.

    I read this forum and also iClarified - iPhone - How to Unlock/Jailbreak Your iPhone 2G on OS 3.1.2 Using RedSn0w (Windows), downloaded files but when I try to restore from iTunes using version 9.0.2.25, I get a message "iphone ___ could not be restored because the firmware file is not compatible.

    I am currently having 2.2.1 (5H11) firmware though my phone is 2G. I checked on iclarified different versions of firmware and noted with surprise that there were two versions of 2.2.1 but I am using one for 3G though my phone is 2G. (Surprised how 3 G version of firmware working on 2G hardware or how my iphone is showing 5H11 instead of 5H1)) Two versions stated there are as follows :
    2.2.1 (2G): iPhone1,1_2.2.1_5H1_Restore.ipsw
    2.2.1 (3G): iPhone1,2_2.2.1_5H11_Restore.ipsw

    A. Now that I am getting non-compatible firmware message with iphone1,1,3.1.2, should I try iphone 1,2,3.1.2 or should I try 3.0.1 version as follows :
    3.1.2 (2G): iPhone1,1_3.1.2_7D11_Restore.ipsw (message non-compatible)
    Should I try 3.0.1 (2G): iPhone1,1_3.0.1_7A400_Restore.ipsw OR
    3.1.2 (3G): iPhone1,2_3.1.2_7D11_Restore.ipsw.

    B. Whether I can use the Redsn0w version 0.9.2 for unlocking / jailbreak with 3.0.1 firmware.

    C. What can be the reason for iTunes not finding 3.1.2 compatible with my iphone?
    Last edited by goyalvimal; 02-14-2010 at 07:16 PM.



  2. #2
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    The iClarified page is incorrect.

    5H11 is the version for both 2G and 3G

    Post a iPhone restore log and we can see why it was rejected.
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  3. #3
    Administrator Array

    Join Date
    Oct 2007
    Posts
    4,145
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    Quote Originally Posted by goyalvimal View Post
    A. Now that I am getting non-compatible firmware message with iphone1,1,3.1.2, should I try iphone 1,2,3.1.2 or should I try 3.0.1 version as follows :
    3.1.2 (2G): iPhone1,1_3.1.2_7D11_Restore.ipsw (message non-compatible)
    Should I try 3.0.1 (2G): iPhone1,1_3.0.1_7A400_Restore.ipsw OR
    3.1.2 (3G): iPhone1,2_3.1.2_7D11_Restore.ipsw.
    - the iPhone1,1 is always the firmware for 2G iphone
    - the iPhone1,2 is always the firmware for 3G iphone
    - the iPhone2,1 is always the firmware for 3GS iphone


    B. Whether I can use the Redsn0w version 0.9.2 for unlocking / jailbreak with 3.0.1 firmware.
    Yes but when you run redsn0w, point it to firmware 3.0 and not 3.0.1

    C. What can be the reason for iTunes not finding 3.1.2 compatible with my iphone?
    Because you are using the wrong firmware. you need to use iPhone1,1
    ** If you just want to support hackint0sh.org with a donation click here **

 

 

Similar Threads

  1. iOS 4 Firmware Not Compatible
    By zachxd in forum iPod Touch 2G
    Replies: 1
    Last Post: 06-28-2010, 06:58 AM
  2. firmware not compatible during jailbreak ??
    By sfaguy in forum iOS 3.x (iPhone OS 3.x)
    Replies: 3
    Last Post: 08-05-2009, 06:31 AM
  3. firmware not compatible
    By noob015 in forum Redsn0w
    Replies: 5
    Last Post: 07-22-2009, 08:10 PM
  4. Replies: 1
    Last Post: 02-22-2009, 09:10 PM
  5. Replies: 6
    Last Post: 06-07-2008, 09:21 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 12:25 PM.
twitter, follow us!