Page 1 of 2 12 LastLast
Results 1 to 10 of 14
Discuss [Pwnagetool] OpenSSH problem at the PwnageTool - Hackint0sh.org; Here's the situation; i need to install openssh via a custompackage in pwnage, now when ...
  1. #1
    boz
    boz is offline
    Senior Professional Array

    Join Date
    Nov 2007
    Posts
    159
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    14

    Default [Pwnagetool] OpenSSH problem

    Here's the situation; i need to install openssh via a custompackage in pwnage, now when i restore the phone with the custom ipsw openssh does not work right out the restore, the problem with this is that the iphone's screen doesn't work anymore so i can't uninstall and reinstall openssh via cydia...

    so i need to have openssh installed and ready after the restore.
    rather i'd need veency, but openssh would be a step in the right direction

    any idea's why this happens?
    and how to solve it?

    boz
    'There is no I in threesome'



  2. #2
    iPhone Moderator Array

    Join Date
    Aug 2007
    Posts
    3,620
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    220

    Default

    Quote Originally Posted by boz View Post
    Here's the situation; i need to install openssh via a custompackage in pwnage, now when i restore the phone with the custom ipsw openssh does not work right out the restore, the problem with this is that the iphone's screen doesn't work anymore so i can't uninstall and reinstall openssh via cydia...

    so i need to have openssh installed and ready after the restore.
    rather i'd need veency, but openssh would be a step in the right direction

    any idea's why this happens?
    and how to solve it?

    boz
    Did you create a custom OpenSSH package that is conform with pwnagetool? Did not chenge much, check this thread to get an idea what to do
    Read the stickies and search the forum before posting!
    If you want to become a Hackint0sh supporter click here
    ----------
    iPhone 4 factory unlocked, iOS 4.3.1, jailbroken
    iPad Wi-Fi + 3G (1G), iOS 4.3.1, jailbroken
    iPad 2

  3. #3
    boz
    boz is offline
    Senior Professional Array

    Join Date
    Nov 2007
    Posts
    159
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    14

    Default

    i used the included custom packages installer via expert mode, don't know if that's wrong
    'There is no I in threesome'

  4. #4
    iPhone Moderator Array

    Join Date
    Aug 2007
    Posts
    3,620
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    220

    Default

    Quote Originally Posted by boz View Post
    i used the included custom packages installer via expert mode, don't know if that's wrong
    Ok, so you used the cydia Package Installer? Selected "Load Packages" and downloaded and then selected OpenSSH in PwnageTool?

    this should work, did for me. Maybe it needs one more rebbot of the iPhone cause at the first launch all the stuff gets executed (installed) on the iPhone when you applied the custom firmware.
    Read the stickies and search the forum before posting!
    If you want to become a Hackint0sh supporter click here
    ----------
    iPhone 4 factory unlocked, iOS 4.3.1, jailbroken
    iPad Wi-Fi + 3G (1G), iOS 4.3.1, jailbroken
    iPad 2

  5. #5
    boz
    boz is offline
    Senior Professional Array

    Join Date
    Nov 2007
    Posts
    159
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    14

    Default

    Quote Originally Posted by volkspost View Post
    Ok, so you used the cydia Package Installer? Selected "Load Packages" and downloaded and then selected OpenSSH in PwnageTool?

    this should work, did for me. Maybe it needs one more rebbot of the iPhone cause at the first launch all the stuff gets executed (installed) on the iPhone when you applied the custom firmware.
    i know it should work, the problem is it doesn't..
    rebooted a few times, still getting
    ssh_exchange_identification: Connection closed by remote host

    installed bossprefs and am able to activate and deactivate openssh via bossprefs, because 2cm of the topscreen still works. but to no avail..
    i actually need veency, but also that doesn't work when installed via cydia Package Installer in pwnage..
    'There is no I in threesome'


  6. #6
    iPhone Moderator Array

    Join Date
    Aug 2007
    Posts
    3,620
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    220

    Default

    Quote Originally Posted by boz View Post
    i know it should work, the problem is it doesn't..
    rebooted a few times, still getting
    ssh_exchange_identification: Connection closed by remote host

    installed bossprefs and am able to activate and deactivate openssh via bossprefs, because 2cm of the topscreen still works. but to no avail..
    i actually need veency, but also that doesn't work when installed via cydia Package Installer in pwnage..
    did you delete the file known_hosts? At least on a Mac it stores the key that is generated. Once you restore to another (new) firmware and try connecting via Terminal (SSH) to the iPhone it refuses the connection.
    On a Mac
    rm ~/.ssh/known_hosts
    removes the file and you are able to connect
    Read the stickies and search the forum before posting!
    If you want to become a Hackint0sh supporter click here
    ----------
    iPhone 4 factory unlocked, iOS 4.3.1, jailbroken
    iPad Wi-Fi + 3G (1G), iOS 4.3.1, jailbroken
    iPad 2

  7. #7
    boz
    boz is offline
    Senior Professional Array

    Join Date
    Nov 2007
    Posts
    159
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    14

    Default

    I figured that could be the case so i have deleted that file a few times now, also tried with fugu, deleted it's know_hosts file too, but again to no avail.

    Tried with 2.1 FW but again, no luck in getting it started, deactivated in bossprefs, restarted, activated, but again... no ssh possible

    terminal report;

    Power-Mac:~ $ ssh root@192.168.1.2
    ssh_exchange_identification: Connection closed by remote host
    ssh on with bossprefs

    ssh: connect to host 192.168.1.2 port 22: Connection refused
    when i close it down with bossprefs

    perhaps it's possible to check the launch-deamon if ssh gets activated anyway?

    thanks for taking an intrest btw volkspost
    'There is no I in threesome'

  8. #8
    boz
    boz is offline
    Senior Professional Array

    Join Date
    Nov 2007
    Posts
    159
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    14

    Default

    Quote Originally Posted by boz View Post
    I figured that could be the case so i have deleted that file a few times now, also tried with fugu, deleted it's know_hosts file too, but again to no avail.

    Tried with 2.1 FW but again, no luck in getting it started, deactivated in bossprefs, restarted, activated, but again... no ssh possible

    terminal report;

    Power-Mac:~ $ ssh root@192.168.1.2
    ssh_exchange_identification: Connection closed by remote host
    ssh on with bossprefs

    ssh: connect to host 192.168.1.2 port 22: Connection refused
    when i close it down with bossprefs

    perhaps it's possible to check the launch-deamon if ssh gets activated anyway?

    thanks for taking an intrest btw volkspost

    PROGRESS; i was able to get veency to work on the iphone, i copied the working veency files from my 3G to the phone. so openssh is not needed anymore... the main shitty problem is; i can't hit the accept button from veency... it needs to be removed or moved up to the first line.

    problem; i can't edit .dylib files without ruining them...

    if you could help me with that that'd be great

    boz
    'There is no I in threesome'

  9. #9
    Senior Professional Array unl0cker's Avatar

    Join Date
    Jul 2007
    Location
    In my Mind
    Posts
    128
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    14

    Default

    The SSH problem sounds like is a problem with the file /etc/ssh/sshd_config in the iPhone. It's nothing to do with the know_hosts file in your mac.

    When you add the OpenSSH package using pwnage, what source are you using? I use the default that comes with pwnage and worked ok for me.

    Another thing, do a fresh sync, do not use backups at the end of the restore/update
    Last edited by unl0cker; 12-02-2008 at 07:41 AM.

  10. #10
    Advanced Array awsmori's Avatar

    Join Date
    Nov 2007
    Posts
    33
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by unl0cker View Post
    The SSH problem sounds like is a problem with the file /etc/ssh/sshd_config in the iPhone. It's nothing to do with the know_hosts file in your mac.

    When you add the OpenSSH package using pwnage, what source are you using? I use the default that comes with pwnage and worked ok for me.

    Another thing, do a fresh sync, do not use backups at the end of the restore/update
    where do i find the default openssh from pwnage, all i see is the one under Cydia SEttings


 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. Pwnagetool improperly installs Openssh
    By qouiou in forum PwnageTool
    Replies: 1
    Last Post: 10-04-2009, 12:14 AM
  2. [1.1.3] ziphone openssh / terminal problem
    By MobileSuperDude in forum iPhone "2G" (Rev. 1)
    Replies: 5
    Last Post: 02-18-2008, 05:01 AM
  3. OpenSSH problem
    By anujpuri85 in forum iPhone "2G" (Rev. 1)
    Replies: 6
    Last Post: 11-05-2007, 06:59 PM
  4. OpenSSH Problem on Mac, Please Help
    By nickchooka in forum iPhone "2G" (Rev. 1)
    Replies: 0
    Last Post: 10-22-2007, 02:07 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 04:08 PM.
twitter, follow us!