Page 1 of 2 12 LastLast
Results 1 to 10 of 12
Discuss 3gs 3.0.1 -> 4.x, never jailbroken/unlocked ? at the PwnageTool - Hackint0sh.org; Hi, I (actually, my wife) has an "old" 3gs that has not been used. So ...
  1. #1
    Newbie Array

    Join Date
    Sep 2007
    Posts
    7
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default 3gs 3.0.1 -> 4.x, never jailbroken/unlocked ?

    Hi,

    I (actually, my wife) has an "old" 3gs that has not been used. So it is still running 3.0.1, baseband 04.26.08, never been jailbroken or unlocked.

    I'd like to jailbreak it and unlock it so that she could use it on tmobile.

    I ran TinyUmbrella to save SHSH, but given how "late" it is, only SHSH for 4.2.1 and above were saved.

    Could I use PwanageTool to jailbreak this unit (and ultrasn0w for unlocking) and upgrade it to 4.x?

    Thanks!



  2. #2
    qnc
    qnc is offline
    Professional Array

    Join Date
    Jun 2008
    Location
    Earth
    Posts
    50
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    8

    Default

    If you are going to keep the old firmware version then you may be able to use Blackrain and then unlock with the ultrasnow from cydia.
    If that does not work you should be able to use Redsnow and then unlock with ultrasnow from cydia.

    The 2 methods above do not require you to restore your phone to do the jailbreak.

    If you are going to upgrade to 4.2.1 then you will only be able to jailbreak the phone. Untethered jailbreak was just released in the past couple of days. No unlock is available for that baseband that it will be upgraded to.
    Yeah. I'm an iPhoneaholic so what!!!!!
    All jailbroken and unlocked!!!!!

  3. #3
    Administrator Array

    Join Date
    Oct 2007
    Posts
    4,145
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    Quote Originally Posted by vip66 View Post
    Hi,

    I (actually, my wife) has an "old" 3gs that has not been used. So it is still running 3.0.1, baseband 04.26.08, never been jailbroken or unlocked.

    I'd like to jailbreak it and unlock it so that she could use it on tmobile.

    I ran TinyUmbrella to save SHSH, but given how "late" it is, only SHSH for 4.2.1 and above were saved.

    Could I use PwanageTool to jailbreak this unit (and ultrasn0w for unlocking) and upgrade it to 4.x?

    Thanks!
    I suggest you read this tutorial here for mac: iClarified - iPhone - How to Jailbreak Your iPhone 3GS on OS 3.0.x Using RedSn0w (Mac)
    or for windows iClarified - iPhone - How to Jailbreak Your iPhone 3G on OS 3.0.x Using RedSn0w (Windows)

    you have one shot at getting this right because you don't have any shsh other than 4.2.1.

    If your 3gs has an old bootrom, then you can use pwnagetool with a special bundle to jailbreak 4.2.1 and preserve the baseband.
    Read here: http://blog.iphone-dev.org/ (and read under update #3)
    Last edited by dtube; 02-08-2011 at 04:01 AM.
    ** If you just want to support hackint0sh.org with a donation click here **

  4. #4
    Newbie Array

    Join Date
    Sep 2007
    Posts
    7
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by dtube View Post
    I suggest you read this tutorial here for mac: iClarified - iPhone - How to Jailbreak Your iPhone 3GS on OS 3.0.x Using RedSn0w (Mac)
    or for windows iClarified - iPhone - How to Jailbreak Your iPhone 3G on OS 3.0.x Using RedSn0w (Windows)

    you have one shot at getting this right because you don't have any shsh other than 4.2.1.

    If your 3gs has an old bootrom, then you can use pwnagetool with a special bundle to jailbreak 4.2.1 and preserve the baseband.
    Read here: Dev-Team Blog (and read under update #3)
    I tried the second suggestion (update #3 on dev blog). The OS is up to 4.2.1, baseband preserved.

    I now need to jailbreak using Redsn0w. But I am confused a bit: should I use the original restore ipsw (iPhone2,1_4.2.1_8C148a_Restore.ipsw) or the custom one I created during the Pwnage upgrade to 4.2.1? Or does it not matter?

    Also a question about unlocking using the latest ultrasn0w: Will that one also work on my 04.26.08 baseband? Quite expectedly, there is no mention of this in recent ultrasn0w posts.

  5. #5
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Redsn0w always wants an original IPSW eg iPhone2,1_4.2.1_8C148a_Restore.ipsw
    Yes.... ultrasn0w still works with 04.26.08 baseband
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!


  6. #6
    Advanced Array

    Join Date
    Jan 2008
    Posts
    44
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    So I have a 3GS new bootrom running 3.1.3 unlocked, I want to upgrade to 4.2.1 cause it's the only shsh I have but will like to preserve my baseband to unlock again, is it possible? if so let me know how please.
    Thanks

  7. #7
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    I've heard reports that this is possible, but I haven't yet been able to confirm the procedure.

    You absolutely need to have access to a mac and pwnagetool 4.1.3 to get this working, but you also need a special bundle (the ones built into pwnagetool 4.1.3 won't work)
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  8. #8
    Advanced Array

    Join Date
    Jan 2008
    Posts
    44
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Hi, Olethros, I do have a Power Mac and have a especial bundle for 4.2.1 and also Pwange Tool special edition but according to iClarfied this is not possible and I don't want to risk my only phone, that's why I asked, to be sure.

  9. #9
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by Chevy45 View Post
    Hi, Olethros, I do have a Power Mac and have a especial bundle for 4.2.1 and also Pwange Tool special edition but according to iClarfied this is not possible and I don't want to risk my only phone, that's why I asked, to be sure.
    I'm sorry that I can't give you a more definitive answer. My suggestion, wait for new pwnagetool, it will be out in a week or so.
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  10. #10
    Newbie Array

    Join Date
    Sep 2007
    Posts
    7
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by Olethros View Post
    Redsn0w always wants an original IPSW eg iPhone2,1_4.2.1_8C148a_Restore.ipsw
    Yes.... ultrasn0w still works with 04.26.08 baseband
    I did the redsn0w jailbreak. It appeared to work. But when I try to start Cydia it (starts to) opens for a second, then closes immediately. So I cannot seem to launch it properly.

    Of course, it being a new install there is nothing in /var/lib/dpkg/updates or /var/lib/apt/lists, which are some of the standard broken cydia suggestions.

    Any other ways to go about fixing this? Should I try to remove cydia.app (eg via diskaid) and re-jailbreak it?
    Last edited by vip66; 02-15-2011 at 04:40 AM.


 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 7
    Last Post: 06-29-2010, 05:52 PM
  2. Replies: 1
    Last Post: 01-15-2009, 07:18 AM
  3. How to get from unlocked/jailbroken 1.1.3 to 1.1.4
    By rendier in forum iPhone "2G" (Rev. 1)
    Replies: 2
    Last Post: 03-20-2008, 08:53 AM
  4. [1.1.2 OTB] unlocked and Jailbroken what now?
    By sackling in forum iPhone "2G" (Rev. 1)
    Replies: 8
    Last Post: 03-09-2008, 08:41 PM
  5. Replies: 5
    Last Post: 02-01-2008, 07:36 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 07:40 AM.
twitter, follow us!