Not sure where is the best place to post this.

When I try to download anything under feature packages I get an error.

NOTE : Cannot locate package
the package cannot be found in your current sources. I might recommend installing more sources.

This issue may also be caused by a number of other factors.
package catalogue is out of date - Tried refreshing and I stil get the error.
Package may not exist
or I am using an old firmware version.

My husband just downloaded from here and has the exact same firmware and his worked.

What can I do to resolve this so I can download again?