I'm very new to this. I read through forums for about a week before attempting any of this, so I'm kind of stuck now (and yes, I have searched).

I have an HP DV2000t CTO from 2007 that I wanted to put OSX and Windows 7 on. So far, I've installed OSX but the wifi isn't working, and that's my first goal.

According to my purchase info, my DV2000t CTO has the following:
- Intel(R) Core(TM) 2 Duo T5300(1.73GHz/2MB L2Cache)
- 14.1" WXGA BrightView Widescreen (1280x800)
- 128MB NVIDIA(R) GeForce(R) Go 7200
- LightScribe Super Multi 8X DVD+/-RW w/Double Layer
- Intel(R) PRO/Wireless 3945ABG Network w/Bluetooth

I upgraded to 4GB of RAM a while ago, and added a 320GB drive for this project. I installed iDeneb 10.5.7.

I found kexts from Project: Camphor: Download links and I installed them using Kext Helper B7, as well as put them in the /System/Library/Extensions folder. Is that the right way to do it?

The bluetooth DOES work (seems somewhat intermittent though, as it just started working a moment ago. I've done tons messing with the switch, kexts, and rebooting many times) and the wireless/blueooth light does glow blue. However if I look at "Network -> Airport Card" it says "no information found".

As a side point, if the wireless switch is set to "off" when I boot and then I turn it on - the mouse moves SLOOOOOOOOWLY and erratically. The only way to fix it (I've found so far) is to reboot.

So, any advice on how to get the wireless working? I am willing to try any suggestions made, and really, REALLY appreciate the advice. Seems I'm on the right track if the blueooth works, right?

Side question - my video card shows as "not supported" by Quartz Extreme. Any advice on that one? I'd really like to use iMovie.

Thanks!!