Results 1 to 5 of 5
Discuss Toshiba Satellite L300 Problems: Atheros 5007 Wireless, Battery Meter, Sleep at the Kernel / Kext (Driver) Support - Hackint0sh.org; Hey all, Just recently managed to get SL installed onto my Toshiba Satellite L300 but ...
  1. #1
    Professional Array ouija's Avatar

    Join Date
    Apr 2009
    Posts
    82
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    26

    Default Toshiba Satellite L300 Problems: Atheros 5007 Wireless, Battery Meter, Sleep

    Hey all,

    Just recently managed to get SL installed onto my Toshiba Satellite L300 but I am still having a few issues getting some hardware setup.

    Most of the hardware is working beautifully (even the built-in webcam!) except for the wireless card (which doesn't surprise me, as I always have issues with wireless in laptops).

    The card in my Toshiba L300 is an Atheros 5700 (Detected by Windows 7), however did appear in Ubuntu/Linux as a 5100 and returned the following in Mac OSX:
    PHP Code:
    03:00.0 Ethernet controller [0200]: Atheros Communications IncAR242x 802.11abg Wireless PCI Express Adapter [168c:001c] (rev 01
    ... which is strange.

    Anyways, the default SL IO80211.kext actually loads up when running verbose mode, however it returns with an "Unable to attach" error followed by "HAL status 13".

    I've tried a number of kexts I've found on the net, and only one of them has done anything, however it too does not seem to work properly.

    The kext I am referring to can be found here: MEGAUPLOAD - The leading online storage and file delivery service

    I believe it is a kext that was originally meant for Leopard, but it is the only kext to actually do anything when installed on my system, in terms of getting the airport icon to at least show up. I am running my SL installation in 32 mode as well. When I have this kext installed, the Airport Icon will appear in the dock, however I CANNOT turn on the wireless at all (does nothing). I've looked at the plist files and my device IDs match, but the airport does not turn on no matter what I try.

    If anyone has any ideas or knows how I might get my wireless working, please advise!

    Also, I tried using the VoodooBattery.kext for SL (found here: Darwin) but cannot get it to work properly unless I envoke the "-f" force command on boot. Any thoughts on this?

    The only other thing I'd love to get working properly is the sleep function, but I've failed to get this resolved on a number of hackintosh installs I've done, so it's almost a lost cause for me these days

    Any help with any or all of these issues would be greatly appreciated!!



  2. #2
    Newbie Array

    Join Date
    Nov 2009
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Did you ever get the wireless working?

  3. #3
    Professional Array ouija's Avatar

    Join Date
    Apr 2009
    Posts
    82
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    26

    Default

    everything BUT the wireless
    (and sleep mode, but that never works)

  4. #4
    Newbie Array

    Join Date
    Nov 2009
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I have the same wirless card.
    Think im just going to buy a broadcom one from ebay and replace

  5. #5
    Newbie Array

    Join Date
    Sep 2011
    Posts
    5
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Question

    A have the same Atheros AR5007 recognized in wondows and AR5001 in Linux (168c:001c)

    Any news about this wifi card? Has anyone got this card working in Lion???

    Cheers!


 

 

Similar Threads

  1. Help with Toshiba satellite l300
    By William L Sousa in forum Kernel / Kext (Driver) Support
    Replies: 0
    Last Post: 05-11-2011, 03:18 PM
  2. will osx work on Toshiba satellite L300-12v ?
    By Gerri1000 in forum Installation
    Replies: 2
    Last Post: 01-03-2011, 09:58 PM
  3. Toshiba Satellite L300-13s ...HELP!!!...
    By cobbinma in forum Installation
    Replies: 22
    Last Post: 07-11-2010, 07:18 AM
  4. Mac os x on toshiba satellite l300-15w
    By haro2x in forum Installation
    Replies: 2
    Last Post: 06-08-2010, 09:15 PM
  5. A Mac for my Toshiba Satellite L300 - 145
    By pedrolupinloura in forum Installation
    Replies: 1
    Last Post: 05-24-2009, 12:09 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 08:32 PM.
twitter, follow us!