Page 1 of 2 12 LastLast
Results 1 to 10 of 11
Discuss NEEDED: 64-bit Atheros AR5007 WIFI kext at the Kernel / Kext (Driver) Support - Hackint0sh.org; Does anyone know of or have a working 64-bit kext file for the Atheros AR5007? ...
  1. #1
    Professional Array ouija's Avatar

    Join Date
    Apr 2009
    Posts
    82
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    26

    Default NEEDED: 64-bit Atheros AR5007 WIFI kext

    Does anyone know of or have a working 64-bit kext file for the Atheros AR5007?

    I am desperately seeking one for my Snow Leopard Hackintosh Installation... It's the last thing I need to get working for full 64-bit support on my rig.

    The 32 bit kext I have works fine, but I would love to see it work in 64-bit mode...

    Thanks!



  2. #2
    Newbie Array

    Join Date
    Sep 2009
    Posts
    3
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Need your kext

    do you have a kext for this Atheros AR5007 ???
    Pleas can you upload or mail me , that would be fine.
    Need it for my EeeMac 901go...Please...

  3. #3
    Professional Array ouija's Avatar

    Join Date
    Apr 2009
    Posts
    82
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    26

    Default

    Quote Originally Posted by galluslongus View Post
    do you have a kext for this Atheros AR5007 ???
    Pleas can you upload or mail me , that would be fine.
    Need it for my EeeMac 901go...Please...
    Do you need it for Snow Leopard? If so, I never actually installed any kext for it, just used the arch=x86_32 flag and it loaded for me.

  4. #4
    Newbie Array

    Join Date
    Sep 2009
    Posts
    3
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Yes, needed for Snow Leopard, i only can boot in 32bit mode at EeePC, but will try with this flag. Means, i donīt need that flag to boot in 32bit, cause the CPU donīt have 64bit support. Itīs that ATOM N270.
    Thanx...give it a try...

    But do you know, what kext i need, that IO802110Family.kext, i know...but what else ?
    Last edited by galluslongus; 10-01-2009 at 11:34 AM.

  5. #5
    Administrator Array

    Join Date
    Oct 2007
    Posts
    4,145
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    Not too familiar with Atheros wifi.
    Look in that IO802110Family.kext (contents, plugins) to see if the AR5007 is supported. If it is and your wifi still not working, you may have to add your deviceid into Info.plist for the Atheros
    ** If you just want to support hackint0sh.org with a donation click here **


  6. #6
    Newbie Array

    Join Date
    Sep 2009
    Posts
    3
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    yes, device id is listet in info.plist into atheros.kext, but didnīt work...tryed everything around the forums like insanley mac...

  7. #7
    Newbie Array

    Join Date
    Oct 2009
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    can you post the kext for me?!
    thanks

  8. #8
    Professional Array ouija's Avatar

    Join Date
    Apr 2009
    Posts
    82
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    26

    Default

    Here are the Atheros Kexts I have that work for my HP Pavilion Elite m9180f (which I believe has the Atheros AR5007 wireless card) This works only using the arch=i386 flag.

    Atheros SL.zip

  9. #9
    Newbie Array

    Join Date
    Jul 2009
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    do you have the Atheros AR5007eg working at all in snow? I been trying wit no luck yet. If so how did you do it?

    how, what where do you use the "arch=i386 flag." ? sorry all new to this.
    lost
    Last edited by lost_loven; 12-13-2010 at 04:54 AM.

  10. #10
    Newbie Array

    Join Date
    Sep 2011
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Please i have installed Mac Os X leopard 10.6.2 on my compaq presario CQ61 and wifi don't work, almost sure that is an Atheros AR5007. I also tried other foruns but nothing.... please help me...

    Thanks


 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. **Atheros AR5007 Help Needed**
    By gabycool in forum Kernel / Kext (Driver) Support
    Replies: 1
    Last Post: 10-28-2011, 03:17 AM
  2. Atheros AR5007 wifi adapter
    By iWuzHere in forum Kernel / Kext (Driver) Support
    Replies: 2
    Last Post: 02-10-2011, 05:53 AM
  3. Atheros AR5007 WiFi Adapter
    By nugiajaime in forum Kernel / Kext (Driver) Support
    Replies: 2
    Last Post: 01-16-2011, 05:07 AM
  4. Wifi not working. Atheros AR5007 in SL 10.6.3
    By Dufflebag in forum Kernel / Kext (Driver) Support
    Replies: 3
    Last Post: 05-14-2010, 11:13 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 09:16 AM.
twitter, follow us!