Results 1 to 9 of 9
Discuss bad graphic performance at the Kernel / Kext (Driver) Support - Hackint0sh.org; hi, i finally got snow leopard on my pc. everything works fine. but i have ...
  1. #1
    Rookie Array

    Join Date
    Aug 2009
    Posts
    14
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default bad graphic performance

    hi,

    i finally got snow leopard on my pc. everything works fine. but i have problems with the graphik card performance. its much slower under snow leopard then under leopard.
    here i have some benchmark results:

    with snow leopard:
    OpenMark started...
    workdfolder: /Users/Sven/Downloads/GioFX OpenMark/
    resources: /Users/Sven/Downloads/GioFX OpenMark/OpenMark.app/Contents/Resources/
    hardware detected:
    cpu family: 0x69353836
    cpu type: 0x69353836
    opengl vendor: NVIDIA Corporation
    opengl renderer: NVIDIA GeForce 8800 GT OpenGL Engine
    opengl version: 2.1 NVIDIA-1.6.6
    test parms:
    surface 1680x1050 32bpp
    textures: on
    lighting: on
    keep in sync: off
    test started
    FPS 2597.0 0 triangles
    FPS 2530.0 1152 triangles
    FPS 2497.0 4608 triangles
    FPS 2236.0 10368 triangles
    FPS 2040.0 18432 triangles
    FPS 1791.0 28800 triangles
    FPS 1614.0 41472 triangles
    FPS 1424.0 56448 triangles
    FPS 1250.0 73728 triangles
    FPS 1092.0 93312 triangles
    FPS 935.0 115200 triangles
    FPS 841.0 139392 triangles
    FPS 746.0 165888 triangles
    FPS 667.0 194688 triangles
    FPS 592.0 225792 triangles
    and wich leopard:
    OpenMark started...
    workdfolder: /Users/Sven/Downloads/GioFX OpenMark/
    resources: /Users/Sven/Downloads/GioFX OpenMark/OpenMark.app/Contents/Resources/
    hardware detected:
    cpu family: 0x69353836
    cpu type: 0x69353836
    opengl vendor: NVIDIA Corporation
    opengl renderer: NVIDIA GeForce 8800 GT OpenGL Engine
    opengl version: 2.0 NVIDIA-1.5.44
    test parms:
    surface 1680x1050 32bpp
    textures: on
    lighting: on
    keep in sync: off
    test started
    FPS 2505.0 0 triangles
    FPS 2503.0 1152 triangles
    FPS 2501.0 4608 triangles
    FPS 2484.0 10368 triangles
    FPS 2105.0 18432 triangles
    FPS 2002.0 28800 triangles
    FPS 1886.0 41472 triangles
    FPS 1669.0 56448 triangles
    FPS 1506.0 73728 triangles
    FPS 1419.0 93312 triangles
    FPS 1251.0 115200 triangles
    FPS 1112.0 139392 triangles
    FPS 1001.0 165888 triangles
    FPS 910.0 194688 triangles
    FPS 835.0 225792 triangles
    test stopped

    i only use efistring for graphic card injection

    thats my boot.plist:
    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
    <key>Kernel</key>
    <string>mach_kernel</string>
    <key>Kernel Flags</key>
    <string></string>
    <key>device-properties</key>
    <string>6c0200000100000001000000600200000d00000002 010c00d041030a010000000101060000010
    101060000007fff04001e00000072006f006d002d007200650 076006900730069006f006e0000002
    e
    0000006e5669646961204765466f7263652038383030204754 204f70656e474c20456e67696e6520
    5
    b4546495d22000000400030002c00640065007600690063006 5005f00740079007000650000000b0
    0
    0000646973706c6179100000004e0056004300410050000000 1800000004000000000003000c0000
    0
    000000007000000000e0000006e0061006d00650000000b000 000646973706c61791400000040003
    0
    002c006e0061006d0065000000120000004e5644412c446973 706c61792d41100000006d006f0064
    0
    065006c0000001a0000006e5669646961204765466f7263652 0383830302047540e0000004e00560
    0
    50004d00000020000000010000000000000000000000000000 000000000000000000000000001400
    0
    000400031002c006e0061006d0065000000120000004e56444 12c446973706c61792d42200000004
    0
    0031002c0063006f006d00700061007400690062006c006500 00000e0000004e5644412c4e564d61
    6
    3220000005600520041004d002c0074006f00740061006c007 30069007a006500000008000000000
    0
    002020000000400030002c0063006f006d0070006100740069 0062006c00650000000e0000004e56
    4
    4412c4e564d616322000000400031002c00640065007600690 0630065005f0074007900700065000
    0
    000b000000646973706c61791c000000640065007600690063 0065005f0074007900700065000000
    0
    f0000004e5644412c506172656e74</string>
    </dict>
    </plist>
    and i uploaded my dsdt as well. maybe some one can look at it?
    dsdt.zip ... at uploaded.to - Free File Hosting, Free Image Hosting, Free Music Hosting, Free Video Hosting, ...
    RapidShare: 1-CLICK Web hosting - Easy Filehosting


    atm i stalled sl with retail dvd and using empireefi. i also tried to install it under leopard and i i had used different distros like hazard or snow universal. the benchmark results are always that bad.

    so someone has an idea what it could be?

    hardware:
    inter core quad q6600
    gigabyte ga p35 ds3
    4gb ram
    geforce 8800gt 512mb



    thanks



  2. #2
    Rookie Array

    Join Date
    Aug 2009
    Posts
    14
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    nobody has an idea?

  3. #3
    Rookie Array

    Join Date
    Aug 2009
    Posts
    14
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    i havent fixed it yet

  4. #4
    Moderator Array ratvn's Avatar

    Join Date
    Mar 2010
    Location
    Washington, United States
    Posts
    2,701
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    140

    Default

    1. Video benchmark utility would perform differently between Leopard and SL, also between x86 and x64 modes.
    2. Your SL is in x64 if the boot.plist is from it.
    3. The injection string may not work well with x64 SL, and you may need to use different kext/method. In fact, EFI string would be the last choice for your card.

  5. #5
    Rookie Array

    Join Date
    Aug 2009
    Posts
    14
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by ratvn View Post
    1. Video benchmark utility would perform differently between Leopard and SL, also between x86 and x64 modes.
    2. Your SL is in x64 if the boot.plist is from it.
    3. The injection string may not work well with x64 SL, and you may need to use different kext/method. In fact, EFI string would be the last choice for your card.
    1. yes i know. but i think its a huge different performance. i notice it most scrolling websites. on leopard it was smooth, but on sl it jerks.

    2. yes i know its in 64bit modus. is it bad? should i start in 32 bit modus?

    3. what kexts or methods should i use insted the string? atm i have the efistring in boot.plist and no extensions for graphic. i only have this extensions:

    /Extra/Extensions/AppleACPIPS2Nub.kext
    /Extra/Extensions/Disabler.kext
    /Extra/Extensions/ElliottForceLegacyRTC.kext
    /Extra/Extensions/EvOreboot.kext
    /Extra/Extensions/fakesmc.kext
    /Extra/Extensions/VoodooPS2Controller.kext

    thx for help
    sykeck
    and sorry for my english^^


  6. #6
    Moderator Array ratvn's Avatar

    Join Date
    Mar 2010
    Location
    Washington, United States
    Posts
    2,701
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    140

    Default

    Quote Originally Posted by sykeck View Post
    1. yes i know. but i think its a huge different performance. i notice it most scrolling websites. on leopard it was smooth, but on sl it jerks.

    2. yes i know its in 64bit modus. is it bad? should i start in 32 bit modus?

    3. what kexts or methods should i use insted the string? atm i have the efistring in boot.plist and no extensions for graphic. i only have this extensions:
    1. That is why I said EFI string is not your best video kext/method.
    3. Those kexts are not for your video card.

    2. Depends on what you like to run. For certain function/software/config x64 is desirable.

    Try this boot option at Chameleon boot screen, and redo your benchmark for comparison. It puts your SL in x86/32 bit for testing your video EFI string/method.

    arch=i386

    Post your result.

  7. #7
    Rookie Array

    Join Date
    Aug 2009
    Posts
    14
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by ratvn View Post
    1. That is why I said EFI string is not your best video kext/method.
    3. Those kexts are not for your video card.

    2. Depends on what you like to run. For certain function/software/config x64 is desirable.

    Try this boot option at Chameleon boot screen, and redo your benchmark for comparison. It puts your SL in x86/32 bit for testing your video EFI string/method.

    arch=i386

    Post your result.
    i didnt have openmark anymore and i havent found a downloadlink so i made a benchmark with geekbench.

    in 64bit modus:
    geekbench 64bit: 5822

    in 32bit modus:
    geekbench 5245
    geekbench64bit 5795

  8. #8
    Moderator Array ratvn's Avatar

    Join Date
    Mar 2010
    Location
    Washington, United States
    Posts
    2,701
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    140

    Default

    Quote Originally Posted by sykeck View Post
    i made a benchmark with geekbench.

    in 64bit modus:
    geekbench 64bit: 5822

    in 32bit modus:
    geekbench 5245
    geekbench64bit 5795
    1. What is the number with Leopard as the test is for your original comparison? That was your question, right?
    2. Take average from 3 tests for each number. Use the same geekbench for both SL and Leopard.
    3. What is your conclusion of the test result?
    4. Also test your web browsing with SL in 32 bit, and compare how smooth the images are to Leopard.

  9. #9
    Rookie Array

    Join Date
    Aug 2009
    Posts
    14
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by ratvn View Post
    1. What is the number with Leopard as the test is for your original comparison? That was your question, right?
    2. Take average from 3 tests for each number. Use the same geekbench for both SL and Leopard.
    3. What is your conclusion of the test result?
    4. Also test your web browsing with SL in 32 bit, and compare how smooth the images are to Leopard.

    i dont hav tha exacly numbers anymore, because i dont have leopard installed anymore. But i know it was faster with leopard than witch snow leopard.
    i tested sl 32bit webbrowsing. its faster with leopard.

 

 

Similar Threads

  1. Better graphic performance on SL VB.
    By Mattis0 in forum General - Lion 10.7.x
    Replies: 0
    Last Post: 11-08-2011, 09:30 AM
  2. worse graphic performance
    By sykeck in forum Installation
    Replies: 1
    Last Post: 01-13-2010, 11:24 PM
  3. no graphic desktop why???
    By skippydvd in forum Installation
    Replies: 1
    Last Post: 10-09-2009, 02:10 PM
  4. Graphic Card
    By The-General in forum Using Leopard
    Replies: 2
    Last Post: 05-29-2009, 06:48 PM
  5. best graphic card
    By stereoFilm in forum Hardware
    Replies: 4
    Last Post: 11-06-2008, 12:19 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 03:31 PM.
twitter, follow us!