Results 1 to 5 of 5
Discuss PNY NVidia 9400GT 512MB on Gigabyte GA-G31M-ES2L at the Kernel / Kext (Driver) Support - Hackint0sh.org; Ok fellas, I've tried about a 1000 things so far. Here's the basic setup I ...
  1. #1
    Newbie Array

    Join Date
    May 2009
    Location
    Fox River Grove, IL
    Posts
    5
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Question PNY NVidia 9400GT 512MB on Gigabyte GA-G31M-ES2L

    Ok fellas, I've tried about a 1000 things so far.

    Here's the basic setup I have

    Gigabyte GA-G31M-ES2L
    PNY NVidia 9400GT 512MB Video card

    I'm upgraded to OS 10.5.6 right now.
    Vanilla Kernel, using Munky's EFI bootloader dealy.

    Everything works great - LAN, Audio, etc. Using all the kexts around.

    However, I can't get the dang 9400GT to support CI/QE. I tried loading nvinject drivers - kernel panic

    Installed the EFI strings using OSx86 Tools Utility for a custom device

    However, with NVDAResman.kext loaded, I get a kernel panic.

    I changed the info.plist in the kext to match the device ID in system profiler, and deleted any other devices from the list:

    <key>IOPCIPrimaryMatch</key>
    <string>0x064110de</string>

    Kernel panic

    Tried installing random drivers from the web for Nvidia 9400 - Kernel Panic


    so all Kexts are installed in /system/library/extensions for Nvidia except for NVDAResman.kext. EFI strings are updated, IOPCIPrimaryMatch strings are updated to remove filler and other devices...


    The card *works* in that I can get a good resolution by presetting to 1280x1024, but I cant adjust it or support CI/QE

    Any help would be appreciated. Thanks!!



  2. #2
    Newbie Array

    Join Date
    May 2009
    Location
    Fox River Grove, IL
    Posts
    5
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    slight update

    I took macnutty's drivers from here:
    Deposit Files

    I installed the 3 items from here using OSx86 tools, and deleted all files from the extensions folder with GeForce in the name.

    Restarted, and got another kernel panic using -v - theres not details in the panic, it just hangs. seems to be when the switch from grey to blue would be. Theres nothing in the panic reporter as well.

    Removing NVDAResman.kext via -s, I can boot again. Low and behold, I do see the device reported in system profiler now:

    Graphics by NVIDIA:

    Chipset Model: Graphics by NVIDIA
    Type: Display
    Bus: PCIe
    PCIe Lane Width: x16
    VRAM (Total): 512 MB
    Vendor: NVIDIA (0x10de)
    Device ID: 0x0641
    Revision ID: 0x00a1
    ROM Revision: NVinject 0.2.1
    Displays:
    Display:
    Resolution: 1280 x 1024
    Depth: 32-bit Color
    Core Image: Software
    Main Display: Yes
    Mirror: Off
    Online: Yes
    Quartz Extreme: Not Supported
    QuartzGL: Supported
    Display Connector:

    But I can't change resolutions, and nothing is supported CI/QE etc.

    Any ideas why NVDAResman.kext is causing a kernel panic??

  3. #3
    Newbie Array

    Join Date
    May 2009
    Location
    Fox River Grove, IL
    Posts
    5
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    OK Fellas, thanks to Hagar|Away on #osx86, All that's necessary is to use STOCK kexts from 10.5.6

    Then just load NVinject, properly updated with the NVCAP and Device ID for the PNY GeForce 9400 GT 512MB

    100% working.

    Edited NVinject.kext linked here for your convenience:

    Board Message

  4. #4
    Newbie Array

    Join Date
    Mar 2009
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default PNY nVidia 9400 GT

    Use stock OS X kexts and add NVInject.kext (edit with ids) with OSx86 tools. It worked perfect for me.

  5. #5
    Newbie Array

    Join Date
    Nov 2007
    Posts
    3
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0


 

 

Similar Threads

  1. Working ALC883 drivers for Gigabyte G31m-es2l (rev2)
    By Lyuokdea in forum Installation
    Replies: 1
    Last Post: 08-25-2010, 11:43 PM
  2. Installer keeps crashing -- Gigabyte G31M-ES2L Rev. 2
    By hirefrank in forum Installation
    Replies: 0
    Last Post: 12-26-2009, 03:21 PM
  3. GA-G31M-ES2L Q9550 GeForce 9600GT
    By romulus007 in forum Hardware
    Replies: 3
    Last Post: 04-13-2009, 12:00 PM
  4. Gigabyte ga-g31m-es2l mostly working
    By zim2dive in forum Hardware
    Replies: 4
    Last Post: 03-17-2009, 03:51 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 07:01 PM.
twitter, follow us!