Page 1 of 2 12 LastLast
Results 1 to 10 of 12
Discuss NVinject v0.2.1 upgrade to v0.2.2 at the Kernel / Kext (Driver) Support - Hackint0sh.org; Hi everyone! I'd like to update NVinject v0.2.1 to v0.2.2 on my hackintosh (iATKOS v7 ...
  1. #1
    Rookie Array Hejsan's Avatar

    Join Date
    Dec 2007
    Location
    Tbilisi, Georgia
    Posts
    18
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default NVinject v0.2.1 upgrade to v0.2.2

    Hi everyone!

    I'd like to update NVinject v0.2.1 to v0.2.2 on my hackintosh (iATKOS v7 10.5.7, updated to 10.5.8 with iDeneb Delta Upgrade Kit). When I install new version of this NVinject.kext I got only 1024x768 resolution after reboot. Here are my specs:

    Fujitsu-Siemens Scenic W620 (i915G chipset)
    3.4 GHz P4 HyperThreading CPU
    4 GB DDR2 667 MHz RAM (Mushkin 5-5-5-15 timing)
    1x 160 GB S-ATA Seagate Barracuda 7200 rpm (Leopard is installed on this drive)
    1x 500 GB S-ATA Samsung 7200 rpm
    NVidia GeForce 6200 TurboCache 128 MB PCI-E
    Plextor DVD-RW PX-716A
    Display: Samsung SyncMaster 204B - 20" / 1600x1200 native resolution

    Chameleon BootLoader: v2.0 r431

    Here is the old Info.plist (from v0.2.1 NVinject.kext):

    ----------------------------------------------------------------------------

    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
    <key>CFBundleDevelopmentRegion</key>
    <string>English</string>
    <key>CFBundleExecutable</key>
    <string>NVinject</string>
    <key>CFBundleGetInfoString</key>
    <string>NVinject 0.2.1, Copyright 2007 nvinject.free.fr</string>
    <key>CFBundleIdentifier</key>
    <string>com.nvinject</string>
    <key>CFBundleInfoDictionaryVersion</key>
    <string>6.0</string>
    <key>CFBundleName</key>
    <string>NVinject</string>
    <key>CFBundlePackageType</key>
    <string>KEXT</string>
    <key>CFBundleSignature</key>
    <string>????</string>
    <key>CFBundleVersion</key>
    <string>0.2.1</string>
    <key>IOKitPersonalities</key>
    <dict>
    <key>NVinject</key>
    <dict>
    <key>CFBundleIdentifier</key>
    <string>com.nvinject</string>
    <key>IOClass</key>
    <string>com_nvinject</string>
    <key>IOMatchCategory</key>
    <string>IOFramebuffer</string>
    <key>IONameMatch</key>
    <string>display</string>
    <key>IOPCIMatch</key>
    <string>0x000010de&amp;0x0000ffff</string>
    <key>IOProbeScore</key>
    <integer>0</integer>
    <key>IOProviderClass</key>
    <string>IOPCIDevice</string>
    <key>entriesToAdd</key>
    <dict>
    <key>@0,compatible</key>
    <string>NVDA,NVMac</string>
    <key>@0,device_type</key>
    <string>display</string>
    <key>@0,name</key>
    <string>NVDA,Display-A</string>
    <key>@1,compatible</key>
    <string>NVDA,NVMac</string>
    <key>@1,device_type</key>
    <string>display</string>
    <key>@1,name</key>
    <string>NVDA,Display-B</string>
    <key>NVCAP</key>
    <data>
    BAAAAAAAAwAMAAAAAAAABwAAAAA=
    </data>
    <key>NVPM</key>
    <data>
    AQAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA==
    </data>
    <key>VRAM,totalsize</key>
    <data>
    AAAACA==
    </data>
    <key>device_type</key>
    <string>NVDA,Parent</string>
    <key>model</key>
    <string>nVidia GeForce 6200 TurboCache</string>
    <key>name</key>
    <string>display</string>
    <key>rom-revision</key>
    <string>NVinject 0.2.1</string>
    </dict>
    </dict>
    </dict>
    <key>OSBundleLibraries</key>
    <dict>
    <key>com.apple.iokit.IOPCIFamily</key>
    <string>1.0.0b1</string>
    <key>com.apple.kernel.iokit</key>
    <string>6.0</string>
    </dict>
    <key>OSBundleRequired</key>
    <string>Safe Boot</string>
    </dict>
    </plist>

    ----------------------------------------------------------------------------

    and the new one (v0.2.2):

    ----------------------------------------------------------------------------

    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
    <key>CFBundleDevelopmentRegion</key>
    <string>English</string>
    <key>CFBundleExecutable</key>
    <string>NVinject</string>
    <key>CFBundleGetInfoString</key>
    <string>NVinject 0.2.2, Copyright 2007 nvinject.free.fr</string>
    <key>CFBundleIdentifier</key>
    <string>com.nvinject</string>
    <key>CFBundleInfoDictionaryVersion</key>
    <string>6.0</string>
    <key>CFBundleName</key>
    <string>NVinject</string>
    <key>CFBundlePackageType</key>
    <string>KEXT</string>
    <key>CFBundleSignature</key>
    <string>????</string>
    <key>CFBundleVersion</key>
    <string>0.2.2</string>
    <key>IOKitPersonalities</key>
    <dict>
    <key>NVinject</key>
    <dict>
    <key>CFBundleIdentifier</key>
    <string>com.nvinject</string>
    <key>IOClass</key>
    <string>com_nvinject</string>
    <key>IOMatchCategory</key>
    <string>IOFramebuffer</string>
    <key>IONameMatch</key>
    <string>display</string>
    <key>IOPCIMatch</key>
    <string>0x000010de&amp;0x0000ffff</string>
    <key>IOProbeScore</key>
    <integer>60000</integer>
    <key>IOProviderClass</key>
    <string>IOPCIDevice</string>
    <key>entriesToAdd</key>
    <dict>
    <key>@0,compatible</key>
    <string>NVDA,NVMac</string>
    <key>@0,device_type</key>
    <string>display</string>
    <key>@0,name</key>
    <string>NVDA,Display-A</string>
    <key>@1,compatible</key>
    <string>NVDA,NVMac</string>
    <key>@1,device_type</key>
    <string>display</string>
    <key>@1,name</key>
    <string>NVDA,Display-B</string>
    <key>NVCAP</key>
    <data>
    BAAAAAAAAwAcAAAAAAAACgAAAAA=
    </data>
    <key>NVPM</key>
    <data>
    AQAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA==
    </data>
    <key>device_type</key>
    <string>NVDA,Parent</string>
    <key>model</key>
    <string>Graphics by NVIDIA</string>
    <key>name</key>
    <string>display</string>
    <key>rom-revision</key>
    <string>NVinject 0.2.2</string>
    </dict>
    </dict>
    </dict>
    <key>OSBundleLibraries</key>
    <dict>
    <key>com.apple.iokit.IOPCIFamily</key>
    <string>1.0.0b1</string>
    <key>com.apple.kpi.iokit</key>
    <string>8.0.0b3</string>
    <key>com.apple.kpi.libkern</key>
    <string>8.0.0b3</string>
    </dict>
    <key>OSBundleRequired</key>
    <string>Safe Boot</string>
    </dict>
    </plist>

    ----------------------------------------------------------------------------

    What can I do with the new (v02.2) NVinject.kext in order to have full list of resolutions in "Displays" (System Preferences)? Any help is highly appreciated.

    There is another question: I've bought another graphic card - NVidia GeForce 8800GT 512 MB. If I install it instead of GeForce 6200TC, what can I do in order to avoid Kernel panic?

    Thanks in advance to all...

    P.S. I have also posted it on another forum, but I'm in real trouble... Sorry guys
    NVinject 0.2.2 - InsanelyMac Forum



  2. #2
    Rookie Array Hejsan's Avatar

    Join Date
    Dec 2007
    Location
    Tbilisi, Georgia
    Posts
    18
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default :(

    I guess, nobody know anything about it

  3. #3
    Administrator Array

    Join Date
    Oct 2007
    Posts
    4,145
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    put back your old version of nvinject.

    Putting in a new nvidia card should not give your kernel panic.
    The injector will find it and use it.

    If you are using chameleon 2, you can try using the built-in graphic enabler instead of nvinject.
    ** If you just want to support hackint0sh.org with a donation click here **

  4. #4
    Rookie Array Hejsan's Avatar

    Join Date
    Dec 2007
    Location
    Tbilisi, Georgia
    Posts
    18
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by dtube View Post
    put back your old version of nvinject.

    Putting in a new nvidia card should not give your kernel panic.
    The injector will find it and use it.

    If you are using chameleon 2, you can try using the built-in graphic enabler instead of nvinject.
    Thanks buddy... I'm still on the old version. Can not upgrade to 0.2.2 version. I don't want to reinstall whole system with a new card. Just want to change old nVidia GeForce 6200TC 128 MB to nVidia GeForce 8800GT 512 MB...

    Any suggestions would be highly appreciated. Thanks again...

  5. #5
    Hackint0sh Moderator Array icchansan's Avatar

    Join Date
    Sep 2007
    Location
    Puerto Ordaz, Venezuela, Venezuela
    Posts
    6,641
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    349

    Default

    Did you add efi strings?
    HP Pavilion Elite m9250f
    Snow Leopard 10.6.6, Asus IPIBL-LB MOD BIOS, Intel Quad Core Q6600, 4GB RAM (800mhz), 2x500GB, nVidia 8600GT (Works), ALC888S (Works), Wireless RT73 (Works), LAN (Works) - How to Install - Blog - Hardware Combos - FAQ by TJ2K7
    Macbook Pro 13"
    iPhone 4
    Follow meh: @icchansan

    If you just want to support hackint0sh.org with a donation click here


  6. #6
    Administrator Array

    Join Date
    Oct 2007
    Posts
    4,145
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    Quote Originally Posted by Hejsan View Post
    Thanks buddy... I'm still on the old version. Can not upgrade to 0.2.2 version. I don't want to reinstall whole system with a new card. Just want to change old nVidia GeForce 6200TC 128 MB to nVidia GeForce 8800GT 512 MB...

    Any suggestions would be highly appreciated. Thanks again...
    Like i said before, swapping out nvidia 6200TC with 8800GT should not kernel panic on you. As long as you have the injector, and if it can find your card, it will work with your existing NVDA* kext in /S/L/E.

    No need to reinstall if you swap out graphic card.
    ** If you just want to support hackint0sh.org with a donation click here **

  7. #7
    Rookie Array Hejsan's Avatar

    Join Date
    Dec 2007
    Location
    Tbilisi, Georgia
    Posts
    18
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by icchansan View Post
    Did you add efi strings?
    No To be honest, I don't know how to do it.

  8. #8
    Rookie Array Hejsan's Avatar

    Join Date
    Dec 2007
    Location
    Tbilisi, Georgia
    Posts
    18
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by dtube View Post
    Like i said before, swapping out nvidia 6200TC with 8800GT should not kernel panic on you. As long as you have the injector, and if it can find your card, it will work with your existing NVDA* kext in /S/L/E.

    No need to reinstall if you swap out graphic card.
    I have swapped the card and when the system starts loading, it freezes somewhere in the middle. Gray screen with Apple logo. If I boot the system with -x -v, I see that it stops loading at AppleBCM5751 string... This is my LAN card kext. I swapped my old GeForce 6200TC back and the system loaded without a problem.

    So, no solution for this problem?

  9. #9
    Administrator Array

    Join Date
    Oct 2007
    Posts
    4,145
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    humm....
    adding EFI string will give you the hang at that point too because the EFI string is equivalent to the injector .

    That's interesting that it stopped at the AppleBMC5751 ... let me think.

    Did you clear your mkext?

    leave your new video card in there.

    boot up with -v -s (-s = single user mode)

    If it booted, you will be at the prompt. Type in

    /sbin/fsck -fy
    /sbin/mount -uw /
    touch /System/Library/Extensions.mkext
    reboot

    When the system reboot, use -v -f

    Let see if that will work.

    If the system does not boot in single user mode, reinstall your old vid card and boot. Then goto terminal and type: sudo touch /System/Library/Extensions.mkext.
    then shutdown system, replace the card, boot up with -v -f.
    Last edited by dtube; 10-02-2009 at 05:47 AM.
    ** If you just want to support hackint0sh.org with a donation click here **

  10. #10
    Rookie Array Hejsan's Avatar

    Join Date
    Dec 2007
    Location
    Tbilisi, Georgia
    Posts
    18
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by dtube View Post
    humm....
    adding EFI string will give you the hang at that point too because the EFI string is equivalent to the injector .

    That's interesting that it stopped at the AppleBMC5751 ... let me think.

    Did you clear your mkext?

    leave your new video card in there.

    boot up with -v -s (-s = single user mode)

    If it booted, you will be at the prompt. Type in

    /sbin/fsck -fy
    /sbin/mount -uw /
    touch /System/Library/Extensions.mkext
    reboot

    When the system reboot, use -v -f

    Let see if that will work.

    If the system does not boot in single user mode, reinstall your old vid card and boot. Then goto terminal and type: sudo touch /System/Library/Extensions.mkext.
    then shutdown system, replace the card, boot up with -v -f.
    Thanks a lot for help... I'll try it tomorrow and let you know about results. Hope, it will work. Otherwise, I'll have to throw my 8800GT away
    Last edited by Hejsan; 10-02-2009 at 09:17 PM.


 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. NVinject problem
    By cpukid in forum Kernel / Kext (Driver) Support
    Replies: 0
    Last Post: 08-20-2009, 08:03 AM
  2. NVinject or NVinjectGO
    By camworskout in forum Installation
    Replies: 7
    Last Post: 12-01-2008, 06:15 AM
  3. extreme quartz 8300GS nvinject blue screen
    By marinex17 in forum Archiv (Leopard)
    Replies: 0
    Last Post: 08-23-2008, 02:35 AM
  4. [Upgrade]OTB 1.1.2 Upgrade to 1.1.4 W/O Unlock/Activate/Jailbreak
    By Allingby in forum iPhone "2G" (Rev. 1)
    Replies: 2
    Last Post: 05-13-2008, 10:36 AM
  5. Replies: 0
    Last Post: 01-25-2008, 08:37 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 08:21 AM.
twitter, follow us!