Results 1 to 8 of 8
Discuss HP nc6400 Notebook - Drivers Question? at the Kernel / Kext (Driver) Support - Hackint0sh.org; Hi folks I'm new to OSX and to the forums so I'll try no to ...
  1. #1
    Rookie Array

    Join Date
    Feb 2009
    Posts
    17
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Red face HP nc6400 Notebook - FULLY WORKING!

    Hi folks I'm new to OSX and to the forums so I'll try no to ask too many noobie questions.

    I've successfully installed OSX on my HP nc6400 after about 9 failed attempts. But I stuck at it and now its working (Wooohooo!) .. I have a few driver issues though:

    i) Wireless - Posted in another thread about this. Its an Intel 3945 which only has experimental drivers. I recon I can change the card as its a standard miniPCI so 1st question is .... is there a miniPCI that is fully supported with WPA drivers and a nice GUI?

    ii) Sound - Acording to the HP Site its a SoundMax ADI1981 HD Audio, I selected the ADI1981 HD driver but this doesn't work. Sound setup shows no Audio Devices - any Idea how I can get some sound out of it?

    iii) Onboard LAN (Broadcom NetXtreme Gigabit Ethernet PCIe Controller) - Not too fussed for getting this working but it would make it complete and also means when I put it in the docking station it would work too. I selected the Broadcom en0 driver but that didn't work.

    Final 2 questions, it took me about 3 evenings of playing to get OXS on to the laptop, is there a Wiki or a settings page I can update to save anyone else trying to install on an nc6400 the pain I went through by giving the install options that worked?

    To assist with my drivers problems is there like a Hardware identifier program I can run to get more info on the Sound and Lan Chipsets to help me find some drivers that work?

    This is a link to the HP site with the Laptop Spec - HP Compaq nc6400 Notebook PC specifications - HP Small & Medium Business products

    Kind Regards

    Plasma
    Last edited by Plasma2k9; 03-24-2009 at 10:28 PM. Reason: Added solutions for driver issues



  2. #2
    Rookie Array

    Join Date
    Feb 2009
    Posts
    17
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Well, it seems there are lots of posts like mine asking for help, but not many with replies. Which is a shame, c'mon guys if you solve a problem let us know it helps every one and encourages people to post back with their success stories which ultimately helps others!

    I'm an OSX and Linux Newbie but I stuck at this problem, as I'm not one to be beaten, and I now have a fully working Mactop from my HP nc6400 with sound and wireless LAN. Here's what I did..

    Firstl My Install Optons from Ideneb 1.4 (10.5.6):

    Code:
    Patches
    |-Essentials
      |-ACPI Kext 10.5.6
      |-PS2Fix for ACPI kext 10.5.6
        |-PS2Fix Mouse
    |-Audio
      |-Analog Devices
        |-ADI1981     (DO NOT SELECT HD OPTION)
    |-Chipset
      |-ICHx Fixed
    |-Kernel
      |-Kernel 9.5.0 Voodoo
    |-Network
      |-Ethernet
        |-AppleBC5751     (Doesn't Work But More Later)
      |-Wireless
        |-Broadcom        (For BCM4311 More on this later)
    |-Fix
      |-Cpus=1-Fix
      |-BatteryManager
      |-SeatBelt Fix
    |-System Utilities
      |-GenericCPUPMControl
    |-Video
      |-Intel
        |-Intel GMA950
    |-Applications
      |-ASU
      |-BetterZip
      |-Kext Helper
      |OSx86Tools
    After the above install most things work, bluetooth, video, touchpad, sound, USB etc.

    To get the wireless working there are a few options for the Intel 3945ABG but at the moment they are rubbish. I plunged for a Generic BCM4311 from eBay for 12 and used the guide here:

    HP nc6400 Laptop with OSX wifi working!! - WinMatrix

    To flash the firmware under Ubuntu, so I could get past the "104 - Unauthorised Device Error". After doing this then installing with the above options my wireless is recognised by AirPort and I'm extatic!

    For the onboard LAN, I'm still looking at that though its not a biggie for me now the wireless is working. I had it working once using the AppleBC5751 Kext and a bit of editing the plist. But since a re-install I've not managed to get it working, not really tried to be honest (did I mention I have wireless).

    The touchpad works but there's no scroll function, I'm looking at fixing that too but again its not a big issue the pad and tapping works.

    So there you have it, its a success story, hope its usefull to some people and that others will share theirs!

    Here is my LSPCI output to assist anyone with similar hardware:

    00:00.0 Host bridge [0600]: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub [8086:27a0] (rev 03)
    00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03)
    00:02.1 Display controller [0380]: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller [8086:27a6] (rev 03)
    00:1b.0 Audio device [0403]: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller [8086:27d8] (rev 01)
    00:1c.0 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 [8086:27d0] (rev 01)
    00:1c.1 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 [8086:27d2] (rev 01)
    00:1c.3 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4 [8086:27d6] (rev 01)
    00:1d.0 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 [8086:27c8] (rev 01)
    00:1d.1 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 [8086:27c9] (rev 01)
    00:1d.2 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 [8086:27ca] (rev 01)
    00:1d.3 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 [8086:27cb] (rev 01)
    00:1d.7 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller [8086:27cc] (rev 01)
    00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev e1)
    00:1f.0 ISA bridge [0601]: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge [8086:27b9] (rev 01)
    00:1f.2 IDE interface [0101]: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller [8086:27c4] (rev 01)
    02:06.0 CardBus bridge [0607]: Texas Instruments PCIxx12 Cardbus Controller [104c:8039]
    02:06.2 Mass storage controller [0180]: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD) [104c:803b]
    02:06.3 SD Host controller [0805]: Texas Instruments PCIxx12 SDA Standard Compliant SD Host Controller [104c:803c]
    02:06.4 Communication controller [0780]: Texas Instruments PCIxx12 GemCore based SmartCard controller [104c:803d]
    08:00.0 Ethernet controller [0200]: Broadcom Corporation NetXtreme BCM5753M Gigabit Ethernet PCI Express [14e4:16fd] (rev 21)
    10:00.0 Network controller [0280]: Broadcom Corporation BCM4311 802.11b/g WLAN [14e4:4311] (rev 02)
    Enjoy

    Plasma

  3. #3
    Newbie Array

    Join Date
    Apr 2009
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Thumbs up

    Plasma2k9, thanks for the post. I followed your steps on my hp nc6400 and got it to boot up as well. It works great in the docking station as well. I used iPC OSx86 10.5.6 Universal FINAL.

    I have the similar limitations as you... onboard wireless and lan don't seem to work. Touchpad works, but scrolling doesn't work.

    Let me know if you have a problem with sound. Sound works great for me, but if I plug in headphones, audio still only comes out through the speakers.

    I'm not much of a developer, so hopefully you have some luck in tinkering with the LAN kext to get it to work right.

    I'll keep searching through forums in case anyone gets the 3945 WLAN finally working right.

    Once again, thanks for the post... it helped tremendously!

  4. #4
    Newbie Array

    Join Date
    Jan 2009
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Thumbs up

    Nice guide, even though I came to the same point it's good to know the problems I've had weren't only on my notebook.

    I've had the luck to have a Broadcom W-LAN card, so I had Airport out of the box.

    There are three things that bother me at the moment:
    1) CPUs=1
    I'd really like to see a fix for this which I'm searching
    for now. If I find something, I'll post it.
    2) Broadcom BCM5753M driver
    I'd really like to get my wired network up and running too,
    but that has a lower priority
    3) Bleutooth
    I've ordered a bleutooth dongle for HP notebooks on e-bay.
    It works like a charm on al OS' i've used (Windows,Linux,OSX)
    In OSX though, sometimes I've got bleutooth and sometimes
    I haven't. A reboot fixes it, but it's annoying.
    Any experiences?

    If I fix any of these 3 things, I'll post. I've got about 1 week to get it stable, if I can't get it to run stable for school works I'll just have to wait a bit longer to get OSX, most likely in the form of buying a MacBook.

    PS: I found out that booting with the Vanilla kernel is possible, I just don't have any network/wlan/video drivers so that might also be an idea. I can start the setup without using cpus=1, but I'm not sure what kernel the iDeneb 1.4 DVD uses by default.

  5. #5
    Newbie Array

    Join Date
    Jul 2009
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default HP laptop AD1981 sound fully working

    .... well, I ' not sure how much you still need to solve your sound problem .... I have the same AD1981 in my hp nw9440 fully working (both speakers and headphones) .... if someone replies to this post, I'll describe how to do it ....


  6. #6
    Newbie Array reeg's Avatar

    Join Date
    Aug 2009
    Posts
    5
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    have you gotten the VGA output to work with a monitor? i have a 6910p already with 10.5.8 on it and the resolution is perfect at 1280x800, but for some reason if i plug a monitor into the VGA and try to detect a display, both displays bug out and im forced to restart.

  7. #7
    Newbie Array

    Join Date
    Aug 2010
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Wireless & Wired Connections

    Thank you so much guys for the post. They were a big help. I am a first time Mac person and have a nc6400 like you folks. I got OS installed and thanks to the above posts, I was able to get Sound working too. Only things that don't work for me is the Wireless and the Wired connections. Can one of you please help me get this working???

    It has Broadcom NetXtream Gigabit as the Ethernet and Intel 3945ABG as the Wireless. I tried the link for the Wifi above and it hosed my system so I had to reinstall OS.

    Any assistance will be helpful.

    Thank you!

  8. #8
    Newbie Array

    Join Date
    Aug 2010
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Any luck on getting wired and wireless drivers for HP nc6400? I can't get the network to recognize. Both wired and wireless not working. Wired it shows Ethernet in the Network but it shows unplugged even though it is plugged in. Would really like to get it to work.

 

 

Similar Threads

  1. Replies: 1
    Last Post: 01-01-2010, 08:17 AM
  2. Drivers for SiS-based Notebook
    By ghaga in forum Kernel / Kext (Driver) Support
    Replies: 1
    Last Post: 09-02-2009, 01:50 AM
  3. AXIOO MNC notebook: install question
    By wcy in forum Installation
    Replies: 0
    Last Post: 08-20-2009, 11:59 AM
  4. OSx Worked! Drivers question..
    By powers27 in forum Hardware
    Replies: 4
    Last Post: 04-23-2009, 10:29 PM
  5. 3945ABG on HP NC6400
    By poppaman2 in forum Hardware
    Replies: 1
    Last Post: 11-29-2008, 08:52 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 07:27 PM.
twitter, follow us!