Page 1 of 2 12 LastLast
Results 1 to 10 of 16
Discuss [HOW TO] ATI Radeon HD2600 Series for Hackintosh at the Kernel / Kext (Driver) Support - Hackint0sh.org; I am writing this tutorial because I have received numberous PMs and no one seemed ...
  1. #1
    Senior Professional Array

    Join Date
    Aug 2007
    Posts
    101
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    13

    Default [HOW TO] ATI Radeon HD2600 Series for Hackintosh

    I am writing this tutorial because I have received numberous PMs and no one seemed to have written much in clear details.
    This tutorial requires some knowledge of Mac OSX and it is NOT completely idiot proof

    I will not be providing any files, since they are not mine to give.
    If you want it to work, put in some effort

    All Credits go to Netkas, for making this all possible!

    I will explain starting from a clean install, please read carefully.

    I used JaS 10.4.8 / 8.8.1 for SSe2 & SSe3, Updated to .9 & .10 respectively.
    At this stage, the Kernel has NOT been updated yet.

    Now download the latest Netkas package from IRC.
    (No, I will not send it to you sorry. It is not my file to give.)
    #RadeonHD on server irc.osx86.hu (refer to the topic)
    Upzip them all in the root of your OSX partition such as /2600XT/ which I will refer to from now on

    1, Updating the Kernel
    copy the kernel and its respective kext over...
    do the following in terminal...

    sudo -s
    cp -R /mach_kernel /old
    cp -R /System/Library/Extensions/System.kext /backup/System.kext
    cp -R /2600XT/mach_kernel /
    cp -R /2600XT/Extenstions/System.kext /System/Library/Extensions/
    cp -R /2600XT/Extenstions/dsmos.kext /System/Library/Extensions/

    chown -R root:wheel /mach_kernel
    chmod -R 775 /mach_kernel
    chown -R root:wheel /System/Library/Extensions/System.kext
    chmod -R 775 /System/Library/Extensions/System.kext
    chown -R root:wheel /System/Library/Extensions/dsmos.kext
    chmod -R 775 /System/Library/Extensions/dsmos.kext

    reboot (you can actually type that in too)

    now you should have kernel 8.10.3

    2, Installing ATI Drivers & Natit
    Download the iMac Update from the Apple Website, use the search function.
    You will need Pacifist to install this package, this time Google is your friend.

    Mount the iMac Update DMG and open up Pacifist.
    In Pacifist, navigate your way to the Mounted Image and you will find a mpkg.
    Click on that and select the first lot of files which will show their path as
    /System/Library/Extensions/..............
    Anything else don't install

    Now, DONT restart your Hackintosh whatever you do.

    2a,
    Now back to the Netkas package you downloaded,
    you can skip this step if you are using 2600XT (Goto 2b)

    Inside Terminal:
    sudo -s
    cp -R /2600XT/Extenstions/ATINDRV.kext /System/Library/Extensions/
    cp -R /2600XT/Extenstions/ATIRadeonX2000.kext /System/Library/Extensions/
    cp -R /2600XT/Extenstions/ATIRadeonX2000GA.plugin /System/Library/Extensions/
    cp -R /2600XT/Extenstions/ATIRadeonX2000GLDriver.bundle /System/Library/Extensions/
    cp -R /2600XT/Extenstions/ATIRadeonX2000VADriver.bundle /System/Library/Extensions/
    cp -R /2600XT/Extenstions/Natit.kext /System/Library/Extensions/

    run "chown" & "chmod" as described earlier but on the above listed files

    2b,
    Now time to copy the OpenGL.framework

    Inside Terminal:
    sudo -s (if you have not already done this)
    cp -Rf /2600XT/Frameworks/OpenGL.framework /System/Library/Frameworks/
    (Note: It is important that you use -Rf)

    run "chown" & "chmod" as described earlier but on the above listed file

    reboot (Again, you can actually type this in)

    Congratulations! Your ATI Radeon HD2600 should now be working!



    F.A.Q.
    I have rebooted and my screen turns off after the grey Apple Screen.
    Currently, ONLY working with DVI2VGA Adapter.

    If help is in fact needed, please DO NOT PM me!
    Please visit the IRC.

    If I have you found I've missed something, please PM me corrections, I will gladly update.


    PS: ATI Radeon HD2900, please get yourself onto IRC. There is gold to find there.
    Hackintosh OSx86 10.6.3
    Gigabyte GA-P35-DS3P | Intel Core2Quad Q6600 @ 3.6GHz, 1333FSB
    Mushkin XP2-6400 2GB x4 (8GB) | ATI Radeon HD 4870x2 2GB (QE/CI Working @ 1920x1200x2)

    Asus G1-AK024C Notebook | 10.5.1
    Core2Duo T7200 @ 2.0GHz | Kingston DDR2 1GB x2 (2GB) | GeForce Go 7700 512MB (Working QE/CI @ 1680x1050)
    Acer Aspire 2000 | 10.4.8 / 8.8.1
    Pentium M @ 1.6GHz | Kingston DDR2 1GB x2 (2GB) | ATI Radeon Mobility 9200 (no QE/CI @ 1280x800)



  2. #2
    Engineer Array netkas's Avatar

    Join Date
    Oct 2006
    Posts
    235
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    few additions - no need to install new kernel
    8.10.1 ia enough
    pkg with all needed files inside available on irc.

  3. #3
    Newbie Array

    Join Date
    Sep 2007
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Hi,

    I have a 2600XT and followed guide steps but with no success (no QE/CI).

    I have 10.4.10 and 8.10.1 kernel, so I didn't upgrade kernel: but I must to copy dmos and natit kext or not?

    Any help, please?

    TIA

  4. #4
    Newbie Array

    Join Date
    Sep 2007
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by netkas View Post
    few additions - no need to install new kernel
    8.10.1 ia enough
    pkg with all needed files inside available on irc.
    If I have a new kernel and got that package
    should I do smth, exept just installing it?

    sorry for stupid questions...

    I've 10.4.10 with 8.10.1 kernel
    2400XT card
    I've install package from IRC (http://tinyurl.com/2eay4v - ATI_Radeon_HD.zip)
    and add to info.plist ID of my card (0x94c11002)
    then clear cache and repair permissions
    after changing video card to 2400xt i've got grey screen while booting
    what else should i do to make it work?
    Last edited by eorlov; 09-28-2007 at 01:29 PM.

  5. #5
    Rookie Array

    Join Date
    May 2006
    Posts
    10
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by eorlov View Post
    If I have a new kernel and got that package
    should I do smth, exept just installing it?

    sorry for stupid questions...

    I've 10.4.10 with 8.10.1 kernel
    2400XT card
    I've install package from IRC (http://tinyurl.com/2eay4v - ATI_Radeon_HD.zip)
    and add to info.plist ID of my card (0x94c11002)
    then clear cache and repair permissions
    after changing video card to 2400xt i've got grey screen while booting
    what else should i do to make it work?
    Not able to use 2400 series at the moment. The best I can is screen display by VNC.


  6. #6
    Newbie Array

    Join Date
    Jun 2007
    Posts
    3
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    where to get the imac software update, I went to the apple site and only have the software update 1.1 and it doesn't contain the kernel or rosetta or whatever... Sorry me noob at this.

  7. #7
    Senior Professional Array

    Join Date
    Aug 2007
    Posts
    101
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    13

    Default

    10.4.10 with 8.10.1 works... I have tried it myself...
    If you didnt update your kernel and it works fine... then you dont need dsmos.kext...

    Type in Terminal to test your kernel "uname -a" (without the quotes)

    But you do need Natit... Make sure your permissions are correct and that you've copied the OpenGL.framework with -Rf (Because once I did it using only -R and it doesnt work)

    I have done these steps atleast over 10times now and it works... because I have 3 Hackintoshes running with these same specs.

    Quote Originally Posted by framura View Post
    Hi,

    I have a 2600XT and followed guide steps but with no success (no QE/CI).

    I have 10.4.10 and 8.10.1 kernel, so I didn't upgrade kernel: but I must to copy dmos and natit kext or not?

    Any help, please?

    TIA
    Hackintosh OSx86 10.6.3
    Gigabyte GA-P35-DS3P | Intel Core2Quad Q6600 @ 3.6GHz, 1333FSB
    Mushkin XP2-6400 2GB x4 (8GB) | ATI Radeon HD 4870x2 2GB (QE/CI Working @ 1920x1200x2)

    Asus G1-AK024C Notebook | 10.5.1
    Core2Duo T7200 @ 2.0GHz | Kingston DDR2 1GB x2 (2GB) | GeForce Go 7700 512MB (Working QE/CI @ 1680x1050)
    Acer Aspire 2000 | 10.4.8 / 8.8.1
    Pentium M @ 1.6GHz | Kingston DDR2 1GB x2 (2GB) | ATI Radeon Mobility 9200 (no QE/CI @ 1280x800)

  8. #8
    Rookie Array

    Join Date
    May 2006
    Posts
    10
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I try the new mobility radeon natit. It loads well with my HD2400 Pro. It shows the followings in the profiler.

    ATI,RadeonHD2400:

    Chipset Model: ATI,RadeonHD2400
    Type: Display
    Bus: PCIe
    VRAM (Total): 835 MB
    Vendor: ATI (0x1002)
    Device ID: 0x94c3
    Revision ID: 0x0000
    ROM Revision: 113-B2250F-207
    EFI Driver Version: 01.00.207
    Displays:
    Display:
    Resolution: 1024 x 768
    Depth: 32-bit Color
    Core Image: Not Supported
    Main Display: Yes
    Mirror: Off
    Online: Yes
    Quartz Extreme: Not Supported
    Display:

    But once add the ATIRadeonX2000 files, it will boot with a blank screen as before. I think the problem is in particular related to the new ATINDRV.kext

  9. #9
    Senior Professional Array

    Join Date
    Aug 2007
    Posts
    101
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    13

    Default

    ATI Radeon HD2600XT WORKS on Leopard

    ATI Radeon HD2600PRO has some issues (Something is being worked on)

    Others... Not sure, please let me know and I will update.

    Thanks!
    Last edited by exodus_xt; 11-02-2007 at 04:12 PM.
    Hackintosh OSx86 10.6.3
    Gigabyte GA-P35-DS3P | Intel Core2Quad Q6600 @ 3.6GHz, 1333FSB
    Mushkin XP2-6400 2GB x4 (8GB) | ATI Radeon HD 4870x2 2GB (QE/CI Working @ 1920x1200x2)

    Asus G1-AK024C Notebook | 10.5.1
    Core2Duo T7200 @ 2.0GHz | Kingston DDR2 1GB x2 (2GB) | GeForce Go 7700 512MB (Working QE/CI @ 1680x1050)
    Acer Aspire 2000 | 10.4.8 / 8.8.1
    Pentium M @ 1.6GHz | Kingston DDR2 1GB x2 (2GB) | ATI Radeon Mobility 9200 (no QE/CI @ 1280x800)

  10. #10
    Newbie Array

    Join Date
    Sep 2006
    Posts
    8
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    ATI Radeon HD 2600pro is working 100% now with Leopard including quicktime
    Last edited by lastExile; 11-03-2007 at 01:38 AM.


 

 
Page 1 of 2 12 LastLast

LinkBacks (?)

  1. 02-17-2009, 08:32 AM
  2. 02-14-2009, 03:21 PM

Similar Threads

  1. MacNN: AMD reveals Mobility Radeon HD 5000 series
    By hackint0sh in forum Latest Headlines
    Replies: 0
    Last Post: 01-07-2010, 08:30 AM
  2. ATI Radeon mobility HD2600 driver?
    By vmiku914 in forum Kernel / Kext (Driver) Support
    Replies: 2
    Last Post: 12-26-2009, 04:57 AM
  3. MacNN: ATI Radeon HD 5700 series due in October?
    By hackint0sh in forum Latest Headlines
    Replies: 0
    Last Post: 09-14-2009, 11:10 PM
  4. Replies: 8
    Last Post: 04-15-2009, 07:29 PM
  5. MacNN: AMD debuts ATI Radeon HD 4800 X2 series
    By hackint0sh in forum Latest Headlines
    Replies: 0
    Last Post: 08-12-2008, 07:50 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 07:26 PM.
twitter, follow us!