Results 1 to 4 of 4
Discuss Broadcom 4311 not working at the Kernel / Kext (Driver) Support - Hackint0sh.org; Hi I am new to this but I installed iDeneb V10.5.5 on my compaq presario ...
  1. #1
    Newbie Array

    Join Date
    May 2009
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Broadcom 4311 not working

    Hi I am new to this but I installed iDeneb V10.5.5 on my compaq presario c500 laptop without any issues with the install. My wireless card however is not working at all. I have tried looking in the forums for info and tried everything that was posted but still am having no luck. I also ran the script bcm43xx_enabler.sh and pointed it to the actual AppleAirPortBrcm4311.kext moved to a specific spot i placed it and still no luck. Any ideas?



  2. #2
    Newbie Array

    Join Date
    May 2009
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Any suggestions at all would help thanks again

  3. #3
    Senior Professional Array

    Join Date
    Apr 2009
    Location
    Singapore
    Posts
    111
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    23

    Default

    Quote Originally Posted by DullOxide View Post
    Any suggestions at all would help thanks again
    Should be working out of the box ... most likely the due to diff addresses .. undo whatever you did ... look in /System/Library/Extensions/IO80211Family.kext right click and show package contents. Traverse to plugins and you should see the AppleAirportBrcm4311.kext right click again and show package contents then double click on info.plist then go to IOKitPersonalities / Broadcomm 802.11 PCI / IONameMatch you'll see stuff like

    pci106b,4e, pci14e4,4312 etc ... your hardware should have an entry in there .. if it's not there, copy out the kext to your desktop and

    run OSX86Tools ( see this thread ) and View PCI Device / Vendor ID and locate your wireless something like

    00:1f.3 SMBus [0c05]: Intel Corporation 82801G (ICH7 Family) SMBus Controller [8086:27da] (rev 02)
    01:00.0 Ethernet controller [0280]: Broadcomm Corporation BCM4311 802.11b/g WLAN [14e4:4311] (rev 01)
    03:00.0 Ethernet controller [0200]: Attansic Technology Corp. L1 Gigabit Ethernet Adapter [1969:1026] (rev b0)


    Just replace one of the e.g. pci14e4,4312 to match yours pci14e4,4311 .. and reinstall ...

    Important to clean up whatever you did cause if you have 2 same drivers might not behave as expected

    QED

  4. #4
    Newbie Array

    Join Date
    May 2009
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I checked the AppleAirportBrcm4311.kext already and was just as you said it all looks good. I will check the PCI Device / Vendor ID just to make sure and will come back with the results.

    Thank you for the reply

 

 

Similar Threads

  1. Broadcom BCM 5785 HELP
    By rafaelperoco in forum Kernel / Kext (Driver) Support
    Replies: 0
    Last Post: 03-04-2011, 04:34 AM
  2. Replies: 1
    Last Post: 11-21-2009, 12:12 AM
  3. wifi not working on swapped broadcom nic -eee 100ha ideneb 1.5.6
    By kryo in forum Kernel / Kext (Driver) Support
    Replies: 1
    Last Post: 11-15-2009, 09:24 PM
  4. Wifi Problems on Wakeup // DELL 1490=Broadcom 4311
    By mathendrix in forum Kernel / Kext (Driver) Support
    Replies: 0
    Last Post: 06-09-2009, 11:44 AM
  5. MacNN: HighPoint intros RocketRAID 4311 controller
    By hackint0sh in forum Latest Headlines
    Replies: 0
    Last Post: 04-14-2009, 05:10 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 09:05 PM.
twitter, follow us!