Hi,

I jailbroken my iPod Touch 2G (iOS 4.2.1) a week ago. Now that a I have multitask enabled I want to use some apps that need multitask, like "Find My iPhone" and now: Google Latitude.

Is there a way to change my product ID, so I change to an compatible device (iPod Touch 4G for example) and be able to install those apps?

Thanks!
PFS