ok i got my 1.1.4 downgraded to 1.1.1 because i couldn't stand not having customize working and now my summerboard wont install. It says package download failed!
Now i've tried everything to restoring my ipod and summerboard (old) but they all say the same thing please someone help!