Page 1 of 2 12 LastLast
Results 1 to 10 of 14
Discuss no need to patch SpringBoard to install homebrew apps via itunes/xcode at the iPhone Developer Exchange - Hackint0sh.org; yeah, only pathced mobileintalltion framework is needed, u can avoid patching SpringBoard, by addid to ...
  1. #1
    Engineer Array netkas's Avatar

    Join Date
    Oct 2006
    Posts
    235
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default no need to patch SpringBoard to install homebrew apps via itunes/xcode

    yeah, only pathced mobileintalltion framework is needed, u can avoid patching SpringBoard, by addid to plist of your application next entry.

    <key>SignerIdentity</key>
    <string>Apple iPhone OS Application Signing</string>

    this will make a trick ,so proper entry will exist in SB config, abd SB will launch an app

    this was discovered by CycloneFr



  2. #2
    DPR
    DPR is offline
    Rookie Array

    Join Date
    Feb 2008
    Posts
    15
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Works great - thx !

  3. #3
    Newbie Array

    Join Date
    Mar 2008
    Posts
    5
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Doesnt work for me i am on ipod touchs o the SignerIdentity string may be different for us how do you fine it?

  4. #4
    Newbie Array

    Join Date
    May 2006
    Posts
    9
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    It doesn't work for me either.... I had the lines to info.plist and the app is copied to iPhone but it doesn't run.... I need to manually ldid to make it run by SB.
    I test on a 2G iPhone

  5. #5
    Senior Professional Array

    Join Date
    May 2006
    Posts
    135
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    14

    Default

    You still have to run ldid. This workaround prevents you from patching the springboard.

    Quote Originally Posted by motote View Post
    It doesn't work for me either.... I had the lines to info.plist and the app is copied to iPhone but it doesn't run.... I need to manually ldid to make it run by SB.
    I test on a 2G iPhone
    1) C2D E2160@3Ghz | MoBo: ASUS P5E-VM DO | Chipset: ICH9 | No Onboard LAN Intel | Wifi: NetGear WPN311 (recognized as Airport Extreme) | Sound: ALC883 but no 5.1 ch atm | Memory: 2 Gb RAM | Geforce 8600 GT 256 MB/CE/QI | HD: SATA 160GB | DVD : Pioneer 111L 40X/16X | OSX 10.5.2 pc efi v8

    2) C2D E6600@3.53Ghz | MoBo: ASUS P5K | Wifi: RT2500USB | Sound: Onboard ALC883 | Memory: 2 Gb RAM | GeForce 8800GT 512 MB/CE/QI | HD: SAMSUNG SATA-II 500GB | DVD : Pioneer 111L 40X/16X | OSX 10.5.2 pc efi v8


  6. #6
    Newbie Array

    Join Date
    May 2006
    Posts
    9
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Then I'm doing things in the correct way. Thanks
    BTW is possible to automatically run ldid from xcode at building time ??

  7. #7
    Developer Array javacom's Avatar

    Join Date
    Mar 2008
    Posts
    304
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    28

    Default

    Seems that we need Springboard and MobileInstallation patches for firmware 2.0.1

  8. #8
    Rookie Array

    Join Date
    Mar 2008
    Posts
    13
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    No, it's still the same as 2.0.

  9. #9
    DPR
    DPR is offline
    Rookie Array

    Join Date
    Feb 2008
    Posts
    15
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by motote View Post
    Then I'm doing things in the correct way. Thanks
    BTW is possible to automatically run ldid from xcode at building time ??
    Create a "New Run Script Build Phase" and add your ldid command there.

    Quote Originally Posted by elpopo View Post
    No, it's still the same as 2.0.
    I can confirm this. Still works with 2.0.1 on the iPhone and the iPod touch ... just the MobileInstallation framework patch is needed (along with the other code signing modifications).

  10. #10
    Newbie Array

    Join Date
    Mar 2008
    Posts
    5
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by javacom View Post
    Seems that we need Springboard and MobileInstallation patches for firmware 2.0.1
    100% True for some people we need both patched or we get the an error that the app cannot be opened the only way i could get it to work on the 2.0 firmwares was to patch the springboard.

    and once again i need a patched SpringBoard as the 2.0 version doesn't work on 2.1.

    also i forgot to say i have added the string into the info.plist
    Last edited by Rocky5; 09-13-2008 at 04:29 PM.


 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. [SpringBoard] No able to install more native apps ?
    By Elf in forum Free Toolchain Software (Cydia App's)
    Replies: 1
    Last Post: 06-04-2008, 05:35 PM
  2. [Beta 2.0] Install Apps through XCode
    By underwaterdub in forum PwnageTool
    Replies: 4
    Last Post: 04-05-2008, 12:51 AM
  3. Apps not appearing on SPRINGBOARD after install
    By iPhoneVN in forum Free Toolchain Software (Cydia App's)
    Replies: 0
    Last Post: 02-06-2008, 10:23 PM
  4. Replies: 3
    Last Post: 10-11-2007, 01:57 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 11:13 PM.
twitter, follow us!