Results 1 to 10 of 10
Discuss iPhone/iPod 2.0.2 MobileInstallation patch at the iPhone Developer Exchange - Hackint0sh.org; While the file was updated, the offset remained the same so just change E0 to ...
  1. #1
    Senior Professional Array

    Join Date
    May 2006
    Posts
    135
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    14

    Default iPhone/iPod 2.0.2 MobileInstallation patch

    While the file was updated, the offset remained the same so just change

    E0 to A0 at offset 6E9A and sign the file (ldid -S works fine). Put it back in /System/Library/PrivateFrameworks/MobileInstallation.Framework/

    So now you can use your self-made Xcode apps and transfer them through your iPhone/iPod just like before

    Enjoy
    1) C2D E2160@3Ghz | MoBo: ASUS P5E-VM DO | Chipset: ICH9 | No Onboard LAN Intel | Wifi: NetGear WPN311 (recognized as Airport Extreme) | Sound: ALC883 but no 5.1 ch atm | Memory: 2 Gb RAM | Geforce 8600 GT 256 MB/CE/QI | HD: SATA 160GB | DVD : Pioneer 111L 40X/16X | OSX 10.5.2 pc efi v8

    2) C2D E6600@3.53Ghz | MoBo: ASUS P5K | Wifi: RT2500USB | Sound: Onboard ALC883 | Memory: 2 Gb RAM | GeForce 8800GT 512 MB/CE/QI | HD: SAMSUNG SATA-II 500GB | DVD : Pioneer 111L 40X/16X | OSX 10.5.2 pc efi v8



  2. #2
    Rookie Array

    Join Date
    Jun 2007
    Posts
    25
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Hmmm I patched the MobileInstallation file and put it back, when I do "ldid -S" on it I get:
    Code:
    iPhone:/System/Library/PrivateFrameworks/MobileInstallation.framework mobile$ ldid -S MobileInstallation
    ./minimal/mapping.h(54): _assert(13:false)
    If I do it from root, I get another error:
    Code:
    iPhone:/System/Library/PrivateFrameworks/MobileInstallation.framework root$ ldid -S MobileInstallation
    util/ldid.cpp(430): _assert(0:WIFEXITED(status))
    This is on a 3g upgraded to 2.0.2 and jailbroken with latest QuickPwn. ldid was installed through Cydia.

    Am I doing something wrong?
    Last edited by xyzzy; 08-21-2008 at 03:36 PM.

  3. #3
    Developer Array javacom's Avatar

    Join Date
    Mar 2008
    Posts
    304
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    28

    Default

    if you ldid after binary patch use
    Code:
    ldid -s MobileInstallation
    That is small s option

  4. #4
    Rookie Array

    Join Date
    Jun 2007
    Posts
    25
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by javacom View Post
    if you ldid after binary patch use
    Code:
    ldid -s MobileInstallation
    That is small s option
    Thanks! That did it!

  5. #5
    Professional Array

    Join Date
    Mar 2008
    Posts
    83
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    12

    Default

    Quote Originally Posted by javacom View Post
    if you ldid after binary patch use
    Code:
    ldid -s MobileInstallation
    That is small s option
    Thats weired. I did it with the -S options the uppercase "S" and no errors on an Iphone 2G.


  6. #6
    Newbie Array

    Join Date
    Nov 2007
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    ldid -s MobileInstallation
    iphone can't find ldid ?

  7. #7
    Newbie Array

    Join Date
    Nov 2007
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    ok nevermind found the ldid

    but how do i change the E to the A0 ?

    Alex,

  8. #8
    Newbie Array

    Join Date
    Aug 2008
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Issue with Mobileinstallation patch

    I've found a strange issue with MobileInstallation patch. After two weeks of using it iPod application don't see any music and all free Apple Store apps crashing in 2 seconds after start. But other applications from Cydia or cracked one installed through new mobileinstallation works fine. Does anybody have idea what happens?

  9. #9
    Senior Professional Array

    Join Date
    May 2006
    Posts
    135
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    14

    Default

    Quote Originally Posted by irsy View Post
    I've found a strange issue with MobileInstallation patch. After two weeks of using it iPod application don't see any music and all free Apple Store apps crashing in 2 seconds after start. But other applications from Cydia or cracked one installed through new mobileinstallation works fine. Does anybody have idea what happens?
    GOogle the problem. It isn't due to this patch. Steve Jobs even made a statement, a fix should be out in september. Meanwhile you can always try to delete all your DRM apps and reinstall these.. or install new one... Google the problem, you can find it even on apple.com forums.
    1) C2D E2160@3Ghz | MoBo: ASUS P5E-VM DO | Chipset: ICH9 | No Onboard LAN Intel | Wifi: NetGear WPN311 (recognized as Airport Extreme) | Sound: ALC883 but no 5.1 ch atm | Memory: 2 Gb RAM | Geforce 8600 GT 256 MB/CE/QI | HD: SATA 160GB | DVD : Pioneer 111L 40X/16X | OSX 10.5.2 pc efi v8

    2) C2D E6600@3.53Ghz | MoBo: ASUS P5K | Wifi: RT2500USB | Sound: Onboard ALC883 | Memory: 2 Gb RAM | GeForce 8800GT 512 MB/CE/QI | HD: SAMSUNG SATA-II 500GB | DVD : Pioneer 111L 40X/16X | OSX 10.5.2 pc efi v8

  10. #10
    Newbie Array

    Join Date
    Jul 2009
    Posts
    3
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    what u did to make find the ldid

    thanks


 

 

Similar Threads

  1. Automatic MobileInstallation Patch (2.0-2.0.2)
    By kwanbis in forum AppStore Software
    Replies: 71
    Last Post: 10-11-2009, 07:16 AM
  2. MobileInstallation Patch version 2.2.1
    By ganja24 in forum AppStore Software
    Replies: 18
    Last Post: 04-17-2009, 09:06 PM
  3. Replies: 3
    Last Post: 04-04-2009, 07:26 PM
  4. What's the use of mobileinstallation patch?
    By elie.fares in forum General
    Replies: 4
    Last Post: 09-22-2008, 01:49 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 02:09 PM.
twitter, follow us!