Results 1 to 3 of 3
Discuss iPhone .deb App installation Problem at the iPhone Developer Exchange - Hackint0sh.org; Hi there. I am into a very strange problem. I have developed an app for ...
  1. #1
    Rookie Array

    Join Date
    Jan 2009
    Posts
    14
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default iPhone .deb App installation Problem

    Hi there.

    I am into a very strange problem. I have developed an app for myself, which has following three files

    * MyApp.app
    * MyAppDaemon.app
    * LaunchDaemon.plist

    When i copy each file into specific folder using ssh , my app works perfect.

    * MyApp.app into /Applications
    * MyAppDaemon.app into /private/var/mobile/
    * LaunchDaemon.plist into /System/Library/LaunchDaemons/

    App works great if i ssh using cyberduck and puts each file in above specified folders.

    Now the problem is when i try to pack the files in .deb file and then transfer to iPhone and then using Terminal i install it [dpkg -i MyApp.deb] the files get copied fine in the folders i specified earlier but my app doesnt work. I have checked all the permissions, still not working.

    Its kinda strange, everything is done in the same way as i do using ssh but in case of .deb file its not working, however it works great if i copy the files individually

    Any Advice on this??



  2. #2
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by raziiq View Post
    Hi there.

    I am into a very strange problem. I have developed an app for myself, which has following three files

    * MyApp.app
    * MyAppDaemon.app
    * LaunchDaemon.plist

    When i copy each file into specific folder using ssh , my app works perfect.

    * MyApp.app into /Applications
    * MyAppDaemon.app into /private/var/mobile/
    * LaunchDaemon.plist into /System/Library/LaunchDaemons/

    App works great if i ssh using cyberduck and puts each file in above specified folders.

    Now the problem is when i try to pack the files in .deb file and then transfer to iPhone and then using Terminal i install it [dpkg -i MyApp.deb] the files get copied fine in the folders i specified earlier but my app doesnt work. I have checked all the permissions, still not working.

    Its kinda strange, everything is done in the same way as i do using ssh but in case of .deb file its not working, however it works great if i copy the files individually

    Any Advice on this??
    Have you checked the file ownership (not just permissions?)
    How did you make the deb file?
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  3. #3
    Rookie Array

    Join Date
    Jan 2009
    Posts
    14
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by Olethros View Post
    Have you checked the file ownership (not just permissions?)
    How did you make the deb file?
    I have this file structure

    +- MyApp
    +-Applications
    MyApp
    +-DEBIAN
    -control
    -postinst
    -postrm
    +- System
    +-Library
    +-LaunchDaemons
    +-com.LaunchDaemon.MyApp.plist

    Then i used Saurik's compiled dpkg-deb-fat to make .deb as below
    Code:
    dpkg-deb-fat -b MyApp.deb
    i then ssh into my iPhone, pasted this .deb to /tmp and then ran this command after ssh through Terminal
    Code:
    dpkg -i MyApp.deb
    Files are properly copied to their respective folders and permissions are fine too. As far as ownership is concerned, that is also fine, as i checked them quite sometimes now.

    Stuck in middle of no where

 

 

Similar Threads

  1. Problem installation
    By thinkpadpre in forum Installation
    Replies: 1
    Last Post: 11-09-2011, 06:51 PM
  2. Installation problem
    By Joemost in forum Installation
    Replies: 19
    Last Post: 05-20-2010, 07:07 PM
  3. Installation problem
    By pcanaveral in forum Installation
    Replies: 0
    Last Post: 04-18-2009, 10:32 PM
  4. Installation problem on PC
    By Grzesiek in forum Installation
    Replies: 2
    Last Post: 02-05-2009, 08:29 PM
  5. Iphone SDK installation problem [kalyway leo 10.5.1]
    By swamijivan in forum Archiv (Leopard)
    Replies: 7
    Last Post: 03-21-2008, 05:44 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 07:38 AM.
twitter, follow us!