Page 4 of 5 FirstFirst 12345 LastLast
Results 31 to 40 of 41
Discuss [HowTo] Use Apple SDK to build 1.1.4 apps at the iPhone Developer Exchange - Hackint0sh.org; I HAVE TRIED LIKE 7 TIMES AND I FAIL AT FINDING THE LETTERS WITH THE ...
  1. #31
    Respected Professional Array

    Join Date
    Sep 2007
    Posts
    695
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    55

    Default

    I HAVE TRIED LIKE 7 TIMES AND I FAIL AT FINDING THE LETTERS WITH THE CAT IN THEM, MAYBE THE FACT THAT THEY ARE ALL UPSIDE DOWN AND THEY INCLUDE A LION AND THEY ARE ALL LIGHT GRAY DOES NOT HELP.

    In other words, capchas annoy the hell out of me, is there any way you could upload this to another website? thanks


  2. #32
    Newbie Array

    Join Date
    Dec 2007
    Posts
    6
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by darkest_hour View Post
    at the moment i just hardcode the path to my executable folder in the script, for example:
    scp -r /path/to/your/build/$EXECUTABLE_FOLDER_PATH root@$IPHONE_IP:/Applications

    make sure you have set the IPHONE_IP correctly in the project settings. i know this isn't a good way to solve that, because for each project you have to change the "run on device" script, but it works for me and maybe i try once to get a better solution.

    hope this helped you.

    greetz
    You said you hardcoded "scp -r /path/to/your/build/$EXECUTABLE_FOLDER_PATH root@$IPHONE_IP:/Applications" to your executable folder in the script.

    Please tell me specifically what script you are referring to and where I can get access to it. Thanks.
    Last edited by brentd49; 06-08-2008 at 09:21 AM.

  3. #33
    Professional Array

    Join Date
    May 2008
    Posts
    55
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    8

    Default

    Is this working with the SDK beta 7?

  4. #34
    Newbie Array

    Join Date
    Jun 2008
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Invalid arch name: armv6

    In my case, the scripts work fine for XCode 3.1 and the latest SDK (beta 7). The problem is that the compiler doesn't build the executable. The error I get is:

    Command /Developer/usr/bin/llvm-gcc-4.2 failed with exit code 1
    llvm-gcc-4.2: Invalid arch name: armv6

    and then of course the 'chmod' fails since it can't find the executable under the app directory.

    The C/C++ Compiler version in the Project Settings is: LLVM GCC 4.2 (the free tool chain compiler). Any other compiler is not installed in this configuration.

    Does anyone else have the same problem? Do you know how to resolve it?
    Many thanks in advance.

  5. #35
    Professional Array

    Join Date
    Jul 2007
    Posts
    69
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    11

    Default

    nope it actually doesnt work right because in the new project window none of the toolchain project file templates show up.

    hopefully this script gets updated.


  6. #36
    Newbie Array

    Join Date
    May 2008
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Installed fine with beta6. Templates show up, but build fails:
    Error "gcc-4.0: installation problem, cannot exec '/Developer/usr/bin/arm-apple-darwin9-gcc-4.0.1' : No such file or directory";
    Command /Developer/usr/bin/gcc-4.0 failed with exit code 255.

    I'll update to SDK beta7, see if that helps.

  7. #37
    Newbie Array

    Join Date
    Jul 2008
    Posts
    7
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default compilation error (XCode: 3.1, SDK: beta 8, Leopard 10.5.3)

    Hi Allz,

    I'm new to iPhone, but have a huge experience in mobile development mainly in Symbian OS. I did all that are written on various forums but toolchain still doesn't works. If I using llvm-gcc-4.2 as the complier (set in XCode->Project Settings) I got exit code 1 with message: "invalid arch name : armv6". gcc-4.0 also falls with exit code 255 saying: "installation problem, cannot exec '/Developer/usr/bin/arm-apple-darwin9-gcc-4.0.1' : Permission denied"

    Any idea?

    Thanks
    benceb

  8. #38
    Newbie Array

    Join Date
    Jul 2008
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default NEED HELP Using Apple SDK to build apps for 1.1.4

    hello darkmen, i am new to iphone app development and i am having trouble following installing the mod_sdk.

    i currently have xcode 3.1 installed on my mac (10.5.4).

    When i am trying to install the mod_sdk it gives me file not found errors (i dont have any of those folders specified in the .sh file).

    i really want this to work, so can you please help me with this??????

    cheers
    naveen gopala

    here is a part of the error message for your reference... as i couldn't get the complete message here...

    rick-gutierrezs-macbook-pro:make.sdk naveengopala$ ./sdk.sh
    (#) 1.1.4 platform SDK creation script for XCode 3.0 -- by Darkmen
    Copying Aspen1.2...
    Password:
    cp: /Developer/Platforms/Aspen.platform: No such file or directory
    Configuring XCode GCC plugin...
    cp: directory /Developer/Platforms/Toolchain.platform/Developer/Library/Xcode/Plug-ins/GCC 4.0.xcplugin/Contents/Resources does not exist
    cp: /Developer/Platforms/Toolchain.platform/Developer/Library/Xcode/Specifications: No such file or directory
    Configuring SDK prefs...
    cp: directory /Developer/Platforms/Toolchain.platform does not exist
    mv: rename /Developer/Platforms/Toolchain.platform/Developer/SDKs/Aspen1.2.sdk to /Developer/Platforms/Toolchain.platform/Developer/SDKs/Toolchain.sdk: No such file or directory
    cp: directory /Developer/Platforms/Toolchain.platform/Developer/SDKs/Toolchain.sdk does not exist
    Removing old templates...
    rm: /Developer/Platforms/Toolchain.platform/Developer/Library/Xcode/Project Templates/*: No such file or directory
    Copying new templates...
    usage: cp [-R [-H | -L | -P]] [-fi | -n] [-pvX] source_file target_file
    cp [-R [-H | -L | -P]] [-fi | -n] [-pvX] source_file ... target_directory
    Making SDK filesystem:
    -Erasing 1.2 System
    rm: /Developer/Platforms/Toolchain.platform/Developer/SDKs/Toolchain.sdk/System/*: No such file or directory
    -Erasing 1.2 lib
    rm: /Developer/Platforms/Toolchain.platform/Developer/SDKs/Toolchain.sdk/usr/lib: No such file or directory
    Make sure original 1.1.4 filesystem is here: /usr/local/share/iphone-filesystem/
    -Copying 1.1.4 iPhone fileystem...
    cp: directory /Developer/Platforms/Toolchain.platform/Developer/SDKs/Toolchain.sdk does not exist
    -Copying dev team 1.1.4 headers...
    cp: /Developer/Platforms/Toolchain.platform/Developer/SDKs/Toolchain.sdk/usr: No such file or directory
    cp: include: unable to copy extended attributes to /Developer/Platforms/Toolchain.platform/Developer/SDKs/Toolchain.sdk/usr: No such file or directory
    cp: /Developer/Platforms/Toolchain.platform/Developer/SDKs/Toolchain.sdk/usr/i386: No such file or directory
    cp: include/i386: unable to copy extended attributes to /Developer/Platforms/Toolchain.platform/Developer/SDKs/Toolchain.sdk/usr/i386: No such file or directory
    cp: /Developer/Platforms/Toolchain.platform/Developer/SDKs/Toolchain.sdk/usr/i386/vmparam.h: No such file or directory

  9. #39
    Rookie Array

    Join Date
    Aug 2008
    Posts
    13
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I have a bit different problem

    I am installing the tool chain with help of http://code.google.com/p/iphone-dev/wiki/Building site.
    I have to get a copy of iphone root filesystem (for iPhone 3G) but I do not have the iPhone, only simulator.

    Is this filesystem on the internet, because I can't find it anywhere.
    I have just found filesystem for previous iPhone, but I need the latest one.

    any ideas?

  10. #40
    Amazingly Knowledgeable Array DJ McG's Avatar

    Join Date
    Dec 2007
    Location
    United States
    Posts
    809
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    59

    Default

    does this work with the final SDK release


    iPhone "2G" - 3.1.3 - Jailbroken + iPhoDroid
    iPhone 4 - 4.0.2 - Not jailbroken (yet)



 

 
Page 4 of 5 FirstFirst 12345 LastLast

LinkBacks (?)


Similar Threads

  1. [AppStore][HowTo] Delete Apps I have Installed?
    By th3joker in forum AppStore Software
    Replies: 2
    Last Post: 07-13-2008, 11:23 PM
  2. [iPhone SDK] Can use Apple SDK Beta4 for Build 1.1.4 apps?
    By DarKMenTaL in forum iPhone Developer Exchange
    Replies: 0
    Last Post: 05-14-2008, 07:12 AM
  3. Replies: 3
    Last Post: 01-19-2008, 05:01 PM
  4. HowTo Write Native Apps
    By linear in forum General
    Replies: 0
    Last Post: 10-28-2007, 09:13 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 12:06 AM.
twitter, follow us!