Results 1 to 4 of 4
Discuss [Firmware] can we use Xcode with 2.0 ? at the iPhone Developer Exchange - Hackint0sh.org; Hi, I checked all the post and found that if we're going to develop application ...
  1. #1
    Newbie Array

    Join Date
    Jun 2008
    Posts
    3
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default [Firmware] can we use Xcode with 2.0 ?

    Hi,
    I checked all the post and found that if we're going to develop application using tool chain, it seems that we have to roll back to 1.1.4 and use SDK 3.0. what's the current status? is it still the same? or can use further version (say SDK 6.0/7.0) on iPhone OS 2.0(5A331 or 5A274D)?

    Further, say i have developer program license but no AT&T phone number, and because firmware 2.0 is requiring AT&T number to activate iPhone. Is there any way that i can jailbreak firmware 2.0 (in order not to enter AT&T phone number) and use XCode (say i have code sign and corresponding profile) to program? (tool chain not necessary) Is Pwnage workable? thanks!!
    Last edited by kenliu; 06-27-2008 at 05:07 AM.



  2. #2
    Developer Array javacom's Avatar

    Join Date
    Mar 2008
    Posts
    304
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    28

    Default

    You can use SDK 6/7/8 and play with the iPhone Simulator.
    and you can install your app to the iPhone / iPod Touch if your are registered $99 developer.

    If you need jailbreak information, you are in the wrong forum.
    Last edited by javacom; 06-27-2008 at 05:11 AM.

  3. #3
    Newbie Array

    Join Date
    Jun 2008
    Posts
    3
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    sorry, maybe I wasn't clear. I am a registered developer but i don't have any AT&T number right now. I need to upload my application to my iPhone, and I'm trying to figure out the best way to do it (because firmware 2.0 is asking for AT&T number and i don't have one so i couldn't upload application anymore). Using tool chain and roll back the firmware to 1.1.4 seems to be a workable way but I also wonder if i can do it on firmware 2.0 and sdk 5/6/7

  4. #4
    Developer Array javacom's Avatar

    Join Date
    Mar 2008
    Posts
    304
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    28

    Default

    if you use pwned iPhone (which support upto firmware 2.0 build 5A240d), you can work on SDK beta 3.

    If you have developer certificate but without AT&T number, I think you can only build 2.0 app on iPod Touch. SDK 8 and new firmware have just been released, the old firmware will expire soon.

 

 

Similar Threads

  1. Xcode 4.x provision profiles, developing using Xcode 4
    By ipatch in forum iPhone Developer Exchange
    Replies: 1
    Last Post: 04-20-2011, 06:36 PM
  2. [Xcode Problems] About Open Toolchain dev in Xcode
    By satashi in forum iPhone Developer Exchange
    Replies: 2
    Last Post: 02-08-2011, 11:26 AM
  3. [XCode Template] for SDK and Open Toolchain API in firmware 2.0
    By javacom in forum iPhone Developer Exchange
    Replies: 143
    Last Post: 04-11-2009, 07:23 PM
  4. XCode Templates for Pwned iPhone && 2.2 Firmware..
    By steffoz in forum iPhone Developer Exchange
    Replies: 7
    Last Post: 11-28-2008, 11:36 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 10:09 AM.
twitter, follow us!