Page 6 of 6 FirstFirst 123456
Results 51 to 57 of 57
Discuss [codesign] how to deploy app to pwnage 2.0 firmware ? at the iPhone Developer Exchange - Hackint0sh.org; I've found what was the problem: I installed the SDK on a second partition. thus, ...
  1. #51
    Newbie Array

    Join Date
    Mar 2008
    Posts
    3
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I've found what was the problem:

    I installed the SDK on a second partition.


    thus, this command :
    export CODESIGN_ALLOCATE=/Developer/Platforms/iPhoneOS.platform/Developer/usr/bin/codesign_allocate
    was not correct. Instead I did

    CODESIGN_ALLOCATE=/Volumes/OSX_2/Developer/Platforms/iPhoneOS.platform/Developer/usr/bin/codesign_allocate

    I modified as well the script to use in Xcode.

    and now it works.

    I can now build&Go and use the GDB.

    PM


  2. #52
    Newbie Array

    Join Date
    Sep 2008
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Question

    Hi there,

    I have problem with 246tNt's solution, where <codesign -s "iPhone developer" -f MobileInstallation> return "Bus error" could anyone suggest something?

    Im trying it on 3G device with jb by winpwn2.5...

  3. #53
    Newbie Array

    Join Date
    Sep 2008
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default iPod communication API

    Can someone lead me to getting the ipod communication api? as at the moment, apple only releases it to "Made for Ipod" big guys. am developing a device that con communicate with the ipod through microcontroller like dump songs on the ipod, delete song, check memory etc. Am talking or raw low level api.
    Thanks

  4. #54
    Newbie Array

    Join Date
    Sep 2008
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    did anyone try it over sdk 2.1? cant seem to pass the provisioning thing to compile as a release.

    cant make a device release using xcode 3.1
    Last edited by Delusionz; 09-20-2008 at 10:16 PM.

  5. #55
    Newbie Array

    Join Date
    Sep 2008
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I just would like to answer myself...

    "Bus error" after <codesign...> was because wrong OSX, I had leo 1.5.1! ^^
    Currently I have updated it to 1.5.4 and bug dissapeared, as well as usnupported '--entitlements' option message. Thought xCode may works fine on 1.5.1 - I was wrong

    Tnt soultion works fine!
    Thx!


  6. #56
    Newbie Array

    Join Date
    May 2009
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I've the same problem, but I can't update to 10.5.4 because it crashes all my installation. I've changed version of os in some file, and Xcode works perfect.
    But the problem is that I can't apply tnt solution.
    First error from: ./iphone_binary_patch
    [+] Start dry-run phase
    [!] Didn't find the expected data at offset 00006e98
    [!] Error patching MobileInstallation
    [!] Something bad happenned in dry-run. Nothing has been done

    Also when I try to
    codesign -s "iPhone developer" -f MobileInstallation
    I get:
    Bus error

    and
    codesign -s "iPhone developer" --entitlements SpringBoard.xcent -f SpringBoard
    codesign: unrecognized option `--entitlements'
    Usage: codesign -s identity [-fv*] [-o flags] [-r reqs] [-i ident] path ... # sign
    codesign -v [-v*] [-R testreq] path|pid ... # verify
    codesign -d [options] path ... # display contents
    codesign -h pid ... # display hosting paths


    Is it possible to apply tnt solution without installing patch to 10.1.4?
    I've tried few times and had to reinstall all the system.

    Thanks, you can help me with really cool game
    AA


    Quote Originally Posted by gunloved View Post
    I just would like to answer myself...

    "Bus error" after <codesign...> was because wrong OSX, I had leo 1.5.1! ^^
    Currently I have updated it to 1.5.4 and bug dissapeared, as well as usnupported '--entitlements' option message. Thought xCode may works fine on 1.5.1 - I was wrong

    Tnt soultion works fine!
    Thx!

  7. #57
    Board Hero Array

    Join Date
    Nov 2007
    Location
    Mustang Ridge, Texas, United States
    Posts
    1,169
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    65

    Default

    hey does ldid work on 3.0 apps???

    cuz when i try it i get this as a error with a build failed

    ldid.cpp(402): _assert(0:arch != NULL)
    race/BPT trap
    Get the latest info for NoAccSplash Here
    Currently it should work on iOS 4.x - 6.x
    If you'd like to help extend its functionality, the source is also available.

 

 
Page 6 of 6 FirstFirst 123456

Similar Threads

  1. bypass codesign 4.0 sdk?
    By truehybridx in forum iPhone Developer Exchange
    Replies: 1
    Last Post: 09-13-2010, 01:54 AM
  2. 2.0.2 firmware how can i pwnage
    By Christian666 in forum Quickpwn
    Replies: 1
    Last Post: 10-24-2008, 07:54 AM
  3. Replies: 173
    Last Post: 08-04-2008, 08:52 PM
  4. Replies: 0
    Last Post: 07-20-2008, 04:07 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 02:05 PM.
twitter, follow us!