Results 1 to 5 of 5
Discuss [Advise] can iPhone 3G be used as development device ? at the iPhone Developer Exchange - Hackint0sh.org; If yes, which firmware should I use 54345 or 5A347 ?...
  1. #1
    Developer Array javacom's Avatar

    Join Date
    Mar 2008
    Posts
    304
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    28

    Question [Advise] can iPhone 3G be used as development device ?

    If yes, which firmware should I use 54345 or 5A347 ?



  2. #2
    Newbie Array

    Join Date
    Jul 2008
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default yes

    for the single day that I've had it, the iPhone 3G has worked fine as a development device. My phone is using firmware v 2.0 (5A345).

    -moss

  3. #3
    Amazingly Knowledgeable Array DJ McG's Avatar

    Join Date
    Dec 2007
    Location
    United States
    Posts
    809
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    59

    Default

    Both firmwares are the same. The 5A345 is 7MB larger and I believe only as the 3G features built in. The other one, 5A347, doesnt because it would crash the phone.


    iPhone "2G" - 3.1.3 - Jailbroken + iPhoDroid
    iPhone 4 - 4.0.2 - Not jailbroken (yet)


  4. #4
    Professional Array

    Join Date
    Jan 2008
    Posts
    85
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    11

    Default

    Quote Originally Posted by DJ McG View Post
    Both firmwares are the same. The 5A345 is 7MB larger and I believe only as the 3G features built in. The other one, 5A347, doesnt because it would crash the phone.
    I dont think so. I have the 5A347 on my 3G iPhone and it is running fine. I can use the 3g iPhone for the development.

  5. #5
    Advanced Array

    Join Date
    Apr 2008
    Location
    Florida
    Posts
    37
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    You could also use 2.1 5F90, but for the moment you can't upload SKD 2.1 apps to the AppStore.

    BTW: To have access to 2.1, you need to have been in the Beta program prior to the release of 2.0.


 

 

Similar Threads

  1. Iphone development. Android development.
    By ShallY in forum iPhone Developer Exchange
    Replies: 0
    Last Post: 03-27-2009, 04:07 PM
  2. [2G iphone] [Advise] sync to new pc
    By deggs1 in forum Tools
    Replies: 1
    Last Post: 09-23-2008, 10:52 PM
  3. Xcode "Couldn't prepare device for development"
    By raptorlol in forum iPhone Developer Exchange
    Replies: 1
    Last Post: 05-13-2008, 05:46 AM
  4. Advise for New iPhone
    By zenmonkey in forum iPhone "2G" (Rev. 1)
    Replies: 6
    Last Post: 09-25-2007, 11:01 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 11:21 PM.
twitter, follow us!