Page 1 of 2 12 LastLast
Results 1 to 10 of 16
Discuss [2.0] Beta Support Dev - iPhone isn't recognized at the iPhone Developer Exchange - Hackint0sh.org; I was accepted into the developer program and installed the 2.0 beta today. Everything went ...
  1. #1
    Rookie Array

    Join Date
    Feb 2008
    Posts
    12
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default [2.0] Beta Support Dev - iPhone isn't recognized

    I was accepted into the developer program and installed the 2.0 beta today. Everything went on without a hitch, until all of a sudden I got the pink screen with a connect to itunes logo. When I connected to itunes it appeared as if the iphone was regularly connected, showing the synch tabs, the music tab, the playlists, etc, even while the iphone still had a pink screen. Xcode wasn't giving me any feedback either, The tab under my iphone info (where you can put provisions, etc) was blank.

    I figured maybe I should just try restoring to 1.1.4 with itunes, but that only messed things up further and iTunes stopped recognizing the iphone. So, I figured maybe I should use pwnage tool to restore everything back to normal and start over. Sadly, I think this has caused even more problems because now xcode still won't recognize my phone, and iTunes will only recognize it when it's in DFU mode. I want to get back to my developer software so I can keep testing applications, as there shouldn't be any stupid need to go through this mess.

    Does anyone have a recommendation as to what process I should take to get the OFFICIAL 2.0 back onto my system and everything running hunky-dory so I can play with my xcode apps?

    I really appreciate the feecback.


    EDIT: Oh, and, since I used Ipwner, every time I start up my iphone I get the pineapple so I don't see how I could take it to the Apple store in this state.... Argh!
    Last edited by rbenjamin; 04-08-2008 at 11:10 AM. Reason: Update



  2. #2
    Rookie Array

    Join Date
    Jan 2008
    Posts
    11
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Don't worry, you didn't do anything wrong. All the currently released versions of 1.2/2.0 have expired now, which is why you're getting the purple non-activated screen. Even if you do go back to de-pwned 2.0 (which you can do simply by restoring to your original 2.0 ipsw using Xcode), its still going to be there. Taking it to the Apple store isn't going to do anything. If you open up Xcode again and go to the organizer, it should say "This device is expired. Please install a newer version of the OS."

    In other words, 1.2/2.0 isn't going to work until Apple releases another seed to developers. Given its Apple Tuesday, I'm betting they'll be a seed out later today it just hasn't been released yet.

    Until then, you can downgrade to 1.1.4 (either custom to keep it pwned or original) and use your phone without a hitch. The 2.0 baseband (04.05.01_G) seems to work fine with 1.1.4 even when its not pwned. If you get an error from iTunes on the downgrade, 1015 or something, just use a tool like iLiberty+ to get it out of DFU mode.

    Keep an eye out for that new seed. Its just that we're among the first people to realize that everyone's phone has been deactivated, but indeed they all have.
    Last edited by Sbrocket; 04-08-2008 at 11:43 AM.

  3. #3
    Rookie Array

    Join Date
    Feb 2008
    Posts
    12
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    The problem is iliberty x won't recognize my iphone, nothing but ipsw tool will recognize my iphone. Xcode won't recognize my iphone either, the only thing that happens when I turn it on is steve jobs. I can't restore it to ANY firmware, pwned or not, i've tried every combination possible.

  4. #4
    Rookie Array

    Join Date
    Jan 2008
    Posts
    11
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    iLiberty+ takes a couple minutes usually to get the phone out of DFU. Just give it some time.

    Restart you computer and iPhone if you can't get it to recognize it again.

  5. #5
    Rookie Array

    Join Date
    Feb 2008
    Posts
    12
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Sorry for not being more thorough, iLiberty won't even recognize that a phone is connected and i've tried restarting, logging in as different users, switching itunes versions... Nothing has worked.... BUT some progress: Ifuntastic kicked me out of the "steve jobs is happy" mode that ipsw tool put the phone into, but I still can't get it activated. I guess that has to do with the firmware you were talking about?


  6. #6
    Rookie Array

    Join Date
    Jan 2008
    Posts
    11
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    iLiberty+ won't say that a phone is connected until it finishes booting it out of DFU mode, so I'm tempted to say you just didn't let it wait long enough.

    If you restore to the original 1.1.4 firmware (and you may have to use iLiberty+ to get it out of DFU mode...just let it sit with the window open for like 5 minutes), you should be able to use your phone like normal. Getting the phone working again with the Apple firmware should be your goal rather than running it through Pwnage Tool again.

  7. #7
    Developer Array celebi23's Avatar

    Join Date
    Mar 2007
    Posts
    65
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    11

    Default

    I've got the PSOD as well. Bring on the new firmware Apple Developer Connection Phone Support wasn't any help when I called. There's not ETA for when the new firmware is gonna show up

  8. #8
    Rookie Array

    Join Date
    Feb 2008
    Posts
    12
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I was able to restore to 1.1.4 when I switched to windows, with an error only at the very end, but ifuntastic still won't kick my phone out of recovery mode. And, with i libertyx, i left my phone on and connected all night. The program never noticed it. I can't think of what else to do. Even waiting for the new firmware seed is pointless, I can't get xcode to recognize my device~

    EDIT: I was able to get iliberty for windows to recognize the device and kick it out of recovery mode. Thanks.
    Last edited by rbenjamin; 04-08-2008 at 06:50 PM.

  9. #9
    Developer Array celebi23's Avatar

    Join Date
    Mar 2007
    Posts
    65
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    11

    Default

    ADC Phone Support still has no idea whats going on or any answers. Their one suggestion was restoring to the current 5A225c build. I fail to see how that would work. Isn't that the firmware that is expired though?

  10. #10
    Amazingly Knowledgeable Array

    Join Date
    Oct 2007
    Posts
    790
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    54

    Default

    Download Independence to kick it out of recovery mode.

    Independence works brilliantly even when all else fails!

    Of course you can now download the new 3rd beta fixing the problem lol
    iPhone US 8GB
    FW 1.0.2--> iUnlock--> iPhoneSIMfree--> 1.1.1 --> 1.1.2--> Soft upgrade 1.1.3 --> 1.1.4 using signal.app
    iPhone UK 16GB
    FW 1.1.3 OOB --> 1.1.4 --> iPlus 1.2 unlocked!

    <----If I helped you out, rep points are always nice (thanks for that idea!)


 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 0
    Last Post: 05-19-2010, 01:40 PM
  2. [2.0 Beta] Exchange support
    By StefanM in forum iPhone Developer Exchange
    Replies: 62
    Last Post: 09-10-2008, 10:18 AM
  3. [2.0 Beta] Cisco VPN support
    By CU3BALL in forum iPhone Developer Exchange
    Replies: 19
    Last Post: 07-14-2008, 10:53 PM
  4. Replies: 11
    Last Post: 04-08-2008, 10:34 PM
  5. [2.0 Beta] Exchange support
    By StefanM in forum PwnageTool
    Replies: 33
    Last Post: 04-05-2008, 02:28 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 12:06 PM.
twitter, follow us!