Results 1 to 9 of 9
Discuss Question regarding 4.0.2 and 4.1 at the iPhone 4 - Hackint0sh.org; Hi all. I have been in this forum and following the Dev Team since my ...
  1. #1
    Professional Array

    Join Date
    Jul 2007
    Posts
    91
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    11

    Default Question regarding 4.0.2 and 4.1

    Hi all. I have been in this forum and following the Dev Team since my iPhone 2G was useless. I was one of those crazy people that unlocked iPhone 2G by hardware, so hopefully, this question won't sound that silly.

    I recently bought an iPhone 4 and has 4.0.2 on it. I know how the Dev Team usually work. They have an exploit but won't release it until Apple releases 4.1. I understand they don't want to "waste" that on 4.0.2. However, we now have an unlock for this baseband, and, 4.1 will probably update baseband firmware.

    So, when 4.1 is released, Dev Team will probably release the Jailbreak but, are we going to have an unlock? Shouldn't we take advantage of the current unlock by jailbreaking 4.0.2?

    I do not want to sound disrespectful, I am just asking.

    Thanks



  2. #2
    Advanced Array

    Join Date
    Mar 2008
    Posts
    47
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I would say no, why would they waste there time on 4.0.2 when 4.0.1 is exactly the same except for the pdf exploit........ waste of time.

  3. #3
    Super Moderator Array n1ckn4m3's Avatar

    Join Date
    Mar 2009
    Location
    USA
    Posts
    2,717
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    145

    Default

    Quote Originally Posted by funkadelic View Post
    So, when 4.1 is released, Dev Team will probably release the Jailbreak but, are we going to have an unlock? Shouldn't we take advantage of the current unlock by jailbreaking 4.0.2?
    They probably do have an exploit that works on 4.0.2, but 4.0.2 is a waste to release it on. If they release it on 4.0.2, then Apple can fix it for 4.1 -- whereas if they sit on it now, and Apple releases 4.1, they can exploit it then and hit a wider audience.

    The only people now on 4.0.2 are people who bought new devices recently or ignored the warnings not to update. I understand you're a member of this group (and of the former, buying a device with 4.0.2, not ignoring their advice and updating), but what you should know is that you're in the smallest percentage of iPhone users in the entire world -- there are infinitely (almost) more users with 4.0, 4.0.1, or earlier, who can be jailbroken with jailbreakme.com right now. This means that the vast majority of iPhone users can jailbreak with one of several tools released right now.

    Add to that the fact that 4.0.2 provides absolutely zero functionality to 4.0.1, and there is really just no reason for them to waste an exploit jailbreaking it. Not an answer you'll like, but 4.1 should be released soon -- in which case the game starts all over.

    Get your SHSH on file now so that you can downgrade if ever a 4.0.2 jailbreak IS released (or if they backport the 4.1 jailbreak to 4.0.2 after the fact), so you can jailbreak then -- and hang on until they make an announcement and until 4.1 becomes general issue.
    The preceding forum post has been brought to you by the letter "N" and the number 42.

    iPhone 4, 32GB (iOS 6.1.2 | evasi0n | SHSH: 4.0 - 6.1.2)
    iPad 2 3G, 64GB (iOS 6.1.2 | evasi0n
    |
    SHSH: 4.3 & 4.3.3 - 6.1)

    Restore problems? Read this: http://www.hackint0sh.org/f137/130802.htm

    Did we solve your problem? Got a dollar or two spare? Please Donate!


  4. #4
    Senior Professional Array

    Join Date
    Dec 2007
    Posts
    143
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    14

    Default

    downgrade to 4.0.1 as i recall apple still signing for that firmware.
    iPhone 4 iOS 4.2.1
    Jailbroken and unlocked
    My website:
    -websites removed, does not comply with site rules related to signatures: see http://www.hackint0sh.org/f18/69493.htm for more details-
    Call In/Out - Yes/Yes
    SMS In/Out - Yes/Yes
    EDGE/WIFI - Yes/Yes
    YouTube - Yes
    Jailbreak-Yes

  5. #5
    Administrator Array

    Join Date
    Oct 2007
    Posts
    4,145
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    ATM, people can still use umbrella to get SHSH for firmware 4.0.1.
    Once that is done, downgrade to fw 4.0.1 from 4.0.2 can be done.
    ** If you just want to support hackint0sh.org with a donation click here **


  6. #6
    Professional Array

    Join Date
    Jul 2007
    Posts
    91
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    11

    Default

    Quote Originally Posted by n1ckn4m3 View Post
    They probably do have an exploit that works on 4.0.2, but 4.0.2 is a waste to release it on. If they release it on 4.0.2, then Apple can fix it for 4.1 -- whereas if they sit on it now, and Apple releases 4.1, they can exploit it then and hit a wider audience.

    The only people now on 4.0.2 are people who bought new devices recently or ignored the warnings not to update. I understand you're a member of this group (and of the former, buying a device with 4.0.2, not ignoring their advice and updating), but what you should know is that you're in the smallest percentage of iPhone users in the entire world -- there are infinitely (almost) more users with 4.0, 4.0.1, or earlier, who can be jailbroken with jailbreakme.com right now. This means that the vast majority of iPhone users can jailbreak with one of several tools released right now.

    Add to that the fact that 4.0.2 provides absolutely zero functionality to 4.0.1, and there is really just no reason for them to waste an exploit jailbreaking it. Not an answer you'll like, but 4.1 should be released soon -- in which case the game starts all over.

    Get your SHSH on file now so that you can downgrade if ever a 4.0.2 jailbreak IS released (or if they backport the 4.1 jailbreak to 4.0.2 after the fact), so you can jailbreak then -- and hang on until they make an announcement and until 4.1 becomes general issue.
    I suppose you are right, that is very convincing.
    I look forward to the next jailbreak. In the meantime, I will keep donating.
    Thank you

  7. #7
    Super Moderator Array n1ckn4m3's Avatar

    Join Date
    Mar 2009
    Location
    USA
    Posts
    2,717
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    145

    Default

    Quote Originally Posted by funkadelic View Post
    I suppose you are right, that is very convincing.
    I look forward to the next jailbreak.
    Good news is that Apple (for the moment) is still signing 4.0.1, so you can restore to 4.0.1 and use Jailbreakme.com to jailbreak the device. Will still require you to have a legit SIM to activate the phone (need to access the browser), but aside from that it's a pretty painless process.

    I'd recommend running the Firmware Umbrella to ensure your 4.0.1 SHSH is on file with Cydia and you won't have much if anything to worry about in the near future.
    The preceding forum post has been brought to you by the letter "N" and the number 42.

    iPhone 4, 32GB (iOS 6.1.2 | evasi0n | SHSH: 4.0 - 6.1.2)
    iPad 2 3G, 64GB (iOS 6.1.2 | evasi0n
    |
    SHSH: 4.3 & 4.3.3 - 6.1)

    Restore problems? Read this: http://www.hackint0sh.org/f137/130802.htm

    Did we solve your problem? Got a dollar or two spare? Please Donate!


  8. #8
    Senior Professional Array

    Join Date
    Aug 2007
    Posts
    101
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    13

    Default

    Quote Originally Posted by dtube View Post
    ATM, people can still use umbrella to get SHSH for firmware 4.0.1.
    Once that is done, downgrade to fw 4.0.1 from 4.0.2 can be done.
    I am due to get my iPhone4 tomorrow or Monday, I would like to know if it is possible to downgrade an OTB 4.0.2 to 4.0.1 , would Apple still sign that?

    I guess I will find out sooner or later... I just thought knowing will make me sleep better... even if Apple stopped signing for them the day I get my iP4... cos then thats just my bad luck...

    Altho I must say it was a very wise move to pick on a mobilesafari exploit instead... otherwise the same thing with the 3GS will happen again...
    Hackintosh OSx86 10.6.3
    Gigabyte GA-P35-DS3P | Intel Core2Quad Q6600 @ 3.6GHz, 1333FSB
    Mushkin XP2-6400 2GB x4 (8GB) | ATI Radeon HD 4870x2 2GB (QE/CI Working @ 1920x1200x2)

    Asus G1-AK024C Notebook | 10.5.1
    Core2Duo T7200 @ 2.0GHz | Kingston DDR2 1GB x2 (2GB) | GeForce Go 7700 512MB (Working QE/CI @ 1680x1050)
    Acer Aspire 2000 | 10.4.8 / 8.8.1
    Pentium M @ 1.6GHz | Kingston DDR2 1GB x2 (2GB) | ATI Radeon Mobility 9200 (no QE/CI @ 1280x800)

  9. #9
    Super Moderator Array n1ckn4m3's Avatar

    Join Date
    Mar 2009
    Location
    USA
    Posts
    2,717
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    145

    Default

    Quote Originally Posted by exodus_xt View Post
    I am due to get my iPhone4 tomorrow or Monday, I would like to know if it is possible to downgrade an OTB 4.0.2 to 4.0.1 , would Apple still sign that?
    Try not to threadjack -- what you're asking doesn't really have much to do with the original topic of this thread, but in any case -- so long as Apple is signing 4.0.1, you can downgrade to it -- even if you get an OTB 4.0.2. I am not aware of any protection Apple is putting in place to stop this beside the SHSH requirement, so as long as that is being signed, you should be good to go.
    The preceding forum post has been brought to you by the letter "N" and the number 42.

    iPhone 4, 32GB (iOS 6.1.2 | evasi0n | SHSH: 4.0 - 6.1.2)
    iPad 2 3G, 64GB (iOS 6.1.2 | evasi0n
    |
    SHSH: 4.3 & 4.3.3 - 6.1)

    Restore problems? Read this: http://www.hackint0sh.org/f137/130802.htm

    Did we solve your problem? Got a dollar or two spare? Please Donate!


 

 

Similar Threads

  1. [QUESTION] Customize.app 2.0 crashes [QUESTION]
    By untold21 in forum Free Toolchain Software (Cydia App's)
    Replies: 0
    Last Post: 12-26-2008, 01:41 AM
  2. [Question] [2.1]Mobile Terminal question
    By lolof in forum Free Toolchain Software (Cydia App's)
    Replies: 1
    Last Post: 10-10-2008, 05:14 PM
  3. [Question] I got no IMEI situation, and got a question...
    By leximus in forum iPhone "2G" (Rev. 1)
    Replies: 0
    Last Post: 04-04-2008, 10:09 PM
  4. Replies: 1
    Last Post: 03-10-2008, 08:02 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 01:55 AM.
twitter, follow us!