Page 1 of 2 12 LastLast
Results 1 to 10 of 11
Discuss No option to restore from backup after updating at the iPhone 4 - Hackint0sh.org; Updated from 4.3.5 to 5.0.1 (iPhone 4). This is what I see in the right ...
  1. #1
    Newbie Array

    Join Date
    Dec 2011
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default No option to restore from backup after updating

    Updated from 4.3.5 to 5.0.1 (iPhone 4).

    This is what I see in the right click menu. No option to restore from backup. http://i43.tinypic.com/2mmuvcg.gif

    I have verified that my backups are here. http://i41.tinypic.com/14j0z0w.gif

    And under the Edit > Preferences > Devices menu... (Perspective is the backup I want to restore to. I deleted the new one iTunes tried to create.) http://i42.tinypic.com/2mwgy0y.gif

    Any help, please?



  2. #2
    Super Moderator Array n1ckn4m3's Avatar

    Join Date
    Mar 2009
    Location
    USA
    Posts
    2,717
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    145

    Default

    Don't you have to shift-right-click for 'Restore from Backup' to become an option? I didn't think it was there by default, but it's been a while, I could be mistaken.
    The preceding forum post has been brought to you by the letter "N" and the number 42.

    iPhone 4, 32GB (iOS 6.1.2 | evasi0n | SHSH: 4.0 - 6.1.2)
    iPad 2 3G, 64GB (iOS 6.1.2 | evasi0n
    |
    SHSH: 4.3 & 4.3.3 - 6.1)

    Restore problems? Read this: http://www.hackint0sh.org/f137/130802.htm

    Did we solve your problem? Got a dollar or two spare? Please Donate!


  3. #3
    Newbie Array

    Join Date
    Dec 2011
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Shift right click doesn't do anything. Gives same menu.

  4. #4
    Super Moderator Array n1ckn4m3's Avatar

    Join Date
    Mar 2009
    Location
    USA
    Posts
    2,717
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    145

    Default

    Do the backups exist when you go to Edit -> Preferences -> Devices -> Device Backups?

    If not, I found these steps by searching with Google that look like they can solve the problem:
    I uninstalled

    1.Apple Application support
    2.Apple mobile device support
    3.Apple software update
    4.bonjur
    5.itunes
    6.Quick time

    Then copy the contents of the Backup folder from the location

    "\Users\(username)\AppData\Roaming\Apple Computer\MobileSync\Backup\"

    to another location in my hard drive and deleted the "Apple computer" folder.

    Installed only iTunes latest version. The rest programs from above were installed by iTunes installation.

    Opened iTunes, conected my iphone, right click the device and hit backup.

    After backup finished I closed iTunes and moved the contents back to the Backup folder in

    "\Users\(username)\AppData\Roaming\Apple Computer\MobileSync\Backup\"

    opened iTunes again and under "Edit - Preferences - devices - device backups" I could see all my back ups!

    Also after I conected my iphone this time when I right click the device the "restore from back up" option was available again.

    Hope it helps..
    Liberated from thread here: https://discussions.apple.com/thread...art=0&tstart=0
    The preceding forum post has been brought to you by the letter "N" and the number 42.

    iPhone 4, 32GB (iOS 6.1.2 | evasi0n | SHSH: 4.0 - 6.1.2)
    iPad 2 3G, 64GB (iOS 6.1.2 | evasi0n
    |
    SHSH: 4.3 & 4.3.3 - 6.1)

    Restore problems? Read this: http://www.hackint0sh.org/f137/130802.htm

    Did we solve your problem? Got a dollar or two spare? Please Donate!


  5. #5
    Newbie Array

    Join Date
    Dec 2011
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Yes, backups exist as in this picture: http://i42.tinypic.com/2mwgy0y.gif "Perspective" is the one I want to restore to.

    I have Googled that and tried that method. It's not working. =(


  6. #6
    Super Moderator Array n1ckn4m3's Avatar

    Join Date
    Mar 2009
    Location
    USA
    Posts
    2,717
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    145

    Default

    Hate to say I'm stumped.. When you make a new backup while following the instructions, does the backup actually create? If so, have you tried just copying the contents of your backup to the folder that Apple creates when it makes a new backup?
    The preceding forum post has been brought to you by the letter "N" and the number 42.

    iPhone 4, 32GB (iOS 6.1.2 | evasi0n | SHSH: 4.0 - 6.1.2)
    iPad 2 3G, 64GB (iOS 6.1.2 | evasi0n
    |
    SHSH: 4.3 & 4.3.3 - 6.1)

    Restore problems? Read this: http://www.hackint0sh.org/f137/130802.htm

    Did we solve your problem? Got a dollar or two spare? Please Donate!


  7. #7
    Newbie Array

    Join Date
    Dec 2011
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Hi,

    I have exactly the same problem.. im getting mad with that. tried it many times.. e.g. with another user reinstall itunes and and and... did you already solve he problem? I hope that someone can help with that!

    thanks

    Quote Originally Posted by Seo Taiji View Post
    Updated from 4.3.5 to 5.0.1 (iPhone 4).

    This is what I see in the right click menu. No option to restore from backup. http://i43.tinypic.com/2mmuvcg.gif

    I have verified that my backups are here. http://i41.tinypic.com/14j0z0w.gif

    And under the Edit > Preferences > Devices menu... (Perspective is the backup I want to restore to. I deleted the new one iTunes tried to create.) http://i42.tinypic.com/2mwgy0y.gif

    Any help, please?

  8. #8
    Newbie Array

    Join Date
    Dec 2011
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    After the whole day of Googling and many restores later, I have found the problem and solution. The problem is (sorry, I can't be more clear as I'm not an iPhone hacker) with the new redsnow jailbreak itself. It uses a hactivation method that causes iTunes to prevent you from restoring from a backup. Here's how to fix it:

    1. Launch Cydia, add the repo http://repo.bingner.com
    2. Look for SAM and SAMprefs.
    3. Deactivate the phone to stock lockdown.
    4. Then re-activate with WildcardActivate.

    You should now be able to restore from a backup. For more info on SAM and SAMprefs, use this guide: iClarified - iPhone - How to Hactivation Your iPhone Using Subscriber Artificial Module (SAM)

  9. Thanks n1ckn4m3 thanked for this post.
    Like n1ckn4m3 liked this post.
  10. #9
    Super Moderator Array n1ckn4m3's Avatar

    Join Date
    Mar 2009
    Location
    USA
    Posts
    2,717
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    145

    Default

    Good to know. I'll let the team know in the IRC channel in case they weren't aware that the hacktivation can cause problems with people's backups. It didn't impact me because I'm on an official carrier so I was activated prior to running redsn0w (and as such, redsn0w didn't hacktivate me). Thanks again for letting us know that you figured it out and what the solution was.
    The preceding forum post has been brought to you by the letter "N" and the number 42.

    iPhone 4, 32GB (iOS 6.1.2 | evasi0n | SHSH: 4.0 - 6.1.2)
    iPad 2 3G, 64GB (iOS 6.1.2 | evasi0n
    |
    SHSH: 4.3 & 4.3.3 - 6.1)

    Restore problems? Read this: http://www.hackint0sh.org/f137/130802.htm

    Did we solve your problem? Got a dollar or two spare? Please Donate!


  11. #10
    Newbie Array

    Join Date
    Dec 2011
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default SAM ! carrier sim not supported

    //problem solved!! I forgot to check the SIM ID! // thank you Seo!!!

    Hey Seo Taiji,

    thank you for the information. I tried it, but it didn't work for me.

    SAM
    -> lockdown
    -> deactivate
    -> try to activate with itunes => ! carrier sim not supported !

    any ideas? I tried also the "manual" option with the official carrier of the phone.



    Quote Originally Posted by Seo Taiji View Post
    After the whole day of Googling and many restores later, I have found the problem and solution. The problem is (sorry, I can't be more clear as I'm not an iPhone hacker) with the new redsnow jailbreak itself. It uses a hactivation method that causes iTunes to prevent you from restoring from a backup. Here's how to fix it:

    1. Launch Cydia, add the repo http://repo.bingner.com
    2. Look for SAM and SAMprefs.
    3. Deactivate the phone to stock lockdown.
    4. Then re-activate with WildcardActivate.

    You should now be able to restore from a backup. For more info on SAM and SAMprefs, use this guide: iClarified - iPhone - How to Hactivation Your iPhone Using Subscriber Artificial Module (SAM)
    Last edited by orleans_bk; 12-29-2011 at 12:17 PM.

  12. Like n1ckn4m3 liked this post.

 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 9
    Last Post: 09-13-2013, 09:44 AM
  2. Replies: 37
    Last Post: 08-11-2008, 03:15 PM
  3. Replies: 2
    Last Post: 04-09-2008, 05:29 PM
  4. [1.1.1] How can I backup when updating to 1.1.4
    By TwistyValhalla in forum General
    Replies: 9
    Last Post: 04-08-2008, 09:08 PM
  5. Replies: 4
    Last Post: 03-18-2008, 12:40 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 07:22 PM.
twitter, follow us!