Results 1 to 3 of 3
Discuss iPhone 4 Baseband Problem at the iPhone 4 - Hackint0sh.org; Hi, I am not sure where to post this so I will post it here. ...
  1. #1
    Senior Professional Array

    Join Date
    Aug 2007
    Posts
    101
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    13

    Default iPhone 4 Baseband Problem

    Hi, I am not sure where to post this so I will post it here. As the hardware forum doesnt seem very specific nor very active.

    I have recently acquired an iPhone 4 wreck which has had its screen smashed but still rings and since it still rings, I have purchased a new screen and had it repaired. But after repairing, I get IMEI and ICCID Unknown, which I felt was very odd (It still rings prior to repair), so I had proceeded to restore the iPhone to a stock IPSW (as jailbreak and baseband update is the lowest of all concerns and it is factory unlocked anyway.)

    So it seems to me that my baseband is borked somewhere in between repair and now. Altho during restore, I do not get any errors, which I thought I should be getting if iTunes fails to write to the baseband? And I have to jailbreak to get it activated as you need a SIM to activate and it wont read a SIM.

    So I was wondering if anyone have any experience regarding this issue, I am willing to try both hardware and software remedies as this is only a spare toy, just a bonus if I do get it to work again, but right now its just a very fancy iPod Classic as there is no WiFi... everything will have to go thru USB.

    iPhoneUpdater.log here
    2011-08-23 14:45:42.296 [1092:1398]: restore library built Feb 7 2011 at 06:28: - Pastebin.com
    Hackintosh OSx86 10.6.3
    Gigabyte GA-P35-DS3P | Intel Core2Quad Q6600 @ 3.6GHz, 1333FSB
    Mushkin XP2-6400 2GB x4 (8GB) | ATI Radeon HD 4870x2 2GB (QE/CI Working @ 1920x1200x2)

    Asus G1-AK024C Notebook | 10.5.1
    Core2Duo T7200 @ 2.0GHz | Kingston DDR2 1GB x2 (2GB) | GeForce Go 7700 512MB (Working QE/CI @ 1680x1050)
    Acer Aspire 2000 | 10.4.8 / 8.8.1
    Pentium M @ 1.6GHz | Kingston DDR2 1GB x2 (2GB) | ATI Radeon Mobility 9200 (no QE/CI @ 1280x800)



  2. #2
    Senior Professional Array

    Join Date
    Aug 2007
    Posts
    101
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    13

    Default

    So... anybody? Is there a manual method of flashing the baseband that I could try?

    I mean it doesnt work now and its a spare phone... so breaking it wont hurt much more...
    Hackintosh OSx86 10.6.3
    Gigabyte GA-P35-DS3P | Intel Core2Quad Q6600 @ 3.6GHz, 1333FSB
    Mushkin XP2-6400 2GB x4 (8GB) | ATI Radeon HD 4870x2 2GB (QE/CI Working @ 1920x1200x2)

    Asus G1-AK024C Notebook | 10.5.1
    Core2Duo T7200 @ 2.0GHz | Kingston DDR2 1GB x2 (2GB) | GeForce Go 7700 512MB (Working QE/CI @ 1680x1050)
    Acer Aspire 2000 | 10.4.8 / 8.8.1
    Pentium M @ 1.6GHz | Kingston DDR2 1GB x2 (2GB) | ATI Radeon Mobility 9200 (no QE/CI @ 1280x800)

  3. #3
    Super Moderator Array n1ckn4m3's Avatar

    Join Date
    Mar 2009
    Location
    USA
    Posts
    2,717
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    145

    Default

    Since this is an iPhone4 and the baseband upgrades are SHSH locked, this may be difficult to do. If you don't mind locking the phone, you can restore to the latest iOS (but you already knew that), and that would force a re-flash of the baseband so long as the baseband on the phone was older, but there's no guarantee this will work -- you may just end up either bootlooping the phone (if it fails to flash the baseband) or on iOS 5.0.1 with a blank IMEI / MAC address.

    There's no known manual method of flashing just the baseband to the iPhone 4, none of the previous utilities work for it, FuzzyBand/etc., and likely won't unless there's an iBoot exploit found (doubtful). Since the baseband on the iPhone 4 iOS revisions requires an SHSH based on a random APticket generated every boot, you can't man-in-the-middle and upgrade the phone to an older (still unlockable) baseband. Unfortunately I think your only option would be to do a restore to 5.0.1 and have it re-flash the baseband. Even if you have SHSH for iOS 4, that will only get iOS 4 on the phone -- it won't get the baseband to flash.
    The preceding forum post has been brought to you by the letter "N" and the number 42.

    iPhone 4, 32GB (iOS 6.1.2 | evasi0n | SHSH: 4.0 - 6.1.2)
    iPad 2 3G, 64GB (iOS 6.1.2 | evasi0n
    |
    SHSH: 4.3 & 4.3.3 - 6.1)

    Restore problems? Read this: http://www.hackint0sh.org/f137/130802.htm

    Did we solve your problem? Got a dollar or two spare? Please Donate!


 

 

Similar Threads

  1. Iphone 3GS baseband problem
    By Raulpepo in forum iOS 4.x (iPhone OS 4.x)
    Replies: 1
    Last Post: 04-27-2011, 03:15 PM
  2. iPhone 3G Baseband Problem. No WiFi/IMEI/Bluetooth/ICCID/Modem Firmware
    By melodosgr in forum iOS 3.x (iPhone OS 3.x)
    Replies: 10
    Last Post: 01-01-2011, 03:56 PM
  3. iPhone's Baseband problem
    By androw in forum iPhone 3G
    Replies: 6
    Last Post: 01-31-2009, 01:06 PM
  4. Big problem with iPhone.. (had no baseband..?)
    By Crailtap25 in forum iPhone "2G" (Rev. 1)
    Replies: 0
    Last Post: 02-08-2008, 12:52 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 02:07 AM.
twitter, follow us!