Results 1 to 9 of 9
Discuss Error 1004... at the iPhone 4 - Hackint0sh.org; Hey, I am in need to a bit of assistance. Basically I got an iPhone ...
  1. #1
    Newbie Array

    Join Date
    Aug 2010
    Posts
    3
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Error 1004...

    Hey,

    I am in need to a bit of assistance. Basically I got an iPhone 4 yesterday... Came home to find the JB had been released. Jailbroke and then a little later tried to update to 4.0.1 and fix the so called Signal Bar Issue.

    That's where is all went downhill. Currently it shows a Picture with Connect to iTunes. I have tried at least 20 times to restore this iPhone on 3 different Computers... 2 Macs and a PC. All Computers have no references to Saurik's Server what so ever. I've tried DFU Mode and Restore Mode, Different USB Ports and Different Computers. 2 out of the 3 Computers have never been used for JB but I checked the Hosts file regardless and had no mention of Saurik's Server or anything apart from the default HOSTS file.

    I have also tried to use RecBoot and Umbrella to kick it out of Recovery Mode but all it brings it to is the Emergency Screen and iTunes says to contact Support or something along them lines. It does not start up the phone as suggested by other people.

    I have read around about the issue and most if not all are fixed by removing Saurik's Server from the Host File but I am 100% sure it's not there (I've moved the Host, commented out and tried all sorts of Combinations). If I issue a Ping trace on this Mac I get back the normal Apple Server:

    Code:
    ping gs.apple.com
    PING gs.apple.com.akadns.net (17.112.176.11): 56 data bytes
    64 bytes from 17.112.176.11: icmp_seq=0 ttl=233 time=636.665 ms
    64 bytes from 17.112.176.11: icmp_seq=1 ttl=233 time=261.677 ms
    64 bytes from 17.112.176.11: icmp_seq=2 ttl=233 time=228.134 ms
    ^C
    --- gs.apple.com.akadns.net ping statistics ---
    3 packets transmitted, 3 packets received, 0.0% packet loss
    round-trip min/avg/max/stddev = 228.134/375.492/636.665/185.184 ms
    Below is the last few bits of the Restore Log from the latest Restore I have just attempted to do (and failed):

    Code:
    bbupdater: -------------------------------------------------------------------------------
    bbupdater:  SENDING FLS FILE DATA:
    bbupdater: -------------------------------------------------------------------------------
    bbupdater: Loading FLS file...bbupdater: OK
    bbupdater: 
    Dynamic EEP is not in Memory Map, so don't touch it
    ...bbupdater: >> Sending Block of type CodeClass(0) from FLS file...bbupdater: 
    bbupdater: 	Sending Security Block...bbupdater: OK
    bbupdater: 	Erasing Load Area from 0x40040000 to 0x40737E5A (this will take some time)...bbupdater: OK
    bbupdater: 	Sending data for mapping 0: bbupdater: !!! bbupdater: [13.-1]::: 
    Exception at :0:
    	- BBUReturnError(1)/2: Response type is 0x41 but expected 0x804
    bbupdater: 
    bbupdater: !!! bbupdater: Exception at :0:
    	- BBUReturnError(1)/2: Response type is 0x41 but expected 0x804
    perform_ice3_baseband_update: bbupdater failed to update stack
    perform_ice3_baseband_update: bbupdater error: Exception at :0:
    	- BBUReturnError(1)/2: Response type is 0x41 but expected 0x804
    
    attempting to dump restore log
    writing log file: /mnt1/restore.log
    
    ==== end of device restore output ====
    2010-08-03 23:41:43.000 iTunes[104:111fb]: AMRAuthInstallDeletePersonalizedBundle
    2010-08-03 23:41:43.000 iTunes[104:111fb]: removed personalized bundle
    2010-08-03 23:41:43.000 iTunes[104:111fb]: <Restore Device 0x18ee1fb0>: Restore failed (result = 1004)
    2010-08-03 23:41:43.000 iTunes[104:207]: iTunes: Restore error 1004
    Thanks in advance for anyone that tries to help!
    Last edited by iMMENSE; 08-04-2010 at 12:47 AM.



  2. #2
    Rookie Array

    Join Date
    Nov 2008
    Posts
    10
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by iMMENSE View Post
    Hey,

    I am in need to a bit of assistance. Basically I got an iPhone 4 yesterday... Came home to find the JB had been released. Jailbroke and then a little later tried to update to 4.0.1 and fix the so called Signal Bar Issue.

    That's where is all went downhill. Currently it shows a Picture with Connect to iTunes. I have tried at least 20 times to restore this iPhone on 3 different Computers... 2 Macs and a PC. All Computers have no references to Saurik's Server what so ever. I've tried DFU Mode and Restore Mode, Different USB Ports and Different Computers. 2 out of the 3 Computers have never been used for JB but I checked the Hosts file regardless and had no mention of Saurik's Server or anything apart from the default HOSTS file.

    I have also tried to use RecBoot and Umbrella to kick it out of Recovery Mode but all it brings it to is the Emergency Screen and iTunes says to contact Support or something along them lines. It does not start up the phone as suggested by other people.

    I have read around about the issue and most if not all are fixed by removing Saurik's Server from the Host File but I am 100% sure it's not there (I've moved the Host, commented out and tried all sorts of Combinations). If I issue a Ping trace on this Mac I get back the normal Apple Server:

    Code:
    ping gs.apple.com
    PING gs.apple.com.akadns.net (17.112.176.11): 56 data bytes
    64 bytes from 17.112.176.11: icmp_seq=0 ttl=233 time=636.665 ms
    64 bytes from 17.112.176.11: icmp_seq=1 ttl=233 time=261.677 ms
    64 bytes from 17.112.176.11: icmp_seq=2 ttl=233 time=228.134 ms
    ^C
    --- gs.apple.com.akadns.net ping statistics ---
    3 packets transmitted, 3 packets received, 0.0% packet loss
    round-trip min/avg/max/stddev = 228.134/375.492/636.665/185.184 ms
    Below is the last few bits of the Restore Log from the latest Restore I have just attempted to do (and failed):

    Code:
    bbupdater: -------------------------------------------------------------------------------
    bbupdater:  SENDING FLS FILE DATA:
    bbupdater: -------------------------------------------------------------------------------
    bbupdater: Loading FLS file...bbupdater: OK
    bbupdater: 
    Dynamic EEP is not in Memory Map, so don't touch it
    ...bbupdater: >> Sending Block of type CodeClass(0) from FLS file...bbupdater: 
    bbupdater: 	Sending Security Block...bbupdater: OK
    bbupdater: 	Erasing Load Area from 0x40040000 to 0x40737E5A (this will take some time)...bbupdater: OK
    bbupdater: 	Sending data for mapping 0: bbupdater: !!! bbupdater: [13.-1]::: 
    Exception at :0:
    	- BBUReturnError(1)/2: Response type is 0x41 but expected 0x804
    bbupdater: 
    bbupdater: !!! bbupdater: Exception at :0:
    	- BBUReturnError(1)/2: Response type is 0x41 but expected 0x804
    perform_ice3_baseband_update: bbupdater failed to update stack
    perform_ice3_baseband_update: bbupdater error: Exception at :0:
    	- BBUReturnError(1)/2: Response type is 0x41 but expected 0x804
    
    attempting to dump restore log
    writing log file: /mnt1/restore.log
    
    ==== end of device restore output ====
    2010-08-03 23:41:43.000 iTunes[104:111fb]: AMRAuthInstallDeletePersonalizedBundle
    2010-08-03 23:41:43.000 iTunes[104:111fb]: removed personalized bundle
    2010-08-03 23:41:43.000 iTunes[104:111fb]: <Restore Device 0x18ee1fb0>: Restore failed (result = 1004)
    2010-08-03 23:41:43.000 iTunes[104:207]: iTunes: Restore error 1004
    Thanks in advance for anyone that tries to help!
    hi i have the same problem like you and i do like this
    on window/mycomputer/c/wimdows/systerm32/divers/etc/host ... open with note pad and delete all the host file.. and delete the itunes and go apple download the new itunes and there you go ...

  3. #3
    Newbie Array

    Join Date
    Aug 2010
    Posts
    3
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I've already tried to remove the HOSTS file and delete all items in it for both the Macs and the PC's. Also thought it maybe something in my Router so plugged the Ethernet wire directly but that didn't solve it either...

  4. #4
    Rookie Array

    Join Date
    Nov 2008
    Posts
    10
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by iMMENSE View Post
    I've already tried to remove the HOSTS file and delete all items in it for both the Macs and the PC's. Also thought it maybe something in my Router so plugged the Ethernet wire directly but that didn't solve it either...
    try to delete the itunes and go apple down load the new one like i did

  5. #5
    Newbie Array

    Join Date
    Aug 2010
    Posts
    3
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Just tried this and it didn't work. Reinstalled iTunes on both the Mac and the PC and both still spit out the same error message. I tried to Restore an iPod Touch 2nd Generation because if the issue was the HOSTS file then it would also spit out the same Error Message but it restored just fine. No errors what so ever and this was a complete restore with iTunes downloading the firmware...
    Last edited by iMMENSE; 08-05-2010 at 09:50 AM.


  6. #6
    The Man Array aviegas's Avatar

    Join Date
    Sep 2007
    Posts
    1,108
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    73

    Default

    The restore is ok but the phone is left in recovery mode.

    Nothing that a good old:

    setenv auto-boot true
    saveenv
    reboot

    from a rslite session will not cure.

    (do a little googling and it's easy to find out how to get out of "recovery mode").

  7. #7
    Rookie Array

    Join Date
    Nov 2008
    Posts
    10
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by aviegas View Post
    The restore is ok but the phone is left in recovery mode.

    Nothing that a good old:

    setenv auto-boot true
    saveenv
    reboot

    from a rslite session will not cure.

    (do a little googling and it's easy to find out how to get out of "recovery mode").
    how to get out recovery mode is hold both power and home and count 1 to 10 second and release both hand and you get out recovery mode ..

  8. #8
    Newbie Array

    Join Date
    Sep 2009
    Posts
    6
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Download RecBoot V1.1 and follow the instructions

  9. #9
    Administrator Array

    Join Date
    Oct 2007
    Posts
    4,145
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    download firmware umbrella ... It is a must have for everyone with iphone 3g, 3gs, iphone4, ipad, itouch2g (mc), itouch 3g.

    connect device and click on "kick device out of recovery"
    ** If you just want to support hackint0sh.org with a donation click here **

 

 

Similar Threads

  1. Appp Store 1004 error
    By baro in forum iPhone 3GS
    Replies: 12
    Last Post: 10-27-2011, 03:37 PM
  2. HELP: iPhone 4 stuck in DFU mode, error 1004
    By playtime44 in forum iOS 4.x (iPhone OS 4.x)
    Replies: 64
    Last Post: 03-13-2011, 07:32 AM
  3. HP Pavilion 1004-EL
    By albertuccio in forum Distributions
    Replies: 1
    Last Post: 05-28-2009, 05:44 PM
  4. Replies: 2
    Last Post: 11-08-2008, 10:53 PM
  5. Replies: 1
    Last Post: 07-19-2008, 10:54 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 06:32 AM.
twitter, follow us!