Page 1 of 2 12 LastLast
Results 1 to 10 of 17
Discuss Update issue at the iPhone 3GS - Hackint0sh.org; guys i got iphone 3gs 32 gb its version is 3.1.2 and its baseband is ...
  1. #1
    Rookie Array

    Join Date
    Mar 2011
    Posts
    24
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Lightbulb Update issue

    guys i got iphone 3gs 32 gb its version is 3.1.2 and its baseband is 4.26.08 the issue is that i can`t update it to new version of 4.2.1 i got the 3194 error i edited my hosts file windows now i get the error that apple update server is down something like that


    so how can i update my version cause this version is causing troubles and cydia crashes again and again i want my phone to be fixed and tidy

    please help



  2. #2
    Moderator Array

    Join Date
    Aug 2007
    Posts
    781
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    51

    Default

    Wait just a bit more (like a few hours) and a new version of PwnageTool will be available, then you make a custom 4.3.1 IPSW without baseband update, enter DFU mode and restore on iTunes.
    Watch blog.iphone-dev.org that's where they'll release the new version.

    In the mean time, download the original firmware here: http://appldnld.apple.com/iPhone4/04...4_Restore.ipsw
    Last edited by element; 04-04-2011 at 01:43 AM.

  3. #3
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    If you rely on unlock.. WAIT a day or two as ultrasn0w doesn't yet work properly on 4.3.1

    WARNING WARNING — ultrasn0w users don’t update yet! We need to first release an update to ultrasn0w that fixes some incompatibilities when FW 4.3.1 is used on the older basebands supported by ultrasn0w. And remember once we do fix ultrasn0w for 4.3.1 (we’ll announce it here and on twitter), you must only get there via a custom IPSW from PwnageTool, Sn0wbreeze or xpwn! Don’t ever try to restore or update to a stock IPSW, or you’ll lose the unlock!
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  4. #4
    Senior Professional Array

    Join Date
    Nov 2007
    Posts
    107
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    12

    Default

    is it possible to update a 3.1.2 new bootrom, jaibroken using jailbreakme.com, relaying on unlock and without any SHSH?
    it shouldn't be possible to use custom FM afaik, am I correct?

  5. #5
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by baro View Post
    is it possible to update a 3.1.2 new bootrom, jaibroken using jailbreakme.com, relaying on unlock and without any SHSH?
    it shouldn't be possible to use custom FM afaik, am I correct?
    Yes, custom IPSW will prevent baseband update

    But ultrasn0w doesn't work yet (with any baseband version) on 4.3.1 - changes in the security model of 4.3.x have broken the loader part of ultrasn0w.

    An unofficial solution is available, the official ultrasn0w update is in testing (likely will be released in the next few days) and will support unlocking the same baseband versions that could be unlocked earlier. (The new update will NOT add support for 5.16.00, 5.15.04, 5.14.02 basebands)

    That is why I said wait.
    Last edited by Olethros; 04-04-2011 at 01:18 PM.
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!


  6. #6
    Senior Professional Array

    Join Date
    Nov 2007
    Posts
    107
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    12

    Default

    sorry if I ask you the same question again as it isn't really clear to me: given that ultrasn0w has got some issues atm, can I apply custom firmwares on a user land jailbroken device (jailbreakme.com) with new bootrom?

  7. #7
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    The original poster in the thread you have replied to asked for advice with restoring iOS 4.2.1 so the answer I gave was based on that.

    You need to be more specific about what iOS version the custom IPSW is for.
    Also you should specify what device you are talking about.

    Except for the iPad 2 (which has only been jailbroken in userland)

    Loading Custom IPSW from a userland jailbroken device (generally) requires the following:
    1. You can enter DFU mode (home+power buttons work and the dock connector interface is functioning)
    2. You send the correct exploit for your device to put your iPhone into a pwned DFU mode. (there are at least 5 different exploits, depending on what model device you have) - currently only the iPad 2 lacks a bootrom level exploit.
    3. If your device verifies SHSH in hardware (3GS and newer) then you must have a SHSH for the iOS version you are restoring.


    There are of course exceptions to the three rules above - one that often confuses people:
    Old Bootrom 3GS - as long as you have access to a device specific SHSH for iOS 3.1.2 or lower, you can patch out the hardware checks for SHSH (this needs to be done both in the new custom IPSW and also in the current NOR images flashed to the device). The disadvantage of this is that it requires a lot more reversing and patching than the limera1n + unpatched bootchain + kernel untether solution used in Pwnagetool 4.1 and higher.

    So while possible, it's not very common any more. It's mostly useful for cheapskates who have broken power or home buttons and don't want to get them repaired.

    Old bootrom 3GS - userland jailbroken without SHSH
    It's possible to go from userland jailbroken to a pwned NOR, but this requires a specific tool (customised for your iOS version and the type of userland jailbreak), only one such tool was released - spirit2pwn - this was a "one shot" type tool, if it didn't work - you had no choice but to restore.
    I've never heard of a jailbreakme2pwn tool, it's possible one could be created.
    Last edited by Olethros; 04-04-2011 at 03:54 PM.
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  8. #8
    Senior Professional Array

    Join Date
    Nov 2007
    Posts
    107
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    12

    Default

    I've got an iPhone 3GS 3.1.2, jailbroken with jailbreakme.com, new bootrom, relying on unlock, no SHSH's saved, and I'm willing to upgrade it to the latest iOS (rather than 4.2.1 as the original poster).
    While wating for the 4.3.1 compatible ultrasn0w, I was warried not to being even able to use a custom FW (and thus avoid bb upgrade) as I've never heard about a jailbreakme2pwn (or something) tool either.
    BUT, according to point 3 of your list, restoring to the LATEST fw (no problem with SHSH then) looks like a possible task (given that I meet point 1 and point 2)
    no need to care about user land then, if I get it right

    a bit off topic sorry, but hopefully these are useful info also for the original poster
    Last edited by baro; 04-04-2011 at 03:35 PM.

  9. #9
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by baro View Post
    BUT, according to point 3 of your list, restoring to the LATEST fw (no problem with SHSH then) looks like a possible task (given that I meet point 1 and point 2)
    no need to care about user land then, if I get it right

    a bit off topic sorry, but hopefully these are useful info also for the original poster
    It's actually pretty much on topic, so I won't move it.

    Point 3 will always be true for the latest/last IOS version for your device (well as long as Apple is still around as a company)

    Also note that I said nothing about "untethered", these requirements are really just to be able to restore a custom IPSW, depending on how "custom" the IPSW is, you may require a way to untether the jailbreak or boot tethered after the restore is complete.
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  10. #10
    Rookie Array

    Join Date
    Mar 2011
    Posts
    24
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    well i checked on the blog for windows "redsn0w 0.9.6rc9" i guess that is for 4.3.1 so i have to load the original firmware and make a custom out of that and have to look to prevent the base band so whats next my baseband is 4.26.08 so what next would i have to do.


    so for now i have redsn0w 0.9.6rc9 and original firmware 4.3.1 itunes what more do i need to update my version from 3.1.2 and jailbreak and unlock
    Last edited by d00m; 04-05-2011 at 12:26 AM.


 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. Will pay $$$ for help with keyboard & mouse - 10.6.5 update issue
    By humpdaymusic in forum Kernel / Kext (Driver) Support
    Replies: 0
    Last Post: 12-13-2010, 05:26 PM
  2. iDeneb Update Issue
    By doctorbagr in forum Installation
    Replies: 1
    Last Post: 10-07-2009, 08:05 PM
  3. iATKOS v5i after update issue
    By Laddu in forum Installation
    Replies: 0
    Last Post: 05-31-2009, 01:21 PM
  4. Replies: 2
    Last Post: 05-25-2008, 12:22 AM
  5. Firmware update issue from 1.0.2 to 1.1.1 NEED HELP!!
    By AleisterCrowley in forum General
    Replies: 6
    Last Post: 11-09-2007, 02:16 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 09:41 AM.
twitter, follow us!