Results 1 to 9 of 9
Discuss ssh in only when browsing at the iPhone 3GS - Hackint0sh.org; Hi, I am a total rookie for iphone. I have 3GS with 3.1.2 and blackra1n ...
  1. #1
    Newbie Array

    Join Date
    Nov 2009
    Posts
    5
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default ssh in only when browsing

    Hi, I am a total rookie for iphone. I have 3GS with 3.1.2 and blackra1n and I am trying to SSH into the phone but having connection problems. I start just by trying to ping the phone from my PC and I get timeouts until I start browsing the internet from the iphone. It's like there is a firewall on the iphone which only opens when the iphone tries to connect. I finally got shh and SCP working but only if on the iphone I keep refreshing a webpage. I was thinking what if I did a continuous ping command from the terminal app on the iphone but I cannot find the ping command within terminal. I thought maybe there was a ping app on cydia but I cannot find one.

    Please advise if you know what the trouble is.

    Thanks!



  2. #2
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    WiFi drops when the iPhone turns off the display (this is a power saving thing) which also causes your SSH session to hang/time out

    This can be prevented by having your iPhone plugged in to power (either usb charger or usb port on a computer that is running)

    Are you talking about something more than this?
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  3. #3
    Newbie Array

    Join Date
    Nov 2009
    Posts
    5
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Hi, I wondered about some sort of battery saving feature but I get the same results whether I'm plugged in or not. I just repeated my test: pings continuously die until I start surfing, and as soon as the web page is fully loaded in Safari on the iPhone, the pings die again.

    Quote Originally Posted by Olethros View Post
    WiFi drops when the iPhone turns off the display (this is a power saving thing) which also causes your SSH session to hang/time out

    This can be prevented by having your iPhone plugged in to power (either usb charger or usb port on a computer that is running)

    Are you talking about something more than this?

  4. #4
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Try a reset network settings on the iPhone
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  5. #5
    Rookie Array micked's Avatar

    Join Date
    Jun 2009
    Posts
    21
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default -

    had similar problems on my 3gs, if your using winscp try to reset the program.

    in winscp hit the Tools... button / Clean up... / Check all, and hit ok.
    reboot your phone and try to connect again. (also restart winscp)

    hope this works for you.


    /micke


  6. #6
    Newbie Array

    Join Date
    Nov 2009
    Posts
    5
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by Olethros View Post
    Try a reset network settings on the iPhone
    I have done that a few times with no change: even plugged into the power and sitting right next to the wifi router I only get ping replies when the iPhone is surfing.

    Thanks for trying to help!

    Bob

  7. #7
    Newbie Array

    Join Date
    Nov 2009
    Posts
    5
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by micked View Post
    had similar problems on my 3gs, if your using winscp try to reset the program.

    in winscp hit the Tools... button / Clean up... / Check all, and hit ok.
    reboot your phone and try to connect again. (also restart winscp)

    hope this works for you.


    /micke
    as I am so green I would like to know if for sure I should see better ping response before I even try apps. I am schooled in networking and my instincts tell me there is something in the iPhone (at least in this version?) which shuts down its network interface to incoming packets as soon as it receives the last expected packet from a http request. This is similar to how a hardware firewall like a Cisco ASA works.

  8. #8
    Administrator Array

    Join Date
    Oct 2007
    Posts
    4,145
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    As long as the phone is not in powersave mode (autolock on) then it should response to a ping request. The OS in iphone does not block icmp request.
    FWIW, i never see the problem like you described.
    ** If you just want to support hackint0sh.org with a donation click here **

  9. #9
    Rookie Array micked's Avatar

    Join Date
    Jun 2009
    Posts
    21
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default -

    @ littleroot

    did you come to any conclusion on this ssh problem?

    I do have the same problem om my phone, it works one day but not the other.
    today it didnt connect and I tryed to ping the phone from the cmd-console but no respons, then I rememberd I have a ping funktion in my router (dlink di524) and pinged the phone from there and it pinged Successfully so I think it is something to to with the router, Il investigate further.


    /micked


    ps

    I have had 3 iphones, first 2g iphone and one 3g iphone and now a 3gs and its only on this I have had any problem.

    ds
    Last edited by micked; 11-19-2009 at 07:50 PM.

 

 

Similar Threads

  1. Network Browsing fixed
    By walterh in forum Genuine Mac Support
    Replies: 1
    Last Post: 08-06-2009, 12:19 AM
  2. Browsing filesystem on 2.1
    By Rooster212 in forum iPhone 3G
    Replies: 3
    Last Post: 09-27-2008, 11:44 PM
  3. I keep on getting error 302 when browsing on 3g
    By asma123 in forum iPhone 3G
    Replies: 2
    Last Post: 08-09-2008, 02:12 AM
  4. Rogers web browsing
    By daviddvdd in forum General
    Replies: 7
    Last Post: 03-01-2008, 06:33 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 09:53 AM.
twitter, follow us!