Results 1 to 7 of 7
Discuss iPhone 3GS cannot restore to 5.0.1 at the iPhone 3GS - Hackint0sh.org; Hi, Got an iPhone 3GS with new bootrom. Currently in DFU loop (tiny umbrella shows ...
  1. #1
    Newbie Array

    Join Date
    Feb 2012
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default iPhone 3GS cannot restore to 5.0.1

    Hi,

    Got an iPhone 3GS with new bootrom. Currently in DFU loop (tiny umbrella shows DFU device connected when connecting the phone), don't know the current firmware or baseband. Checked for saved SHSH by manually entering ECID, found out that it has SHSH for 4.1 and 5.0.1.
    Tried restoring to ios 5.0.1 but I keep getting error 21. Here is the log: http://pastebin.com/tXkSC5Eq

    Can anyone help me with this please?

    UPDATE: Ran SHSH blob dump with iFaith, found out that the iOS version is 3.1.3, but failed to dump SHSH blobs.
    Last edited by myrat; 02-14-2012 at 10:19 AM. Reason: UP



  2. #2
    Super Moderator Array n1ckn4m3's Avatar

    Join Date
    Mar 2009
    Location
    USA
    Posts
    2,717
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    145

    Default

    Remove gs.apple.com from your hosts file. This is 99.95% the cause of Error 21 when restoring iOS 5.0.1. You do not need SHSH on file for iOS 5.0.1, and attempting to use them (or pointing to gs.apple.com from your hosts file) breaks restoring for iOS 5.0+
    The preceding forum post has been brought to you by the letter "N" and the number 42.

    iPhone 4, 32GB (iOS 6.1.2 | evasi0n | SHSH: 4.0 - 6.1.2)
    iPad 2 3G, 64GB (iOS 6.1.2 | evasi0n
    |
    SHSH: 4.3 & 4.3.3 - 6.1)

    Restore problems? Read this: http://www.hackint0sh.org/f137/130802.htm

    Did we solve your problem? Got a dollar or two spare? Please Donate!


  3. #3
    Newbie Array

    Join Date
    Feb 2012
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Cleared out the hosts file and tried restoring again, this time it gives error 1600. I read that the error is given when you are trying to upload custom ipsw but this one is 5.0.1 stock firmware downloaded from apple.

  4. #4
    Super Moderator Array n1ckn4m3's Avatar

    Join Date
    Mar 2009
    Location
    USA
    Posts
    2,717
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    145

    Default

    Error 1600 really is reserved for when you're attempting to flash either a custom firmware with no baseband or a custom jailbroken firmware to a device, and the device is not in DFU / Pwned DFU mode. Alternately, you can get this when you need to be restoring in DFU mode but are restoring in standard or recovery mode.

    If the phone is bootlooped now (I think it is based on your first post), put it into DFU mode (not Pwned DFU mode UNLESS you're blocking a baseband update with PwnageTool/redsn0w by removing it from the .IPSW) and attempt the restore again.
    The preceding forum post has been brought to you by the letter "N" and the number 42.

    iPhone 4, 32GB (iOS 6.1.2 | evasi0n | SHSH: 4.0 - 6.1.2)
    iPad 2 3G, 64GB (iOS 6.1.2 | evasi0n
    |
    SHSH: 4.3 & 4.3.3 - 6.1)

    Restore problems? Read this: http://www.hackint0sh.org/f137/130802.htm

    Did we solve your problem? Got a dollar or two spare? Please Donate!


  5. #5
    Newbie Array

    Join Date
    Feb 2012
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Still getting the error 21, posting the log again. 3GS_error_21_log - Pastebin.com


  6. #6
    Super Moderator Array n1ckn4m3's Avatar

    Join Date
    Mar 2009
    Location
    USA
    Posts
    2,717
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    145

    Default

    Any reason you're using iTunes 10.5.2 and not 10.5.3? It shouldn't be causing your error but I always recommend using the latest version. Beyond that, I hate to say the log is not providing me any indication as to what the issue is. I can only really point to the error (21), and that, as previously mentioned, usually happens only if you're using a custom firmware and not restoring in Pwned DFU mode, or you are trying to restore 5.x with gs.apple.com in your hosts file.... If you're in Pwned DFU mode while attempting to restore AND you've cleaned any reference to gs.apple.com out, then I can't think of any reason it shouldn't work...
    The preceding forum post has been brought to you by the letter "N" and the number 42.

    iPhone 4, 32GB (iOS 6.1.2 | evasi0n | SHSH: 4.0 - 6.1.2)
    iPad 2 3G, 64GB (iOS 6.1.2 | evasi0n
    |
    SHSH: 4.3 & 4.3.3 - 6.1)

    Restore problems? Read this: http://www.hackint0sh.org/f137/130802.htm

    Did we solve your problem? Got a dollar or two spare? Please Donate!


  7. #7
    Newbie Array

    Join Date
    Feb 2012
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Yeah, it was 10.5.2, upgraded to 10.5.3 still no luck. I guess this one is bricked. Still thanks for trying to help.

  8. Thanks Eliet thanked for this post.
 

 

Similar Threads

  1. Replies: 11
    Last Post: 10-27-2010, 11:45 PM
  2. Replies: 8
    Last Post: 10-20-2009, 04:30 PM
  3. [Problem][Restore Mode] iPhone wont restore
    By ipicazo08 in forum General
    Replies: 7
    Last Post: 05-08-2008, 01:17 AM
  4. Replies: 7
    Last Post: 08-30-2007, 09:58 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 03:30 PM.
twitter, follow us!