Results 1 to 4 of 4
Discuss Can someone help me jailbreak my 3gs with old 3.1 os? at the iPhone 3GS - Hackint0sh.org; Hello, I need help jailbreaking my iPhone. I'm still using 3.1 (7C144) os modem firmware ...
  1. #1
    Newbie Array

    Join Date
    Aug 2010
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Can someone help me jailbreak my 3gs with old 3.1 os?

    Hello, I need help jailbreaking my iPhone. I'm still using 3.1 (7C144) os modem firmware 5.11.07 and from what I can tell I need to have 4.0 on to jailbreak?, but from what I've read I shouldn't update unless I've already jailbroke my phone. I was wondering if somebody could help me with a step by step process on how I would go about jailbreaking my phone since I have the older os. I'm using a pc so I would need pc software. Thanks a million in advance, I really appreciate it!



  2. #2
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by Jessman View Post
    Hello, I need help jailbreaking my iPhone. I'm still using 3.1 (7C144) os modem firmware 5.11.07 and from what I can tell I need to have 4.0 on to jailbreak?, but from what I've read I shouldn't update unless I've already jailbroke my phone. I was wondering if somebody could help me with a step by step process on how I would go about jailbreaking my phone since I have the older os. I'm using a pc so I would need pc software. Thanks a million in advance, I really appreciate it!
    Okay - you have a few options.

    Risk factor - you cannot restore to iOS 3.x if you screw things up on your iPhone after jailbreak. This is because you don't have a cached SHSH for any version below iOS 4.0.1 - read up on SHSH - you should have been caching them from the day you got your iPhone - just in case you ever wanted to downgrade or reload your OS. Even if you never jailbroke.

    It is important to find out of you have old or new bootrom.
    See PwnageTool 3.1.4 for Mac OS X

    iBoot-359.3.2 is new bootrom
    iBoot-359.3 is old bootrom

    If you have old bootrom and want to stay at 3.1 - your best option is blackra1n (as much as I hate to recommend it)
    iClarified - iPhone - How to Jailbreak Your iPhone, iPod Using BlackRa1n [Windows]
    Do not install Rock, do not install Sn0w.

    If you have new bootrom - your best option is to restore to 4.0.1 and use new jailbreakme web based jailbreak - see http://www.hackint0sh.org/f247/155146.htm for details.
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  3. #3
    Newbie Array

    Join Date
    Aug 2010
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I'm still trying to figure out whether I can jailbreak & unlock my iPhone 3GS, because there is conflicting info about what will work and what will cause irreversible loss of future chance at jailbreak/unlock. Here's my situation:

    I got a free iPhone 3GS from my mother-in-law. Somewhere along the line she updated to OS 3.1 (NOT 3.1.2 or 3.1.3, just 3.1). Not surprisingly, she did not cache her certificates/EICD etc anywhere, so there's no going back to 3.0 for me, as far as I can tell. And it looks like if I update via iTunes I'll end up with 4.0.2, which currently has no jailbreak or unlock available.

    The previous post on this thread says I can jailbreak with blackra1n if I have the old boot loader version, but blackra1n info says it won't work if I have the "new" (5.11) baseband. Does anybody know if I have any options with my current setup:

    iPhone 3GS, OS 3.1
    Baseband 5.11.07 - 6.4_M352
    Bootloader[iBoot-359.3]

    Thanks for any time & info you've got.

  4. #4
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by plod View Post
    I got a free iPhone 3GS from my mother-in-law. Somewhere along the line she updated to OS 3.1 (NOT 3.1.2 or 3.1.3, just 3.1). Not surprisingly, she did not cache her certificates/EICD etc anywhere, so there's no going back to 3.0 for me, as far as I can tell. And it looks like if I update via iTunes I'll end up with 4.0.2, which currently has no jailbreak or unlock available.

    The previous post on this thread says I can jailbreak with blackra1n if I have the old boot loader version, but blackra1n info says it won't work if I have the "new" (5.11) baseband. Does anybody know if I have any options with my current setup:

    iPhone 3GS, OS 3.1
    Baseband 5.11.07 - 6.4_M352
    Bootloader[iBoot-359.3]
    You have old bootrom - which is good news.

    Best option:
    jailbreak/pwn with blackra1n
    Restore with custom IPSW from pwnagetool 3.1.3 (iOS 3.1), pwnagetool 3.1.4 (iOS 3.1.2), pwnagetool 3.1.5 (iOS 3.1.3)

    That will get you on the pwnagetrain which is where you need to stay.
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

 

 

Similar Threads

  1. Replies: 1
    Last Post: 01-28-2011, 11:15 AM
  2. Replies: 2
    Last Post: 04-09-2008, 03:20 PM
  3. [Jailbreak 1.1.2] OktoPrep not recognised when running Jailbreak.jar
    By sheikhworld in forum iPhone "2G" (Rev. 1)
    Replies: 38
    Last Post: 02-19-2008, 05:08 PM
  4. Replies: 14
    Last Post: 02-16-2008, 01:11 PM
  5. [1.1.3][jailbreak] is dev team also working on true jailbreak?
    By hangsun2 in forum iPhone "2G" (Rev. 1)
    Replies: 1
    Last Post: 02-05-2008, 05:36 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 01:46 AM.
twitter, follow us!