Page 1 of 2 12 LastLast
Results 1 to 10 of 13
Discuss Appp Store 1004 error at the iPhone 3GS - Hackint0sh.org; It's a couple of day I've been experiencing a weird error: when I try to ...
  1. #1
    Senior Professional Array

    Join Date
    Nov 2007
    Posts
    107
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    12

    Default Appp Store 1004 error

    It's a couple of day I've been experiencing a weird error: when I try to download apps from App Store it all goes as usual, untill I click on "install" then for some reasons I keep getting "error 1004 try again later"
    I've been trying several fix like clear safari cache, logout/login again from appstore, restore network but nothing worked.
    And one more thing: Ebay app is also complaining about network issue (all other apps tested so far seems connecting with no problems)
    What could be wrong? Is there an hosts file or something on the phone?



  2. #2
    Super Moderator Array n1ckn4m3's Avatar

    Join Date
    Mar 2009
    Location
    USA
    Posts
    2,717
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    145

    Default

    Usually 1004 is related to network issues, and if the ebay app is also complaining about network issues, you may want to check to ensure that everything is correct from that perspective. Are you running an unlocked device on a non-standard network? Do you require any APN editing in order for it to function normally? Have you installed anything that may patch your CommCenter like TetherMe or MyWi?

    Let us know... You've already tried the most common solutions (apple store sign out/sign in & reset network settings), so I really do think the ebay issue you're having is also related.
    The preceding forum post has been brought to you by the letter "N" and the number 42.

    iPhone 4, 32GB (iOS 6.1.2 | evasi0n | SHSH: 4.0 - 6.1.2)
    iPad 2 3G, 64GB (iOS 6.1.2 | evasi0n
    |
    SHSH: 4.3 & 4.3.3 - 6.1)

    Restore problems? Read this: http://www.hackint0sh.org/f137/130802.htm

    Did we solve your problem? Got a dollar or two spare? Please Donate!


  3. #3
    Senior Professional Array

    Join Date
    Nov 2007
    Posts
    107
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    12

    Default

    it is indeed an unlocked device on a non-standard network, 3GS oldboot running 4.3.3 with modem firmware 05.11.07 on Vodafone IT

    the network issue seems very likely but, given that, why safari mail cydia and the most frequently used apps arent' complaining at all? that is a bit confusing and doesn't help narrowing down the issue :\

    oh, and it can't be a Vodafone problem as the error is showing up also using wifi...
    Last edited by baro; 10-24-2011 at 07:19 PM.

  4. #4
    Super Moderator Array n1ckn4m3's Avatar

    Join Date
    Mar 2009
    Location
    USA
    Posts
    2,717
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    145

    Default

    Yeah it's hard for me to explain or understand why some things would be working but others would be complaining about network issues -- but I do think they're related. Can you trace this back to any change you could have made relating to the device in the recent past?
    The preceding forum post has been brought to you by the letter "N" and the number 42.

    iPhone 4, 32GB (iOS 6.1.2 | evasi0n | SHSH: 4.0 - 6.1.2)
    iPad 2 3G, 64GB (iOS 6.1.2 | evasi0n
    |
    SHSH: 4.3 & 4.3.3 - 6.1)

    Restore problems? Read this: http://www.hackint0sh.org/f137/130802.htm

    Did we solve your problem? Got a dollar or two spare? Please Donate!


  5. #5
    Senior Professional Array

    Join Date
    Nov 2007
    Posts
    107
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    12

    Default

    I can't think on anything more than the latest Cydia updates... (error 1004 also in safemode, if it is of any help)


  6. #6
    Senior Professional Array

    Join Date
    Nov 2007
    Posts
    107
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    12

    Default

    forgot to say that MyWI is installed

  7. #7
    Senior Professional Array

    Join Date
    Nov 2007
    Posts
    107
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    12

    Default

    and CommCenter is patched indeed.... time to upgrade to iOS5?

  8. #8
    Senior Professional Array

    Join Date
    Nov 2007
    Posts
    107
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    12

    Default

    uh oh... my girlfriend's 2G (unlocked) is showing the very same 1004 error.... wtf.....

  9. #9
    Super Moderator Array n1ckn4m3's Avatar

    Join Date
    Mar 2009
    Location
    USA
    Posts
    2,717
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    145

    Default

    Are you connected to your home's wifi? Have you rebooted your router or access point recently? It's very coincidental that two devices would start exhibiting the same problems at the same time...
    The preceding forum post has been brought to you by the letter "N" and the number 42.

    iPhone 4, 32GB (iOS 6.1.2 | evasi0n | SHSH: 4.0 - 6.1.2)
    iPad 2 3G, 64GB (iOS 6.1.2 | evasi0n
    |
    SHSH: 4.3 & 4.3.3 - 6.1)

    Restore problems? Read this: http://www.hackint0sh.org/f137/130802.htm

    Did we solve your problem? Got a dollar or two spare? Please Donate!


  10. #10
    Senior Professional Array

    Join Date
    Nov 2007
    Posts
    107
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    12

    Default

    she's @home and I am @work.... do I need to call an exorcist??


 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. HELP: iPhone 4 stuck in DFU mode, error 1004
    By playtime44 in forum iOS 4.x (iPhone OS 4.x)
    Replies: 64
    Last Post: 03-13-2011, 07:32 AM
  2. Error 1004...
    By iMMENSE in forum iPhone 4
    Replies: 8
    Last Post: 08-13-2010, 02:19 AM
  3. HP Pavilion 1004-EL
    By albertuccio in forum Distributions
    Replies: 1
    Last Post: 05-28-2009, 05:44 PM
  4. ipod touch (app store, itunes store) error
    By colton in forum iPod Touch 1G
    Replies: 0
    Last Post: 02-01-2009, 05:15 AM
  5. Replies: 2
    Last Post: 11-08-2008, 10:53 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 10:39 AM.
twitter, follow us!